Welcome to the North American Subaru Impreza Owners Club Thursday October 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-28-2012, 02:04 PM   #1
Mr.BlackNorris
Scooby Newbie
 
Member#: 281422
Join Date: Apr 2011
Chapter/Region: MWSOC
Location: Detroit, Michigan
Vehicle:
2004 wrx
red

Default P1491;P0442 Help????

I'm not sure if this is the right forum for this but I need some help. I keep getting a check engine light and my accessport pulls up the same codes after clearing them twice. P1491 (positive crankcase ventilation) and P0442 (Evap emission control system leak: small leak)

I have a 2004 wrx w/ custom tune via cobb accessport.

Mods:
2.5l block (balanced & blueprinted), 2.0l heads (Quenched to Sti specs)
cp 99.5mm pistons
Manley H beam rods
ACL race main & rod bearings
2008 sti crankshaft
cosworth head studs
cosworth head gaskets
Killer B oil pickup & baffle
Subaru OE gasket set
Grimmspeed TGV deletes
Perrin big MAF intake
Samco turbo inlet air hose
Deadbolt SZ 49 (20g) turbo
Invidia V2 downpipe
Trust up pipe
Stromung 3" turbo back exhaust
HKS electronic boost sylenoid
RC 850 injectors (stock fuel rail/FPR)
Turbo XS fmic w/ Tial qr recirc valve w/ 11lb spring
Full Sti drivetrain swap

The P1491 code has popped up several times by itself w/ no other codes, my tuner has turned this code off but for some reason it keeps coming back. My tuner has spoke w/ Cobb numerous times and they cant figure out why the code keeps coming back. I'm concerned about the P0442 code It first popped up 2 days ago I cleared it filled my gas tank and the code came back yesterday. I checked the O ring around my gas cap and it's fine and I can't figure out where the problem (P0442) is coming from. Can anybody help me diagnose this?
* Registered users of the site do not see these ads.
Mr.BlackNorris is offline   Reply With Quote
Old 03-31-2012, 09:51 PM   #2
ran2
Scooby Newbie
 
Member#: 172643
Join Date: Feb 2008
Chapter/Region: MWSOC
Location: Northern Illinois
Vehicle:
2002 WRXWgn & Legacy
Blue/Green

Default

I am chasing a P0442 on my bone stock 03 Legacy.
I will subscribe to your thread and post back if I can
figure out what is up with my car.
ran2 is offline   Reply With Quote
Old 03-31-2012, 10:43 PM   #3
REDrexsti
Scooby Newbie
 
Member#: 283553
Join Date: May 2011
Location: Fort Dodge
Vehicle:
2004 wrx
jbp

Default

P0442 can be a lot of things. Some have had luck with replacing the gas cap, others the Fuel pump assembly gasket...it really could be anywhere from the gas tank to the charcoal canister and then all the way back up to the engine. Check for any cracked/brittle/broken/etc... rubber lines in the system. This code is such a pia.
REDrexsti is offline   Reply With Quote
Old 03-31-2012, 10:52 PM   #4
MattTHEpainter
Scooby Specialist
 
Member#: 284046
Join Date: May 2011
Chapter/Region: NESIC
Location: CT
Vehicle:
2000 Impreza w/ WRX

Default

For the positive crankcase code; do you have the pcv sensor connected to your new turbo inlet?
MattTHEpainter is offline   Reply With Quote
Old 04-15-2012, 11:03 AM   #5
ran2
Scooby Newbie
 
Member#: 172643
Join Date: Feb 2008
Chapter/Region: MWSOC
Location: Northern Illinois
Vehicle:
2002 WRXWgn & Legacy
Blue/Green

Default

I reset the codes on my car and the error has not come back yet.
I'm with REDrexsti...the code is a PIA.
ran2 is offline   Reply With Quote
Old 04-15-2012, 07:00 PM   #6
jakechup
Scooby Newbie
 
Member#: 280793
Join Date: Apr 2011
Chapter/Region: MWSOC
Location: Clarkston, MI
Vehicle:
02 WRX Wagon
WRB

Default

I got a P0442, too. trying to figure it out. Such a PIA.
jakechup is offline   Reply With Quote
Old 04-17-2012, 02:22 PM   #7
fabiosugitani
Scooby Newbie
 
Member#: 285398
Join Date: Jun 2011
Chapter/Region: South East
Location: Cornelius, NC
Vehicle:
2010 2.5i Premium WG
Spark Silver Metallic

Default

same P0442 here... smoke test could't find anything but little bit of gas smell around the gas tank. The dealership suggested one of the sensors above the gas tank could be cracked.
I'll post any updates...
fabiosugitani is offline   Reply With Quote
Old 04-26-2012, 05:24 PM   #8
fabiosugitani
Scooby Newbie
 
Member#: 285398
Join Date: Jun 2011
Chapter/Region: South East
Location: Cornelius, NC
Vehicle:
2010 2.5i Premium WG
Spark Silver Metallic

Default

Here's my problem:
It wasn't broke like in the picture, but it was cracked so bad you can see the brown spot around the tube, so when I touched to release the clamp, it broke.


This is how supposed to look like

Last edited by fabiosugitani; 04-27-2012 at 08:41 AM.
fabiosugitani is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
04 WRX misfire/stutter help! JRosado Newbies & FAQs 6 07-19-2013 05:09 PM
Yet another help me pick a car thread... ganzhimself Off-Topic 78 04-01-2012 12:50 PM
Need some help! Mitchyy Tri-State Area Forum 6 03-29-2012 08:53 AM
Help me with a cheap suspension solution. nicksamba_18 Brakes, Steering & Suspension 3 03-28-2012 05:57 PM
I'm doing a project on subaru and I need some help! mitchell02wrx Off-Topic 16 03-28-2012 10:58 AM


All times are GMT -4. The time now is 01:22 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.