Welcome to the North American Subaru Impreza Owners Club Saturday October 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-30-2012, 04:44 PM   #1
74novaman
Scooby Newbie
 
Member#: 315175
Join Date: Mar 2012
Default 97 Impreza a/c help

Hey guys, nice forum. I'm more of an old muscle car guy (thus the screen name) but my wife's daily driver is a 97 Subaru Impreza with the 2.2L n/a motor. Been a nice, reliable car.

Last winter, the A/C compressor died, which as yall know, is not acceptable in a DD in Texas during the summer.

I went ahead and got the a/c parts replaced, got the system flushed and buttoned back up, and the car is blowing cool!

With one slight problem: It is only blowing cool out of the defroster vent by the windshield. Now, I don't know if it was doing this before a messed with the a/c, or just started.

Fan knob still works, hot/cold knob still works, but no matter where you turn the knob that directs face/feet, face, feet/defrost, defrost, it blows out of the defroster vent.

What I'm having trouble finding is this: I don't know if the vent doors on this car are mechanically or vaccuum controlled, or what I should be doing to fix this problem....if its the knob, or the vent doors, or what I should be looking at.

I finally have it blowing cool, but it would be nice if the car would blow cool on your face and not the windshield!

Any ideas? Thanks in advance....
* Registered users of the site do not see these ads.
74novaman is offline   Reply With Quote
Old 03-30-2012, 05:06 PM   #2
Evaded
Scooby Newbie
 
Member#: 284680
Join Date: Jun 2011
Chapter/Region: TXIC
Location: South
Vehicle:
1998 2.5 RS Coupe
Acadia Green aka (Uni)

Default

Not too sure about a fix, im thinking with the year of the car its mechanical. Im guesiing your gonna have to pull the dash and look at it from the back while you switch your controls to see whats going on. Im sure someone else will have more info on this. Good luck.
Evaded is offline   Reply With Quote
Old 03-30-2012, 08:57 PM   #3
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Moved to a more appropriate section.
Sounds like the cable for the mode control is either broken or disconnected. As suggested get under there and have a look. You may be able to see and fix it without taking too much stuff apart.
Mulder is offline   Reply With Quote
Old 04-02-2012, 03:24 PM   #4
Legacy777
Scooby Guru
 
Member#: 4800
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Houston, Tx
Vehicle:
1990 Legacy & 97 OBS
AWD 6MT EJ22T AWIC Swap

Default

More than likely the clip that holds the cable in place came undone. This has happened a couple times on my 97 Impreza. If you look under the dash on the driver's side towards the blower box you'll see the cable for the mode selector. There will be a clip that holds that cable in place so the mode door moves. This clip is notorious for coming out of its holder. You'll just need to push it back in there. It's kind of a pain since it's up under the dash. Yo may need to take the clip off and bend the tabs so it stays in place.

Josh
Legacy777 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
97 impreza motor swap, help peanutswagon Subaru Conversions 2 05-30-2011 11:36 PM
97 Impreza Transmission Swap Help Needed BabyDoll0889 Interior & Exterior Modification 7 02-24-2011 02:24 PM
97 JDM sti swap in 97 impreza CEL flashes, won't hit full boost HELP WRXlerate Subaru Conversions 13 05-31-2005 12:30 PM
97 Impreza 2.2 Cyl 2&4 misfire CEL HELP dexterous Normally Aspirated Powertrain 1 04-10-2005 09:02 PM
Stock WRX Seats in a 97 Impreza L? Help allenm Newbies & FAQs 9 08-19-2002 08:28 PM


All times are GMT -4. The time now is 08:57 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.