Welcome to the North American Subaru Impreza Owners Club Wednesday July 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-31-2012, 06:28 PM   #1
lolol
Scooby Newbie
 
Member#: 311801
Join Date: Feb 2012
Chapter/Region: NWIC
Location: Portland OR
Default WTF, how is it that my 91 Legacy FWD is getting 17mpg?

New NGK plugs, air filter, PCV valve. Drained and filled automatic trans fluid.
Adjusted TPS as per factory service manual.
Cleared check engine code and it hasn't come back since.

Didn't expect any outcome, but ran Seaform through the intake.

Tire inflation, fine.
Car drives fine, but I continue to get 17mpg on highway, 15 city.

Looking at the engine, the timing belt cover is held in place with zip ties. Perhaps the timing belt was replaced at one point. Could it be off a tooth? If so, can I check this with a timing light?
* Registered users of the site do not see these ads.
lolol is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How is it that leafy green lettuce gets ahead of food I ate hours ahead of it? Snoopy Off-Topic 17 01-02-2012 11:51 PM
So why is it that my obdII scanner cannot connect to my ECU (ecutek reflashed)??? jigga Commercial ECU Reflashes 30 07-14-2006 02:34 PM
wtb: tranny cable clutch that will work in my 91 legacy or parts car with tranny eph Private 'Wanted' Classifieds 0 01-01-2006 08:57 AM
91 Legacy FWD wheel options CapeRex Tire & Wheel 5 12-06-2005 12:57 PM
just curious : why is it that every thread I post on gets locked? confused.. wrxg/f Off-Topic 21 08-11-2005 12:55 AM


All times are GMT -4. The time now is 10:47 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.