Welcome to the North American Subaru Impreza Owners Club Sunday September 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-24-2012, 09:16 PM   #301
cn07
Scooby Newbie
 
Member#: 197246
Join Date: Dec 2008
Location: Gettysburg
Default

Went stg 2 at 1000 miles on my brand new (in Sep of 06') 07 sti. Change my dino oil (5-30 Castrol ) every 3000. 17944 miles later no problems what so ever. It's all about the tune.
* Registered users of the site do not see these ads.
cn07 is offline   Reply With Quote
Old 04-25-2012, 01:13 AM   #302
gordyzero
Scooby Newbie
 
Member#: 56219
Join Date: Feb 2004
Chapter/Region: NESIC
Location: Vermont
Vehicle:
2011 WRX STI Limited
SPW

Default

Quote:
Originally Posted by cn07
Went stg 2 at 1000 miles on my brand new (in Sep of 06') 07 sti. Change my dino oil (5-30 Castrol ) every 3000. 17944 miles later no problems what so ever. It's all about the tune.
Well okay maybe. Its also all about the warranty ... If I tune this bone I won't have one. Glad to hear a " tune " worked for you. I just don't have the balls to play that no warranty game.
gordyzero is offline   Reply With Quote
Old 04-25-2012, 01:20 AM   #303
gordyzero
Scooby Newbie
 
Member#: 56219
Join Date: Feb 2004
Chapter/Region: NESIC
Location: Vermont
Vehicle:
2011 WRX STI Limited
SPW

Default

So finally got out of work. Here's what I have noticed so far.. the car starts faster, the throttle response seems just a little more polished. Maybe the idle is higher ? Its more of a treat to drive now. The idle on the devil tune seemed to hunt. Overall the car just feels smoother than before. I haven't gotten silly with it yet. But even the service director said. "beat that **** out of that thing " ... yes sir! I can do that.
gordyzero is offline   Reply With Quote
Old 04-25-2012, 01:43 AM   #304
JonzFaSTi
Scooby Specialist
 
Member#: 85575
Join Date: Apr 2005
Chapter/Region: SCIC
Location: Orange County, CA
Vehicle:
2013 STi
Dark Gray Metallic

Default

Drive it like you stole it!

I understand your concern about not wanting to tune it and since you only have a 5 year plan with the car anyways, there is no need to risk not having your warranty anymore.

But I do suggest you take that advice and drive it hard. This probably would have been taken care of a long time ago and if it can handle hard conditions for XXX amount of miles I am sure you will get more confident with the car as long as nothing else happens.

On a side note I havent notices any difference with my car since the mystery tune I got.
JonzFaSTi is offline   Reply With Quote
Old 04-25-2012, 01:47 AM   #305
JonzFaSTi
Scooby Specialist
 
Member#: 85575
Join Date: Apr 2005
Chapter/Region: SCIC
Location: Orange County, CA
Vehicle:
2013 STi
Dark Gray Metallic

Default

I am glad you got your car back though
JonzFaSTi is offline   Reply With Quote
Old 04-25-2012, 02:01 AM   #306
gordyzero
Scooby Newbie
 
Member#: 56219
Join Date: Feb 2004
Chapter/Region: NESIC
Location: Vermont
Vehicle:
2011 WRX STI Limited
SPW

Default

I have noticed a difference. However me and this tune are in certainly in the honeymoon stage. With that being said. I will report my findings. Its been a long month without my car. And then the murdered wheel. That really pissed me off. But my boys at the dealer took care of it and ordered the wheel the second they saw the picture of the damage. They even offered me a new tire. That dealership has earned my respect. I am going to drive it hard and keep my fingers crossed. Thank you all for your 2 cents. It means more to me than you will ever know. Respect and cheers to everyone. Drinks are on me to everyone if we ever meet up at a show. NASIOC members are the s h i t ! With respect, Gordyzero!
gordyzero is offline   Reply With Quote
Old 04-25-2012, 09:00 AM   #307
WRXLTD
Scooby Specialist
 
Member#: 136314
Join Date: Jan 2007
Location: A$$achusetts
Vehicle:
2014 Grand Cherokee

Default

Glad to hear you got your car fixed, and its also nice to hear that even after a horror story like this, the dealership did their best to fix the issue, and you two are still on good terms.

WRXLTD is offline   Reply With Quote
Old 04-25-2012, 09:27 AM   #308
1PearlyWhite1
Scooby Newbie
 
Member#: 314976
Join Date: Mar 2012
Chapter/Region: South East
Location: Cary, NC
Vehicle:
2011 STi 4dr
SWP

Default

way to be gordy! I've been following this thread for a couple of weeks now and, as many others have said, I'm not sure I would have been able to put up with the BS you had to go through. Glad the dealership was able to extend some great customer service and that you got your car back! keep us posted on how she's doing if ya don't mind!
1PearlyWhite1 is offline   Reply With Quote
Old 04-25-2012, 10:48 AM   #309
nightdown fox
Scooby Specialist
 
Member#: 309636
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Baltimore, MD
Vehicle:
2015 STI LE
WRB on Gold!

Default

Yay, Gordy! I would check the treadwear on the other tires though when that wheel is replaced... One new tire on an AWD car = fail...

Last edited by nightdown fox; 04-25-2012 at 11:20 AM.
nightdown fox is offline   Reply With Quote
Old 04-25-2012, 11:12 AM   #310
gordyzero
Scooby Newbie
 
Member#: 56219
Join Date: Feb 2004
Chapter/Region: NESIC
Location: Vermont
Vehicle:
2011 WRX STI Limited
SPW

Default

Quote:
Originally Posted by nightdown fox
Yay, Gordy! I would check the treadwear on the other tires though when that wheel is replaced... One new tire on an AWD car = fail...
Good point. I declined the tire offer. The curb protector has a chip in it. Big woop. Besides the OEM tires in my opinion, cucka . Besides the car had a bad alignment from day one and Those tires are so loud even when they are new. Now there all chop sueied Rawww,rawww rawww .. The dealer will give me a awesome deal on tires I actually want.
gordyzero is offline   Reply With Quote
Old 04-25-2012, 11:23 AM   #311
nightdown fox
Scooby Specialist
 
Member#: 309636
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Baltimore, MD
Vehicle:
2015 STI LE
WRB on Gold!

Default

Sidenote rant, but now I'm scared.... I had a 2007 Mazdaspeed6 that went in 500 miles before the warranty expired (69,500) for an engine squeak... that was January 2012, and they had the car until the end of March... They replaced the turbo and timing chain under warranty... Then figured out that the squeak was caused by a cracked sleeve in cylinder 3... Replaced that under warranty after a Mazda Cigarrette Smoking Man came out from California... Then the tech messed up the starter when taking the engine out... Replaced that... Then they called me up and said since they had to take the engine out, they would replace clutch for all my trouble...then the tech messed up the shift linkage and pressure plate from the clutch install... Replaced that... Then when i picked it up, the electronic throttle body threw a code, had to return it and get that fixed... Then found out the tech messed up the airbag harness when replacing the shift linkage somehow and it threw another code... And Mazda didn't make that part anymore for the Speed6... So they had to have one fabricated according to MoA.

The point is, through this ordeal, ranting on the Mazdaspeed forums about how I never would buy another Mazda... The dealer across the street brought in a 2012 PBP WRX Limited that had been customized by a customer (short shifter, SPT exhaust, home link mirror, footwell LEDs... Bunch of other SPT stuff...) ... but OOPS, the customer wanted WRB, not PBP... And I remembered how I've always wanted a WRX and I bought the Mazdaspeed6 because at the time my insurance and credit said it was a better deal and I spent everyday pretending it was a WRX...

"Subarus never blow engines like Mazdas," I told my wife as she heard that boxer rumble pull up into our driveway and met me at the door with her arms crossed. Grr, and I got the extended warranty... Plus I put on Stage 1 after hearing other horror stories....
nightdown fox is offline   Reply With Quote
Old 04-25-2012, 03:05 PM   #312
gordyzero
Scooby Newbie
 
Member#: 56219
Join Date: Feb 2004
Chapter/Region: NESIC
Location: Vermont
Vehicle:
2011 WRX STI Limited
SPW

Default

Who's the tech at the Mazda dealership ? Is he the retarded kid from the t.v. show life goes on ? Sounds like your dealership can't find their ass with 2 hands. Hardly Mazdas fault. SOA still hasn't called me back with any info other than " we have no info at this tme " 8 days after I asked for information. Any broken car is a POS. Its up to the dealer and the manufacturer to make it right. When one of them fails the consumer has every right to be furious.
gordyzero is offline   Reply With Quote
Old 04-25-2012, 05:23 PM   #313
k mier
Scooby Specialist
 
Member#: 98000
Join Date: Oct 2005
Location: MO
Vehicle:
05 sti e85@420hp

Default

No one else found those cylinder pics odd???
k mier is offline   Reply With Quote
Old 04-25-2012, 05:51 PM   #314
gordyzero
Scooby Newbie
 
Member#: 56219
Join Date: Feb 2004
Chapter/Region: NESIC
Location: Vermont
Vehicle:
2011 WRX STI Limited
SPW

Default

My thoughts exactly. ? What do you think of the pics?
gordyzero is offline   Reply With Quote
Old 04-25-2012, 05:53 PM   #315
gordyzero
Scooby Newbie
 
Member#: 56219
Join Date: Feb 2004
Chapter/Region: NESIC
Location: Vermont
Vehicle:
2011 WRX STI Limited
SPW

Default

You can't see them on the android app. So maybe thats it?
gordyzero is offline   Reply With Quote
Old 04-25-2012, 06:06 PM   #316
nightdown fox
Scooby Specialist
 
Member#: 309636
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Baltimore, MD
Vehicle:
2015 STI LE
WRB on Gold!

Default

Yeah I think the techs at my Mazda dealership were fed asbestos chips as kids... I can't see the pics on my IPAD app either... Had to go check them out on the PC...


Holy crap, that's glazed in???????
nightdown fox is offline   Reply With Quote
Old 04-25-2012, 06:13 PM   #317
gordyzero
Scooby Newbie
 
Member#: 56219
Join Date: Feb 2004
Chapter/Region: NESIC
Location: Vermont
Vehicle:
2011 WRX STI Limited
SPW

Default

Here's the best part. I changed the oil every 3750 with Subaru Synthetic. Its only required to be changed @ 7500 miles. Double oil service intervals and never tuning in any way. 13774 miles later ....
gordyzero is offline   Reply With Quote
Old 04-25-2012, 06:21 PM   #318
apocalight
Scooby Newbie
 
Member#: 315478
Join Date: Apr 2012
Chapter/Region: NWIC
Location: Portland, OR
Vehicle:
2012 STi
DGM

Default

We need to get your new tune downloaded gordy . . . I think many of us are eager to see what's different.
apocalight is offline   Reply With Quote
Old 04-25-2012, 06:42 PM   #319
gordyzero
Scooby Newbie
 
Member#: 56219
Join Date: Feb 2004
Chapter/Region: NESIC
Location: Vermont
Vehicle:
2011 WRX STI Limited
SPW

Default

Quote:
Originally Posted by apocalight
We need to get your new tune downloaded gordy . . . I think many of us are eager to see what's different.
Well I have no clue on how safe it is to do that. But here is what I know for sure. My old tune and engine were dog ****tt. New engine and 8 miles later I had a software problem ? Which the cigarette smoking Man had to be dispatched to install the " bat tune" has fixed it so far, it can't be much better..? But my car does have bad guy radar now and its bullet proof..LOL..This whole thing doesn't pass the smell test.
gordyzero is offline   Reply With Quote
Old 04-25-2012, 08:04 PM   #320
SWP n Gold
Scooby Guru
 
Member#: 110783
Join Date: Mar 2006
Chapter/Region: Tri-State
Location: Stamford, CT
Vehicle:
2010 WRX
Satin White Pearl

Default

Quote:
Originally Posted by nightdown fox View Post
Holy crap, that's glazed in???????
I don't think this is the first 2011+ WRX/STi I've seen with the same problem and they used Subaru Synthetic oil as well. I can't remember where the thread is though; I'll check around and see if I can find it.
SWP n Gold is offline   Reply With Quote
Old 04-25-2012, 08:41 PM   #321
gordyzero
Scooby Newbie
 
Member#: 56219
Join Date: Feb 2004
Chapter/Region: NESIC
Location: Vermont
Vehicle:
2011 WRX STI Limited
SPW

Default

BTW, every time I dumped that oil it had a very strange RED tint to it. I thought I was nucking futs. But the dealer asked me why I had a dye in my oil ? I Don't think they believed me when I said I didn't. A couple days later. Another customers car drained reddish too, same oil, same interval. Then they all agreed , That oil sucks !
gordyzero is offline   Reply With Quote
Old 04-25-2012, 09:08 PM   #322
mejifair
Scooby Specialist
 
Member#: 11356
Join Date: Oct 2001
Chapter/Region: MWSOC
Location: Cottage Grove, MN
Vehicle:
2012 WRX STi Hatch
DGM

Default

Quote:
Originally Posted by gordyzero View Post
The dealer just called, they said Subaru is sending a tech to reflash the car with a different map. Turns out the ECU is now the NEW problem. So much of a problem that only a field tech can perform this fix , so when the dealer isn't allowed to perform the fix this ties the car up at least 3 more days. What a mess. I called Subaru, I want out of this car. They are going to investigate and tell me what if any options I may have for a trade assist or etc.
Hey - did they say it was a new tune for the 2012's? When I was at the dealer about a month ago they said there was an ECU upgrade in Beta, but that they did not know when it would be out.
mejifair is offline   Reply With Quote
Old 04-25-2012, 09:19 PM   #323
gordyzero
Scooby Newbie
 
Member#: 56219
Join Date: Feb 2004
Chapter/Region: NESIC
Location: Vermont
Vehicle:
2011 WRX STI Limited
SPW

Default

Quote:
Originally Posted by mejifair

Hey - did they say it was a new tune for the 2012's? When I was at the dealer about a month ago they said there was an ECU upgrade in Beta, but that they did not know when it would be out.
Thats the best part. No one knows anything about this tune. I even had a guy at the dealer call technical and they said to the best of their knowledge no changes for 2012. But I also learned each ecu part # is what determines what flash is on board out of the box. The only way to confirm if there is a update available is by vin #. The day my car wouldn't stop throwing codes, Their was NO UPDATE available. The next business day, the dealer called SOA tech. And after methodical check list of check this and thats. No resolution was found so the phone call was ended. A very short while later SOA tech called back " yeah we have a reflash for that, but we have to send someone to do it, you can't ".... the rest is history.
gordyzero is offline   Reply With Quote
Old 04-25-2012, 10:05 PM   #324
k mier
Scooby Specialist
 
Member#: 98000
Join Date: Oct 2005
Location: MO
Vehicle:
05 sti e85@420hp

Default

If it's not just a trick of the camera at that angle, it looks like half the cylinder didn't even touch the piston. Look toward the back bottom of the second pic.
k mier is offline   Reply With Quote
Old 04-25-2012, 11:37 PM   #325
gordyzero
Scooby Newbie
 
Member#: 56219
Join Date: Feb 2004
Chapter/Region: NESIC
Location: Vermont
Vehicle:
2011 WRX STI Limited
SPW

Default

Quote:
Originally Posted by k mier
If it's not just a trick of the camera at that angle, it looks like half the cylinder didn't even touch the piston. Look toward the back bottom of the second pic.
Im no expert, but last time I knew no engine should look like that @ 13k. Not to mention the wear isn't even CLOSE to being uniform around the cylinder wall. I wish I could have seen the pistons. You can't really see it in the photo but the very top of the cylinder hoan is notched ... dikked up
gordyzero is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 STi Sedan 305/368 EFI Tuned krotondo Factory 2.5L Turbo Powertrain 1 09-22-2011 01:46 AM
***PhatBotti Tuned: E85'ed 2011 STi, 330whp!! Per Gear Data + Tuning Discussed*** PhatBotti Tuning TKR Proven Power Bragging 54 06-24-2011 10:58 AM
2011 STI OTS map vs Pro tune Jose Gordils Newbies & FAQs 6 05-09-2011 11:08 AM
2011 STi V-Limited LIPS IN STOCK! Yeah we got them! RallySport Direct Vendor 'General Sale' Forum 1 11-08-2010 03:03 PM
07 STI Blown Piston or Ring? 07stilover Factory 2.5L Turbo Powertrain 49 01-25-2008 01:24 AM


All times are GMT -4. The time now is 12:26 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.