Welcome to the North American Subaru Impreza Owners Club Thursday September 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-10-2012, 03:19 PM   #1
20subaru02
Scooby Newbie
 
Member#: 306104
Join Date: Jan 2012
Chapter/Region: SCIC
Location: Menifee
Vehicle:
2006 Impreza WRX
Black

Default 2002 wrx sputtering and flashing CEL

Ok I know there's alot of forums out there about this but everyone I've read I can't find a definite answer.
My car sputters when I step on it and this morning it threw the CEL it flashed for about 10 seconds and then it went away.
I've read that it could be the coil pack,fuel filter,MAF,fuel injectors timing spark plugs.
But none of them said for sure what it was, so I was wondering of any of you guys have had this problem and how did u fix it?
Thanks
* Registered users of the site do not see these ads.
20subaru02 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
02 WRX Sputtering and CEL Tweeder Factory 2.0L Turbo Powertrain 12 11-30-2009 07:56 PM
2002 WRX Wgn - Flashing CEL kysef Factory 2.0L Turbo Powertrain 1 05-04-2008 04:36 PM
Missing and flashing CELs leeswrx Factory 2.0L Turbo Powertrain 3 07-26-2007 02:34 AM
changed out the plugs on the sti and flashing cel Deezy1678 Service & Maintenance 4 04-03-2007 08:36 AM
Stage 2 AP and flashing Cel HELP!!! DanBelford Engine Management & Tuning 18 12-08-2005 08:06 PM


All times are GMT -4. The time now is 04:41 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.