Welcome to the North American Subaru Impreza Owners Club Friday December 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-11-2012, 01:31 PM   #1
20boxer
Scooby Newbie
 
Member#: 179382
Join Date: May 2008
Location: city of brotherly love
Vehicle:
03 wrx
psm

Default 02 legacy at help needed

So I just swapped a motor into an 02 legacy auto for a friend. Started the car without the exhaust and pit it in drive and reverse and everything was gravy. Put the exhaust on....and now the car won't go into gear. The display is saying it is in drive bit it acts like its in neutral. Any help would be great. Fluid level is slightly above full
* Registered users of the site do not see these ads.
20boxer is offline   Reply With Quote
Old 04-11-2012, 05:35 PM   #2
PMDSOA
Scooby Newbie
 
Member#: 274810
Join Date: Feb 2011
Location: Long Island, New York
Vehicle:
05 LGTL
Brilliant Silver

Default

If the fluid is too full youll mess up the tranny. Have you checked all the linkage? Maybe something came undone or damage while putting the exhaust on. You never know
PMDSOA is offline   Reply With Quote
Old 04-12-2012, 12:57 AM   #3
04Legacy
Scooby Newbie
 
Member#: 316432
Join Date: Apr 2012
Location: Williamsport,PA
Vehicle:
2004 Legacy BE
Regetta Red

Default

Thats what i was thinking prolly disconnected your tranny linkage. maybe u could have hit one of the sensor on the tranny
04Legacy is offline   Reply With Quote
Old 04-12-2012, 04:17 PM   #4
20boxer
Scooby Newbie
 
Member#: 179382
Join Date: May 2008
Location: city of brotherly love
Vehicle:
03 wrx
psm

Default

Ok thanks for the quick replys everyone. So here is the update. Linkage is working as should....so it seems. When the car is shifted into drive there is a constant buzzing sound coming from the trans. Buzzing is not from shift linkage side but appears to be coming from the top of the trans somewhere. Any ideas what is making this buzzing noise
20boxer is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
JDM Momo Airbag in 99 Legacy gt help needed snowjob Subaru Conversions 10 12-09-2011 07:01 PM
IAC in 91 Leg vs 02 WRX GURU HELP needed dangerousatom Subaru Conversions 4 07-01-2009 11:02 PM
Getting Espelir GT springs to fit an 02 wagon - help needed from STI Espelir owners Durmiente Brakes, Steering & Suspension 8 05-24-2007 12:27 AM
Attn: All who know someone at or will be at the Maine Rally - immediate help needed!! Fitz New England Impreza Club Forum -- NESIC 3 08-02-2003 01:39 PM
Making cold air intake for legacy, some help needed tonytiger Normally Aspirated Powertrain 5 02-06-2001 01:52 AM


All times are GMT -4. The time now is 10:34 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.