Welcome to the North American Subaru Impreza Owners Club Tuesday October 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-13-2012, 11:01 AM   #1
nunez07c
Scooby Newbie
 
Member#: 258027
Join Date: Sep 2010
Chapter/Region: Tri-State
Location: New Jersey
Default STi transmission problem... Need help.

I have an Sti trans into my 04 wrx, just recently done a month ago...
This has been happening for two week now and its getting really annoying. On some occasions when shifting in low rpms (only when going to 5th gear) it will pop out of gear a few seconds later. To describe it better; I'm in 4th gear accelerating, around 2.5k rpm i upshift to 5th and as soon as i am letting go of the clutch and getting back on throttle, within that second it pops back out into neutral leaving me revving.

All in all, what may be causing this? as I'm REALLY worried for the fact that I've spent so much money on the swap not too long ago, and now it looks like I would have to spend more. Don't get me wrong I love my subbie, but wow, now in the back of my head I'm considering moving on and getting an evo. I really dont' want to though.


* Things I've noticed

-- does not always occur.
-- Only happens in low rpms. When shifting at 4k or greater, it does not pop out.



Thanks so much in advance for the help.
* Registered users of the site do not see these ads.
nunez07c is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission problems! Need opinions, torque converter or transmission?? Mega1m Transmission (AT/MT) & Driveline 8 01-29-2012 10:25 AM
05 STi Tranny problems...need help... jonpark Transmission (AT/MT) & Driveline 18 02-27-2009 04:38 PM
04 Sti V-belt problems. Need help! Brettnrs423 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 0 05-23-2008 02:04 PM
Transmission problem. Please help! Flat 6 Transmission (AT/MT) & Driveline 2 10-06-2005 09:18 AM
PROBLEM NEED HELP Turbo XS H-RFl Blow-off Install on 05 STI TimL Engine Management & Tuning 8 10-12-2004 09:56 AM


All times are GMT -4. The time now is 03:00 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.