Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-17-2012, 08:12 PM   #1
Blue BugeyeRS2.5
Scooby Newbie
 
Member#: 295045
Join Date: Sep 2011
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2002 WRX
silver

Default CV issues i think...help please

recently i had my passenger side cv go bad, so i bought a new one and had it installed, however i still notice a grinding/knocking noise when i make right hand corners faster than 30-40mph, but do not notice anything on left hand corners, it sounds like it is coming from the passenger side area, maybe it is something else, any ideas are appreciated, i have a hard time believing that the current cv is bad because it was brand new (not OEM though, duralast). If anyone thinks they might know what's going on, please let me know, thank you!
* Registered users of the site do not see these ads.
Blue BugeyeRS2.5 is offline   Reply With Quote
Old 05-01-2012, 02:04 PM   #2
cbadowski
Scooby Newbie
 
Member#: 318654
Join Date: Apr 2012
Default

It sounds like your front passenger wheel bearing.
cbadowski is offline   Reply With Quote
Old 05-01-2012, 08:05 PM   #3
Blue BugeyeRS2.5
Scooby Newbie
 
Member#: 295045
Join Date: Sep 2011
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2002 WRX
silver

Default

i actually did more investigation and the noise is coming from right under my center console, it sounds like something is rubbing up against the drive shaft, but i have no idea what it could be
Blue BugeyeRS2.5 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad CV Axle, Wheel Bearing, Or Worse? Help please 02baruRS Transmission (AT/MT) & Driveline 12 07-28-2011 03:16 PM
Bad CV axle, wheel hub, or worse? Help please... 02baruRS Brakes, Steering & Suspension 0 04-07-2011 04:49 PM
CV Boot Leak - Help please... Hank3 Transmission (AT/MT) & Driveline 8 06-30-2007 12:56 AM
Help, STi alignment issue...i think nomorem3 Brakes, Steering & Suspension 9 05-12-2005 03:56 PM
Help please I think my turbo is done Turbo Tin Can Factory 2.0L Turbo Powertrain 14 08-08-2002 11:04 PM


All times are GMT -4. The time now is 11:18 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.