Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-05-2012, 08:45 PM   #1
mikeistheman1022
Scooby Newbie
 
Member#: 250639
Join Date: Jun 2010
Default 2002 WRX misfiring. PLEASE HELP!

hey guys, first off ill tell you about my setup.

The car is a 2002 impreza wrx 5spd sedan. purchased 3 years ago with 117k miles all stock. at 127k miles i did a turbo swap (blouch 16g) and now has 143k miles. I havent had any problems until recently.
--modified parts:
Blouch 16g Turbo
Deatschwerks 650cc injectors
walbro 255 fuel pump
JDM v7 STI tmic
equal length headers/ 2.5 inch catless up pipe
3" catless turbo back exhaust
K&N Typhoon Short ram intake
grimmspeed EBCS
STi ignition coils
Denso Iridium spark plugs
Tuned by ECS performance In Connecticut.

I noticed the misfires occuring about a month ago and the problem has been getting much worse. Now every time i drive it down the road it will sputter and the CEL will be flashing. I replaced the ignition coils and plugs today and still no difference. I had a leak in my headers a while back and was told it was fixed after bringing it to an exhaust shop. I noticed a slight exhaust leak still near the turbo. I suspect it could be a gasket to the up pipe/turbo? I dont know the exact code that showed up after running a diagnostic test but i do know it was misfiring on 2 different cylinders. (coilpacks and plugs are not the issue)

Anyone else experience this and know a solution? I'd like to fix it myself so i dont have to pay a shop.
* Registered users of the site do not see these ads.
mikeistheman1022 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
('93-'01) Engine misfire please help! Burdman412 Impreza Forum 2 03-30-2013 08:03 PM
WTB : LOOKing for 2002 WRX parts please help norewhat24 Tri-State Area Private Classifieds 1 09-13-2011 11:15 PM
Engine Misfire please help! Burdman412 Engine Management & Tuning 2 04-02-2008 09:13 PM
Multiple Misfires, please help keirnna Normally Aspirated Powertrain 19 07-27-2005 12:54 AM
TXS Unichip Misfires!? Please Help. ctwrxwagon Engine Management & Tuning 0 08-23-2003 02:02 PM


All times are GMT -4. The time now is 06:27 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.