Welcome to the North American Subaru Impreza Owners Club Sunday November 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
New England Subaru Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > New England Impreza Club Forum -- NESIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 06-30-2012, 11:31 AM   #1201
subiescooby2002
Scooby Newbie
 
Member#: 283928
Join Date: May 2011
Chapter/Region: NESIC
Location: Leominster
Vehicle:
2002 Wrx wagon
Burgandy

Default

Quote:
Originally Posted by colin1234567

Did you go sandwich or gallery plug?
Electrical or mechanical?
I had one it did the job
Sandwich and it's the electrical one
* Registered users of the site do not see these ads.
subiescooby2002 is offline  
Old 06-30-2012, 03:42 PM   #1202
colin1234567
Scooby Specialist
 
Member#: 212639
Join Date: May 2009
Chapter/Region: TXIC
Vehicle:
WRX= 13/SWP/GR/TP
Stage 3, '90 NA Miata

Default

I assume you're not pouting oil?
If the wires are not damaged and plugged in correctly with the other holes safely plugged it should be working.
The lights turn on but 0 psi?
colin1234567 is offline  
Old 06-30-2012, 04:39 PM   #1203
subiescooby2002
Scooby Newbie
 
Member#: 283928
Join Date: May 2011
Chapter/Region: NESIC
Location: Leominster
Vehicle:
2002 Wrx wagon
Burgandy

Default

Quote:
Originally Posted by colin1234567
I assume you're not pouting oil?
If the wires are not damaged and plugged in correctly with the other holes safely plugged it should be working.
The lights turn on but 0 psi?
Yea everything turns on but reads 0 psi
subiescooby2002 is offline  
Old 06-30-2012, 07:07 PM   #1204
Pearly_Whites
Scooby Specialist
 
Member#: 164714
Join Date: Nov 2007
Chapter/Region: NESIC
Location: Woostah
Vehicle:
2007 WRX TR
Satin White Pearl

Default

Quote:
Originally Posted by subiescooby2002

Yea everything turns on but reads 0 psi
Bad sender
Pearly_Whites is offline  
Old 06-30-2012, 07:45 PM   #1205
subiescooby2002
Scooby Newbie
 
Member#: 283928
Join Date: May 2011
Chapter/Region: NESIC
Location: Leominster
Vehicle:
2002 Wrx wagon
Burgandy

Default

Quote:
Originally Posted by Pearly_Whites

Bad sender
Damn I figured that I have another one here but is a pain to put on and take off that damn adapter plus I just just changed my oil .... This suuuuucks
subiescooby2002 is offline  
Old 06-30-2012, 11:36 PM   #1206
MaddSubieLove
Scooby Specialist
 
Member#: 108258
Join Date: Feb 2006
Chapter/Region: NESIC
Location: MA
Vehicle:
2002 WRX/99ForesterS
PSM

Default

Kevin your car looks awesome with those installed!
MaddSubieLove is offline  
Old 07-01-2012, 01:33 AM   #1207
subiescooby2002
Scooby Newbie
 
Member#: 283928
Join Date: May 2011
Chapter/Region: NESIC
Location: Leominster
Vehicle:
2002 Wrx wagon
Burgandy

Default

Anybody have an extra galley plug I can steal off of and maybe a spot to empty out my oil and put it back in so I can remove this stupid adapter I'm hearing bad things about
subiescooby2002 is offline  
Old 07-01-2012, 01:52 AM   #1208
yotasteak569
Scooby Specialist
 
Member#: 287333
Join Date: Jul 2011
Default

If you just changed your oil then leave it in there you will get a little run off when you pull the oil filter and adapter but just top it off. If your gonna drain it n then reuse it might as well just leave it in the pan.
yotasteak569 is offline  
Old 07-01-2012, 02:12 AM   #1209
subiescooby2002
Scooby Newbie
 
Member#: 283928
Join Date: May 2011
Chapter/Region: NESIC
Location: Leominster
Vehicle:
2002 Wrx wagon
Burgandy

Default

Quote:
Originally Posted by yotasteak569
If you just changed your oil then leave it in there you will get a little run off when you pull the oil filter and adapter but just top it off. If your gonna drain it n then reuse it might as well just leave it in the pan.
I'm gonna do this tomorrow then just didn't know how much oil was going to come out when I pull the filter out.... Haha Dumb noob question I could still use the same filter though no need to buy a new one ????
subiescooby2002 is offline  
Old 07-01-2012, 11:21 AM   #1210
colin1234567
Scooby Specialist
 
Member#: 212639
Join Date: May 2009
Chapter/Region: TXIC
Vehicle:
WRX= 13/SWP/GR/TP
Stage 3, '90 NA Miata

Default

I'd put it in a bag if you're hell bent on reusing it. I'm cheap I'd probably do the same thing. So clean it as best as possible on the car, take it off and drain it and put it in a ziploc bag
colin1234567 is offline  
Old 07-01-2012, 12:00 PM   #1211
subiescooby2002
Scooby Newbie
 
Member#: 283928
Join Date: May 2011
Chapter/Region: NESIC
Location: Leominster
Vehicle:
2002 Wrx wagon
Burgandy

Default

Quote:
Originally Posted by colin1234567
I'd put it in a bag if you're hell bent on reusing it. I'm cheap I'd probably do the same thing. So clean it as best as possible on the car, take it off and drain it and put it in a ziploc bag
Lol you gotta be cheap mobile 1 at 8.99 a qrt. Sucks
subiescooby2002 is offline  
Old 07-01-2012, 12:05 PM   #1212
yotasteak569
Scooby Specialist
 
Member#: 287333
Join Date: Jul 2011
Default

If you just changed the oil and filter reuse the filter leave the oil in the car. Back in the day I had a teacher at the automotive school I went to used to change his oil every 3k but filter only every 6k. N that was on a fully swapped rsti with just under or just over 400whp. Save the few bucks reuse it no reason to replace if it's new! Good luck with your sender issue!
yotasteak569 is offline  
Old 07-01-2012, 12:11 PM   #1213
H4kustomz
Scooby Newbie
 
Member#: 292654
Join Date: Aug 2011
Chapter/Region: NESIC
Location: Westminster MA / Wells ME
Vehicle:
2005 2.5RS
PSM

Default

so yesterday me and grant installed my coilovers and i tinted my tail light the other day too
stock hight



low


final hight so i dont rip my lip and bumper off






H4kustomz is offline  
Old 07-01-2012, 12:12 PM   #1214
subiescooby2002
Scooby Newbie
 
Member#: 283928
Join Date: May 2011
Chapter/Region: NESIC
Location: Leominster
Vehicle:
2002 Wrx wagon
Burgandy

Default

Thanks guys I appreciate all the help I'll try and make it to the next meet so I can put some faces to some names
subiescooby2002 is offline  
Old 07-01-2012, 03:48 PM   #1215
yotasteak569
Scooby Specialist
 
Member#: 287333
Join Date: Jul 2011
Default

Looks good man!
yotasteak569 is offline  
Old 07-01-2012, 04:12 PM   #1216
H4kustomz
Scooby Newbie
 
Member#: 292654
Join Date: Aug 2011
Chapter/Region: NESIC
Location: Westminster MA / Wells ME
Vehicle:
2005 2.5RS
PSM

Default

Quote:
Originally Posted by yotasteak569
Looks good man!
Thanks man just need an alignment
H4kustomz is offline  
Old 07-01-2012, 05:47 PM   #1217
Pearly_Whites
Scooby Specialist
 
Member#: 164714
Join Date: Nov 2007
Chapter/Region: NESIC
Location: Woostah
Vehicle:
2007 WRX TR
Satin White Pearl

Default

Quote:
Originally Posted by subiescooby2002

Lol you gotta be cheap mobile 1 at 8.99 a qrt. Sucks
Buy it at Walmart in the big 5qt container. Way cheaper than an auto store
Pearly_Whites is offline  
Old 07-01-2012, 07:17 PM   #1218
yotasteak569
Scooby Specialist
 
Member#: 287333
Join Date: Jul 2011
Default

Space monkey, was that you?
yotasteak569 is offline  
Old 07-01-2012, 07:33 PM   #1219
space0monkey
Scooby Newbie
 
Member#: 277967
Join Date: Mar 2011
Chapter/Region: NESIC
Location: Waltham MA
Vehicle:
2004 WRX wgn
PSM

Default

Yes it was! Was leaving to get to Conway nh for some camping. Got here just in time to set up the tent in the rain :-D
space0monkey is offline  
Old 07-01-2012, 10:01 PM   #1220
colin1234567
Scooby Specialist
 
Member#: 212639
Join Date: May 2009
Chapter/Region: TXIC
Vehicle:
WRX= 13/SWP/GR/TP
Stage 3, '90 NA Miata

Default

Theres rain?

Anyone live out west/go out west like west Springfield? Having a hard time coordinating the trip to get the AP
colin1234567 is offline  
Old 07-01-2012, 10:11 PM   #1221
space0monkey
Scooby Newbie
 
Member#: 277967
Join Date: Mar 2011
Chapter/Region: NESIC
Location: Waltham MA
Vehicle:
2004 WRX wgn
PSM

Default

Well there was, all set now though luckily. Moving quickly with the new bug! Stage 2 soon?
space0monkey is offline  
Old 07-01-2012, 11:16 PM   #1222
vision.dynamix
Scooby Guru
 
Member#: 139955
Join Date: Feb 2007
Chapter/Region: NESIC
Location: Boston
Vehicle:
2015 Subaru STI
Black, like my soul.

Default

Yeah it started sprinkling when I was loading up at the track.
vision.dynamix is offline  
Old 07-02-2012, 12:38 AM   #1223
colin1234567
Scooby Specialist
 
Member#: 212639
Join Date: May 2009
Chapter/Region: TXIC
Vehicle:
WRX= 13/SWP/GR/TP
Stage 3, '90 NA Miata

Default

Quote:
Originally Posted by space0monkey
Well there was, all set now though luckily. Moving quickly with the new bug! Stage 2 soon?
I just want off this stock map!
Once my car sells I'll have money to play with hopefully, stuck for the time being
colin1234567 is offline  
Old 07-02-2012, 08:51 AM   #1224
myklwrx
Scooby Specialist
 
Member#: 150791
Join Date: Jun 2007
Chapter/Region: NESIC
Location: Townsend, Ma
Vehicle:
2002 wrx wagon
midnight black pearl

Default

Quote:
Originally Posted by colin1234567 View Post
I just want off this stock map!
Once my car sells I'll have money to play with hopefully, stuck for the time being
happy to see another bugeye, and a wagon to boot!!! hopefully the car sells soon, any hits on it yet?
myklwrx is offline  
Old 07-02-2012, 09:58 AM   #1225
colin1234567
Scooby Specialist
 
Member#: 212639
Join Date: May 2009
Chapter/Region: TXIC
Vehicle:
WRX= 13/SWP/GR/TP
Stage 3, '90 NA Miata

Default

Only one who's not too thrilled it's a base, making me wait until Friday to come take a look :/
colin1234567 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HR: Peninsula Meet 11/3 Buffalo Wild Wings 7PM tux2122 Mid Atlantic Impreza Club -- MAIC 46 11-04-2009 06:56 PM
NOVA MEET: Thursday 6/4/09 - Buffalo Wild Wings blubaru703 Mid Atlantic Impreza Club -- MAIC 61 06-20-2009 07:58 AM
Chi: Thursday Borders Meet, 6/26/08 speelnik Mid West Subaru Owners Club Forum -- MWSOC 149 06-30-2008 01:04 PM
SE/Clear Lake Meet - Wednesday 2/2/05 or Thursday 2/3/05 - Buffalo Wild Wings 7:30pm Hotrodguru Texas Impreza Club Forum -- TXIC 11 02-03-2005 05:07 AM
Rochester, NY meet 5pm friday(today) buffalo wild wings joel(PA) Tri-State Area Forum 17 04-25-2004 01:35 PM


All times are GMT -4. The time now is 09:18 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.