Welcome to the North American Subaru Impreza Owners Club Friday August 28, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-03-2012, 02:41 PM   #1
rsg9115
Scooby Newbie
 
Member#: 218569
Join Date: Jul 2009
Chapter/Region: NESIC
Location: massachusetts
Vehicle:
91 leggy sdn turbo
black

Default Four codes

Air flow sensor
Cam angle sensor
knock sensor
iac

Any ideas on my problem ? Just bought the car a week ago
* Registered users of the site do not see these ads.
rsg9115 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-03-2012, 03:33 PM   #2
rsg9115
Scooby Newbie
 
Member#: 218569
Join Date: Jul 2009
Chapter/Region: NESIC
Location: massachusetts
Vehicle:
91 leggy sdn turbo
black

Default

Cleaned all related sensor plugs except cam angle ( no idea which one) and disconnected batt. Start it check light was instantly on
rsg9115 is offline   Reply With Quote
Old 05-03-2012, 07:59 PM   #3
rsg9115
Scooby Newbie
 
Member#: 218569
Join Date: Jul 2009
Chapter/Region: NESIC
Location: massachusetts
Vehicle:
91 leggy sdn turbo
black

Default

Well no one seems to kno I guesss but my abs light was on fixed that by cleaning plugs and I cleaned manyy plugs to the engine and power washed carefully now the lights out flicks on for a few seconds mayb only a couple times so I checked codes still saying the same four so i unhooked the batt again see what happins but I did a pull and it's bogging under boost a few times it was like stuttering idkk
rsg9115 is offline   Reply With Quote
Old 05-04-2012, 01:52 PM   #4
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
QuickSilver Metallic

Default

Assuming your older EJ is the same as the newer ones, the cam angle sensor is on the top of the driver side head.

With that many sensors indicating a fault I would be inclined to think there was a ground issue somewhere that was causing the ECU to get bad readings.
Patrick Olsen is offline   Reply With Quote
Old 05-04-2012, 08:50 PM   #5
rsg9115
Scooby Newbie
 
Member#: 218569
Join Date: Jul 2009
Chapter/Region: NESIC
Location: massachusetts
Vehicle:
91 leggy sdn turbo
black

Default

Hmm thats a really good idea I'll check grounding Tom.
rsg9115 is offline   Reply With Quote
Old 05-04-2012, 09:00 PM   #6
rsg9115
Scooby Newbie
 
Member#: 218569
Join Date: Jul 2009
Chapter/Region: NESIC
Location: massachusetts
Vehicle:
91 leggy sdn turbo
black

Default

Ya and more random codes have popped up I found a crack in the line off the intake to the bypass valve earlier
rsg9115 is offline   Reply With Quote
Old 05-05-2012, 07:36 PM   #7
rsg9115
Scooby Newbie
 
Member#: 218569
Join Date: Jul 2009
Chapter/Region: NESIC
Location: massachusetts
Vehicle:
91 leggy sdn turbo
black

Default

Update like 6 random codes put in a brand new alt has new batt I did some grounds I'll finish then Tom
rsg9115 is offline   Reply With Quote
Old 05-05-2012, 07:38 PM   #8
rsg9115
Scooby Newbie
 
Member#: 218569
Join Date: Jul 2009
Chapter/Region: NESIC
Location: massachusetts
Vehicle:
91 leggy sdn turbo
black

Default

I'm planning on also goin vac line crazy and inspect the ecu, btw now it has no power no turbo sounds like it hardly spools
rsg9115 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2006-2007 Subaru Wrx Four Pot Brake Calipers, All Four CHEAP!!!! 98SubbyLeg Suspension/Brakes/Handling 4 02-22-2010 08:14 PM
Dear Four x Four Gee Gee Gee psychoskip Off-Topic 17 08-18-2009 09:24 PM
FS set of four ASA AR1 Silver w/Machined Lip 17x7 (+48) and four RE92 tires Piper NWIC Private Classifieds 21 03-04-2009 02:30 AM
codes,codes and more codes grinch77 Newbies & FAQs 8 01-07-2009 05:27 PM
2008 Chevrolet Cobalt SS Faces Four Forced-Induction Fours and a High-RPM Honda AVANTI R5 Non-Subaru News & Rumors 76 06-16-2008 07:06 PM


All times are GMT -4. The time now is 12:02 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.