Welcome to the North American Subaru Impreza Owners Club Friday December 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-17-2012, 09:54 PM   #1
joelkarlonas
Scooby Newbie
 
Member#: 317169
Join Date: Apr 2012
Default 1996 GC8 WRX STi type-RA

hey guys i just got a 1996 sti type ra this weekend with 146,000km and was imported 6months ago.

before i got it the guy got a comp test done and did 150 across the board

but when i speed over 5k rpm the turbo or something that sounds similar almost like quick couple of backfires happens then my revs go all low and up and down. and when im cruising at 3k rpm and 50kph it bogs when i want to slowly speed up after a bump. i give more gas then it gets up to speed in a jolt

the oil smells strong almost like gas or like sharpy markers. it dosent seem to be burning any oil and the oil level has been good for the 3days plus 7hour drive.

on the drive home i added the octane booster the previous owner gave to me to the 91 octane gas from the highway gas stations. when the gas was out i put shell premium 91 octane and had problems until i added octane booster and let it sit for an hour or two

but it always bogged just a little with the 91 octane with octane booster and whatever gas it seems makes noise the odd time when in high rev boost. its also a bone stock ej20

could it be fuel filter, and previous owner may have ran 94 octane but isn't that to much for a stock ej20
* Registered users of the site do not see these ads.
joelkarlonas is offline   Reply With Quote
Old 04-17-2012, 10:55 PM   #2
Cbgrandtheftauto
Scooby Specialist
 
Member#: 184977
Join Date: Jul 2008
Chapter/Region: South East
Location: TN
Vehicle:
99 Impreza RS
'13 BRZ

Default

That does sound like a fuel filter. I'd figure it out and fix it pretty quickly. Rebuilding a motor in a car that you only had for a couple weeks sucks!!
Cbgrandtheftauto is offline   Reply With Quote
Old 04-17-2012, 11:13 PM   #3
eg33GC
Scooby Specialist
 
Member#: 206851
Join Date: Mar 2009
Chapter/Region: MWSOC
Vehicle:
99 V4
EJ20K RS

Default

Very likely the coils are gone
eg33GC is offline   Reply With Quote
Old 04-17-2012, 11:36 PM   #4
Drewbie
Scooby Newbie
 
Member#: 309709
Join Date: Feb 2012
Chapter/Region: RMIC
Location: Utah
Vehicle:
99 Rs coupe

Default

Quote:
Originally Posted by Cbgrandtheftauto View Post
Rebuilding a motor in a car that you only had for a couple weeks sucks!!
not when it's planned

Good luck with your car man. Those are sweet cars..
Drewbie is offline   Reply With Quote
Old 04-17-2012, 11:37 PM   #5
i_c_the_light
Scooby Guru
 
Member#: 88618
Join Date: Jun 2005
Chapter/Region: SCIC
Location: New Zealand
Vehicle:
1994 Legacy
"The Silver Slug"

Default

Ffs use 93.
i_c_the_light is offline   Reply With Quote
Old 04-18-2012, 05:17 AM   #6
Marnix
Scooby Specialist
 
Member#: 51480
Join Date: Dec 2003
Chapter/Region: International
Location: The Netherlands
Vehicle:
1984 AM5, 1994 BC4,
2010 BR5

Default

I also guess coils (spark blow out) and clean the boost solenoid too
Marnix is offline   Reply With Quote
Old 04-18-2012, 09:40 AM   #7
joelkarlonas
Scooby Newbie
 
Member#: 317169
Join Date: Apr 2012
Default

Does anyone know where i can get new coils spark plugs and all break pads for my car?

Id also like to know how much oil, trans fluid and rear diff fluid i need to fill those and ill get extra for flushes.

The previous owner ran 5w30 Mobil 1 so i think ill stick with it but what should i use for the trans and diff
joelkarlonas is offline   Reply With Quote
Old 04-18-2012, 10:32 AM   #8
Marnix
Scooby Specialist
 
Member#: 51480
Join Date: Dec 2003
Chapter/Region: International
Location: The Netherlands
Vehicle:
1984 AM5, 1994 BC4,
2010 BR5

Default

75W90 just like any other Subaru MT. Amounts are the same as USDM WRX EJ205
Marnix is offline   Reply With Quote
Old 04-18-2012, 12:57 PM   #9
joelkarlonas
Scooby Newbie
 
Member#: 317169
Join Date: Apr 2012
Default

Quote:
Originally Posted by Marnix
I also guess coils (spark blow out) and clean the boost solenoid too
Do you know how much coils would be each and would they be the same as usdm because the subaru where i am doesnt even have my oil filter.

And could it just be bad spark plugs rather than a coil pack or a couple

And would that be the cause of the bogging when cruising?
joelkarlonas is offline   Reply With Quote
Old 04-18-2012, 01:33 PM   #10
joelkarlonas
Scooby Newbie
 
Member#: 317169
Join Date: Apr 2012
Default

Could i just use a ej205 or 207 newer sti oil filter
joelkarlonas is offline   Reply With Quote
Old 04-18-2012, 02:21 PM   #11
joelkarlonas
Scooby Newbie
 
Member#: 317169
Join Date: Apr 2012
Default

Went for another drive, when i hit boost and it pulls you back then breaks off and makes sputtering backfire noises.

Engine sounds fine but after that happens the idle fluctuated
joelkarlonas is offline   Reply With Quote
Old 04-18-2012, 02:30 PM   #12
Zulu-
Scooby Specialist
 
Member#: 232213
Join Date: Dec 2009
Chapter/Region: South East
Location: Asheville, NC
Default

Ignition related. Check coils, plugs.
Zulu- is offline   Reply With Quote
Old 04-18-2012, 02:32 PM   #13
Zulu-
Scooby Specialist
 
Member#: 232213
Join Date: Dec 2009
Chapter/Region: South East
Location: Asheville, NC
Default

BTW, owner does not seem on par with the car. PM me if you ever want to unload it. ^_^
Zulu- is offline   Reply With Quote
Old 04-18-2012, 05:31 PM   #14
joelkarlonas
Scooby Newbie
 
Member#: 317169
Join Date: Apr 2012
Default

Im going to order new spark plugs tonight and a new oil filter and walbro 255 pump.

Im going to look for some vacuum leaks after work but how do i tell if the coils are bad
joelkarlonas is offline   Reply With Quote
Old 04-18-2012, 05:40 PM   #15
simer1228
Scooby Newbie
 
Member#: 171039
Join Date: Feb 2008
Chapter/Region: NESIC
Location: Burlington, Vermont
Vehicle:
99 RSTi Type-R LTD
Black Diamond Pearl

Default

use only 93 or higher octane gas!! STOP using mobil 1 5w-30 and switch to rotella T6 5w-40. and yes, most subaru oil filters can be used
simer1228 is offline   Reply With Quote
Old 04-18-2012, 08:03 PM   #16
joelkarlonas
Scooby Newbie
 
Member#: 317169
Join Date: Apr 2012
Default

Quote:
Originally Posted by simer1228
use only 93 or higher octane gas!! STOP using mobil 1 5w-30 and switch to rotella T6 5w-40. and yes, most subaru oil filters can be used
Would you agree spark plugs are my.boost problem?

Engine runs amazing but once i put it to the floor and build more that a little boost (hit high boost) it backfires like nother and i let off instantly then my revs go up and down. Stock everything
joelkarlonas is offline   Reply With Quote
Old 04-18-2012, 09:06 PM   #17
i_c_the_light
Scooby Guru
 
Member#: 88618
Join Date: Jun 2005
Chapter/Region: SCIC
Location: New Zealand
Vehicle:
1994 Legacy
"The Silver Slug"

Default

Quote:
Originally Posted by joelkarlonas

Would you agree spark plugs are my.boost problem?

Engine runs amazing but once i put it to the floor and build more that a little boost (hit high boost) it backfires like nother and i let off instantly then my revs go up and down. Stock everything
No. Replace coils and stop using crap fuel. 93MON or nothing.
i_c_the_light is offline   Reply With Quote
Old 04-18-2012, 10:03 PM   #18
69subaru360
Scooby Guru
 
Member#: 159682
Join Date: Sep 2007
Chapter/Region: NESIC
Location: Maine
Vehicle:
1995 WRX
1998 2.5 RS

Default

A 96 is a K not a G. It's not a coil on plug G and the K coil packs on top of the intake rarely fail. The K uses the orange label maf that always fails, that's more likely the problem.
69subaru360 is offline   Reply With Quote
Old 04-18-2012, 11:05 PM   #19
joelkarlonas
Scooby Newbie
 
Member#: 317169
Join Date: Apr 2012
Default

Quote:
Originally Posted by 69subaru360
A 96 is a K not a G. It's not a coil on plug G and the K coil packs on top of the intake rarely fail. The K uses the orange label maf that always fails, that's more likely the problem.
The maf is in my airbox right? Where can i get a new maf sensor
joelkarlonas is offline   Reply With Quote
Old 04-18-2012, 11:12 PM   #20
69subaru360
Scooby Guru
 
Member#: 159682
Join Date: Sep 2007
Chapter/Region: NESIC
Location: Maine
Vehicle:
1995 WRX
1998 2.5 RS

Default

Quote:
Originally Posted by joelkarlonas View Post
The maf is in my airbox right? Where can i get a new maf sensor
Yes and dealer. They aren't cheap, verify it's the problem first.
69subaru360 is offline   Reply With Quote
Old 04-18-2012, 11:37 PM   #21
i_c_the_light
Scooby Guru
 
Member#: 88618
Join Date: Jun 2005
Chapter/Region: SCIC
Location: New Zealand
Vehicle:
1994 Legacy
"The Silver Slug"

Default

Quote:
Originally Posted by 69subaru360
A 96 is a K not a G. It's not a coil on plug G and the K coil packs on top of the intake rarely fail. The K uses the orange label maf that always fails, that's more likely the problem.
Depends if the car was built in the first 1/2 of 1996 or not.
i_c_the_light is offline   Reply With Quote
Old 04-18-2012, 11:46 PM   #22
joelkarlonas
Scooby Newbie
 
Member#: 317169
Join Date: Apr 2012
Default

Quote:
Originally Posted by 69subaru360

Yes and dealer. They aren't cheap, verify it's the problem first.
How do i do that. What should i look for on the maf
joelkarlonas is offline   Reply With Quote
Old 04-18-2012, 11:47 PM   #23
joelkarlonas
Scooby Newbie
 
Member#: 317169
Join Date: Apr 2012
Default

Quote:
Originally Posted by 69subaru360

Yes and dealer. They aren't cheap, verify it's the problem first.
will it be broken
joelkarlonas is offline   Reply With Quote
Old 04-19-2012, 02:06 AM   #24
SilverSubiGC8
Scooby Newbie
 
Member#: 313024
Join Date: Mar 2012
Chapter/Region: W. Canada
Location: Edmonton
Vehicle:
1995 GC8 JDM
Silver

Default

Pull codes
SilverSubiGC8 is offline   Reply With Quote
Old 04-19-2012, 05:06 AM   #25
Marnix
Scooby Specialist
 
Member#: 51480
Join Date: Dec 2003
Chapter/Region: International
Location: The Netherlands
Vehicle:
1984 AM5, 1994 BC4,
2010 BR5

Default

First find out if you have a MY 96 EJ20G type RA or a MY97 EJ20K type RA. Oh and do use NGK PFR7B plugs.
Marnix is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB : Subaru Impreza WRX STi Type-RA R brochure Trinzler Private 'Wanted' Classifieds 0 12-24-2011 11:04 PM
My GC8 WRX STI Type-RA Limited dundunskeert Member's Car Gallery 7 05-09-2011 05:35 AM
1996 EDM WRX STi v-limited on ebay ScottPWRX General Community 0 01-22-2007 03:32 PM
WTB: 98 WRX STi Type-RA Version 4 ECU dRu888 Private 'Wanted' Classifieds 0 02-16-2006 08:05 PM
Black WRX STi Type-RA spotted in Dunedin, Florida!! TampaWRX South East Region Forum 5 03-28-2002 09:23 PM


All times are GMT -4. The time now is 04:46 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.