Welcome to the North American Subaru Impreza Owners Club Saturday August 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-16-2012, 12:14 PM   #1
werks04
Scooby Newbie
 
Member#: 201804
Join Date: Feb 2009
Chapter/Region: MAIC
Location: Virginia Beach
Vehicle:
2012 Impreza WRX
WRB

Exclamation AC Clutch Diagnosis

Hey guys and gals,

So last year AC stopped working, clutch was not engaging. I charged it up today and the clutch happily came back on. Now after I charged it, the belt began to slip, so I adjusted the tensioner to get rid of the slack. Now that the belt is tight, the clutch will engage but locks back up. I have attached a video for reference. Any help is appreciated as to whether the clutch needs lube somewhere or if needs to be replaced. Thank you in advance.

Vehicle is a 2004 WRX with 130K Miles

http://www.youtube.com/watch?v=NDls3...ature=youtu.be

Cheers!
* Registered users of the site do not see these ads.
werks04 is offline   Reply With Quote
Old 05-16-2012, 12:41 PM   #2
werks04
Scooby Newbie
 
Member#: 201804
Join Date: Feb 2009
Chapter/Region: MAIC
Location: Virginia Beach
Vehicle:
2012 Impreza WRX
WRB

Default

Well I just relieved the system of some R-134 and its working now! Easy fix! Looks like I overcharged it somehow the gauge was reading improperly.
werks04 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch diagnosis please subi lovers help 02jdmsubi Transmission (AT/MT) & Driveline 1 11-28-2011 04:43 AM
Tranny, clutch diagnosis?? Pirce39 Transmission (AT/MT) & Driveline 4 12-25-2009 08:38 PM
AC clutch/compressor Audiosavvy Engine/Power/Exhaust 3 04-24-2009 03:49 PM
ac clutch wont engage. Im in cali ugh mcganz121 Service & Maintenance 2 05-20-2008 07:03 PM
Torque Converter Lock-up Clutch Diagnosis Astralogical Transmission (AT/MT) & Driveline 5 10-15-2006 11:27 PM


All times are GMT -4. The time now is 01:02 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.