Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-16-2012, 10:49 AM   #501
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Every car "burns" oil. Some of us are just shocked that our brand new cars may have a thirst for it not seen since the mid 70's.
* Registered users of the site do not see these ads.
79letour is offline   Reply With Quote
Old 07-16-2012, 11:04 AM   #502
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

I've lost about a quarter inch on the dipstick after 1100+ miles. Not the end of the world but it is disappointing. Just going to keep vigilant.
79letour is offline   Reply With Quote
Old 07-16-2012, 01:15 PM   #503
Blanyer
Scooby Newbie
 
Member#: 307186
Join Date: Jan 2012
Chapter/Region: MAIC
Location: Pittsburgh, PA
Vehicle:
2012 Impreza
Marine Blue

Default

Quote:
Originally Posted by Zeeper

No, your car maybe, but most of our 2012 Impreza's aren't burning oil in any appreciable way.
Given that salesman at Cochran and Baierl in Pittsburgh have backed me up on this, and said my quart every 22-2500 is a little BETTER than average, I'm going to say it's more than a few outliers.

I'm trading mine on a Prius C next week, so I've stopped caring about the thirst for $8 quarts of oil and the seat that's driving my sciatica insane.
Blanyer is offline   Reply With Quote
Old 07-16-2012, 02:36 PM   #504
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

I wish the seats didn't incorporate all the airbag jazz. With these new cars, seat swaps are MUCH trickier than in the old days. Lol back when new cars didn't consume oil.
79letour is offline   Reply With Quote
Old 07-16-2012, 03:51 PM   #505
Zeeper
Scooby Specialist
 
Member#: 299286
Join Date: Oct 2011
Chapter/Region: NESIC
Location: Albany NY
Vehicle:
2012 Sport 5MT
Green/Silver

Default

Quote:
Originally Posted by Blanyer

Given that salesman at Cochran and Baierl in Pittsburgh have backed me up on this, and said my quart every 22-2500 is a little BETTER than average, I'm going to say it's more than a few outliers.

I'm trading mine on a Prius C next week, so I've stopped caring about the thirst for $8 quarts of oil and the seat that's driving my sciatica insane.
Of all the people posting here only a couple have verified that their car is burning oil -- and a few who just don't really know 'think' their car 'might' be burning oil.

My car hasn't needed an oil infusion and I'm about 4,000 miles in on my oil change.

Enjoy your Prius, you're the second person I've seen on the forums trade an impreza for a Prius. Maybe you'll run into him on your next car forum.
Zeeper is online now   Reply With Quote
Old 07-16-2012, 06:00 PM   #506
G-Omaha
Scooby Specialist
 
Member#: 209172
Join Date: Apr 2009
Location: Omaha, NE
Vehicle:
2012 Impreza CLL
BL2

Default

Prius C = Yaris Hybrid, et al... (Silly Wabbit)
G-Omaha is offline   Reply With Quote
Old 07-16-2012, 09:02 PM   #507
John451
Scooby Newbie
 
Member#: 321966
Join Date: Jun 2012
Location: Sydneys South, Australia
Vehicle:
2012 Impreza 2.0i H
Black Pearl

Default

Quote:
Originally Posted by 79letour View Post
But I'm now more aware of how innacurate and useless the dipstick markings are and am now dealing with professionals.
Have you worked out a consistent way to measure the oil, when I measured mine today after some 1500miles since the oil was changed last dealer service after engine is off for 1 minute it's under the "Full" mark but after 1 hour its half inch above the F ?.
John451 is offline   Reply With Quote
Old 07-17-2012, 01:35 PM   #508
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by John451 View Post
Have you worked out a consistent way to measure the oil, when I measured mine today after some 1500miles since the oil was changed last dealer service after engine is off for 1 minute it's under the "Full" mark but after 1 hour its half inch above the F ?.
usually you need to wait 3-5minutes before checking the oil so it can all drain back into the pan
flyboy1100 is offline   Reply With Quote
Old 07-17-2012, 01:51 PM   #509
auskip07
Scooby Specialist
 
Member#: 315643
Join Date: Apr 2012
Chapter/Region: South East
Location: Atlanta Ga
Vehicle:
2012 Impreza Sedan
DGM 5mt

Default

Quote:
Originally Posted by flyboy1100 View Post
usually you need to wait 3-5minutes before checking the oil so it can all drain back into the pan
when the engine is hot even after 10 min. my dip stick tube is coated with oil because i cant get an accurate reading.

(engine cold) is the lowest true reading i get. Since fluid expands with heat i think this to be the most accurate.
auskip07 is offline   Reply With Quote
Old 07-17-2012, 02:24 PM   #510
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

Quote:
Originally Posted by auskip07 View Post
when the engine is hot even after 10 min. my dip stick tube is coated with oil because i cant get an accurate reading.

(engine cold) is the lowest true reading i get. Since fluid expands with heat i think this to be the most accurate.
Yes, I too sometimes struggle to get a reliable reading because of the residual oil that gets scraped off the sides of the dip stick tube.

However, I believe the owner's manual says to check the oil when the engine is hot. So it's hard to know what the best process is.

At the end of the day, I think the main thing is to check for a consistent reading. Hot or cold, look for the level to not change from one reading to the next. One thing that helps with consistency is to always park the car in the same place for each reading. My car is always in the same place in my garage when I check my oil.
sgoldste01 is offline   Reply With Quote
Old 07-17-2012, 05:23 PM   #511
enfinityx
Scooby Newbie
 
Member#: 326440
Join Date: Jul 2012
Vehicle:
2012 impreza

Default

i'd like to chime in with my own experience. im at 7000 kilometers right now. No oil consumption issues or anything even during break in periods (i checked a little more frequently during this time because i heard people say engines could burn oil during break-in, however i had none of this issue).
enfinityx is offline   Reply With Quote
Old 07-17-2012, 09:59 PM   #512
ZionZR2
Scooby Newbie
 
Member#: 319990
Join Date: May 2012
Chapter/Region: TXIC
Location: Austin, TX
Vehicle:
2012 Imp Prm 5D CVT
Dark Grey Metallic

Default

now at 2500 miles and the only oil loss I am seeing is whats dabbed on the paper towel from checking oil levels
ZionZR2 is offline   Reply With Quote
Old 07-18-2012, 08:38 AM   #513
FourOhFour
Scooby Newbie
 
Member#: 309509
Join Date: Feb 2012
Vehicle:
2012 Impreza

Default

Quote:
Originally Posted by sgoldste01 View Post
However, I believe the owner's manual says to check the oil when the engine is hot. So it's hard to know what the best process is.
The service manual says "As the oil level gauge is used for daily maintenance, F line and L line is set assuming that the engine is cold."

I'm too lazy to fish my owner's manual out of the car, but it wouldn't surprise me if it disagrees. Heh.
FourOhFour is offline   Reply With Quote
Old 07-18-2012, 09:15 AM   #514
auskip07
Scooby Specialist
 
Member#: 315643
Join Date: Apr 2012
Chapter/Region: South East
Location: Atlanta Ga
Vehicle:
2012 Impreza Sedan
DGM 5mt

Default

Quote:
Originally Posted by FourOhFour View Post
The service manual says "As the oil level gauge is used for daily maintenance, F line and L line is set assuming that the engine is cold."

I'm too lazy to fish my owner's manual out of the car, but it wouldn't surprise me if it disagrees. Heh.
that would explain why mine reads very high when hot and perfectly on the H line when cold.
auskip07 is offline   Reply With Quote
Old 07-18-2012, 09:42 AM   #515
Haunty
Scooby Newbie
 
Member#: 319378
Join Date: May 2012
Chapter/Region: MWSOC
Location: West Central MN
Vehicle:
2012 2.0i Sport Ltd.
Satin White Pearl

Default

I haven't noticed much difference between the hot and cold reading, maybe 1/8 inch at the most.
Haunty is offline   Reply With Quote
Old 07-18-2012, 09:50 AM   #516
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

^same here
79letour is offline   Reply With Quote
Old 07-22-2012, 11:39 PM   #517
ALafya
Scooby Newbie
 
Member#: 293105
Join Date: Aug 2011
Default

I read somewhere that someone had their oil filter changed to a model number which is not compatible with the 12 Impreza then had high oil level:
2012 Impreza you MUST USE part 15208AA160 or it wont function correctly. The dealer had put on part 15208AA130 which can ONLY be switched on the Forester NOT the Impreza.
I wonder if the people changing their oil at a dealership had a similar mix-up.
ALafya is offline   Reply With Quote
Old 07-23-2012, 09:32 AM   #518
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Not mine. Its alwasys had "160" filters.
79letour is offline   Reply With Quote
Old 07-23-2012, 10:58 AM   #519
Impreza1228
Scooby Newbie
 
Member#: 325234
Join Date: Jul 2012
Location: NC
Vehicle:
2012 Impreza Pre CVT

Default

Quote:
Originally Posted by 79letour View Post
Not mine. Its alwasys had "160" filters.

I second that I also used the 160 filter. I have 6100 miles no oil consumption issues.
Impreza1228 is offline   Reply With Quote
Old 07-23-2012, 11:02 AM   #520
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

Quote:
Originally Posted by Impreza1228 View Post
I second that I also used the 160 filter. I have 6100 miles no oil consumption issues.
Good to hear. At what mileage have you done oil changes so far? What oil did you use?
sgoldste01 is offline   Reply With Quote
Old 07-23-2012, 11:18 AM   #521
Impreza1228
Scooby Newbie
 
Member#: 325234
Join Date: Jul 2012
Location: NC
Vehicle:
2012 Impreza Pre CVT

Default

Quote:
Originally Posted by sgoldste01 View Post
Good to hear. At what mileage have you done oil changes so far? What oil did you use?

5140 first oil change Subaru oil 0w 20 and oem filter and washer I did the oil change myself. I followed owners manual for break in and this is a daily driver I have taken several trips since purchased in Dec of last year with 0% oil consumption so far. Most of my trips are 50 miles or less with half dozen approximately 300 miles one way.

When I changed the oil only 5 quarts drained out, so that is the amount I put back in. The oil level after warming up was at full mark and has remained there for approximately last 1000 miles since change occurred.

Now this car was purchased 12/11 with build date of 9/11.
Impreza1228 is offline   Reply With Quote
Old 07-23-2012, 10:40 PM   #522
John451
Scooby Newbie
 
Member#: 321966
Join Date: Jun 2012
Location: Sydneys South, Australia
Vehicle:
2012 Impreza 2.0i H
Black Pearl

Default

Quote:
Originally Posted by flyboy1100 View Post
usually you need to wait 3-5minutes before checking the oil so it can all drain back into the pan
Checked my dipstick cold this morning after resting overnight and then again after being driven then rested for 5 minutes, both times indicate the Level is approx 12mm or nearly a 1/2 inch above the Full mark. Checked it both times on the same location on my garage floor which my spirit level says is near perfectly flat.

As I've not added in any oil since the dealer oil change some 2000miles ago does anyone think approx 1/2 inch above the Full mark would cause any problems ?
John451 is offline   Reply With Quote
Old 07-23-2012, 10:59 PM   #523
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by John451 View Post
Checked my dipstick cold this morning after resting overnight and then again after being driven then rested for 5 minutes, both times indicate the Level is approx 12mm or nearly a 1/2 inch above the Full mark. Checked it both times on the same location on my garage floor which my spirit level says is near perfectly flat.

As I've not added in any oil since the dealer oil change some 2000miles ago does anyone think approx 1/2 inch above the Full mark would cause any problems ?
i've decided the dipstick is wrong since the amount required by the manual fills it over the mark. I'm not worrying about it.
flyboy1100 is offline   Reply With Quote
Old 07-24-2012, 02:36 AM   #524
John451
Scooby Newbie
 
Member#: 321966
Join Date: Jun 2012
Location: Sydneys South, Australia
Vehicle:
2012 Impreza 2.0i H
Black Pearl

Default

Quote:
Originally Posted by flyboy1100 View Post
i've decided the dipstick is wrong since the amount required by the manual fills it over the mark. I'm not worrying about it.
Reason I've become interested is during a cold start at any time of the day from the Imprezas exhaust there is a light amount of light grey smoke that appears about 30 seconds after starting and carry's on for about a minute, doesn't appear to be just water vapour as smells faintly of oil.

While I know some white smoke from water vapour on cold mornings is normal as this occurs during a cold start any time of day haven't noticed this on any other new car I've ever owned so was wondering if this is normal for a Subaru's flat 4 ?
John451 is offline   Reply With Quote
Old 07-24-2012, 03:47 AM   #525
JoshAvila
Scooby Newbie
 
Member#: 326275
Join Date: Jul 2012
Chapter/Region: BAIC
Location: Tracy, ca
Vehicle:
2012 Impreza wrx
Gray

Default

I'm at 5500 miles now and I've lost 2 qts so far :/
JoshAvila is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Are there any DIY independent fog lights write ups yet for 2012 impreza sports? JDMSTA Electrical & Lighting 59 07-21-2013 08:04 AM
2012 Impreza 2.0i Mobil1 oil filter model # jr0bb5 Service & Maintenance 27 01-04-2013 05:18 PM
('11+) OC interval and the first oil change on 2012 Impreza 2.0 Oceanguy Impreza Forum 80 11-18-2012 12:56 PM
My Oil Light is Flickering and I have No Leak??? kakarotoni Newbies & FAQs 39 08-16-2012 10:36 AM
('11+) 2012 Impreza High beams = Low beams lighting Jmzda Impreza Forum 28 06-01-2012 12:14 PM


All times are GMT -4. The time now is 07:14 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.