Welcome to the North American Subaru Impreza Owners Club Thursday January 29, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-29-2012, 08:52 AM   #1976
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

I did my first oil change at 1700 miles, and then my next oil change at 6700 miles (I'm on a 5k mile oil change interval). I used Amsoil OE 0W20 both times, which is a full synth oil that costs approximately $6.50/quart. I pick up up directly from a distributor here in town, so I don't pay any shipping charges.

I also buy a 3-pack of Subaru 160 oil filters on eBay for approximately $7/filter. I don't need crush washers because I installed a Fumoto valve as part of my first oil change.

My oil consumption has been negligible.
* Registered users of the site do not see these ads.
sgoldste01 is offline   Reply With Quote
Old 11-29-2012, 09:59 AM   #1977
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Right. Well, again, I'm really glad you got a good car, Steve. Esapecially since VW sucked so badly for you.

My newest noise/irritation/problem is a loud clunk when I stop. Its coming from the passenger side rear about every few times I brake. May be a shock absorber.
Its coming up on a year of ownership soon. This car has added a lot of unnecessary stress this year. But after countless hours reading over forums and google, I'm VERY glad not to be one of the MANY unhappy FR-S/BRZ owners.
I'm still fighting with USAA about my rates. My cars VIN apparently denotes that its a 2012 WRX premium. I asked soa about this, no response. Several attempts now. So I'm paying 200 a month because of my VIN#.
Had I known I'd be paying WRX insurance rates, and having to constantly monitor and maintain this silly car, I deeply, DEEPLY regret not buying a wrx.
79letour is offline   Reply With Quote
Old 11-29-2012, 10:13 AM   #1978
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

Quote:
Originally Posted by 79letour View Post
I'm still fighting with USAA about my rates. My cars VIN apparently denotes that its a 2012 WRX premium. I asked soa about this, no response. Several attempts now. So I'm paying 200 a month because of my VIN#.
Had I known I'd be paying WRX insurance rates, and having to constantly monitor and maintain this silly car, I deeply, DEEPLY regret not buying a wrx.
Huh, that's interesting. Is that a SOA problem or an insurance industry problem? It seems to me that you should be able to drive your Impreza to your insurance agent's office, drag him/her out to the car, prove that it's not a WRX, and then get a rate adjustment and a retroactive refund.

But I realize we're talking about the insurance industry here, and I loathe the insurance industry.
sgoldste01 is offline   Reply With Quote
Old 11-29-2012, 11:40 AM   #1979
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

I hate insurance co's every bit as much as SOA! If not, more!
They don't have a local office at USAA as far as I know. My aunt is the manager at Progressive, and my cousin is a state farm agent. They all gave me the same quotes roughly. All told me I needed to contact subaru, which io did. Mastro said they'd look into it, among other things that didn't get accomplished.
Usaa says that they're stuck because of the vin. If I call them with any other 2012 impreza vin, the rate goes down a LOT.
Dreaming here- I wish they'd just put my vin on a wrx and trade it out for the pos I currently have. In a perfect world...
79letour is offline   Reply With Quote
Old 11-29-2012, 12:21 PM   #1980
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by auskip07

Actually its typical to never run full synthetic in a new engine. Regular oil is slightly more abrasive and helps to break in all the internals.

of course i didnt have any consumption troubles so i cant help but wonder if that is true but i would follow it and its typical to do a break in oil change at 1k then 3k then normal changes. so cost could come into play when you are doing a change as often.
My point was the dealer is going against subaru recommendations on a brand new vehicle. I wouldn't risk my warranty on it, ultimately it is your car so you are responsible
flyboy1100 is offline   Reply With Quote
Old 11-29-2012, 12:23 PM   #1981
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by 79letour
I hate insurance co's every bit as much as SOA! If not, more!
They don't have a local office at USAA as far as I know. My aunt is the manager at Progressive, and my cousin is a state farm agent. They all gave me the same quotes roughly. All told me I needed to contact subaru, which io did. Mastro said they'd look into it, among other things that didn't get accomplished.
Usaa says that they're stuck because of the vin. If I call them with any other 2012 impreza vin, the rate goes down a LOT.
Dreaming here- I wish they'd just put my vin on a wrx and trade it out for the pos I currently have. In a perfect world...
It us an insurance problem, I almost had the same problem with Horace Mann
flyboy1100 is offline   Reply With Quote
Old 11-29-2012, 12:34 PM   #1982
pgh88
Scooby Newbie
 
Member#: 316756
Join Date: Apr 2012
Default

First oil change at 3k and I have almost 2k on current and I can not get the oil to come down from a little past full if I tried. This weekend I put 200 miles of 80+ mph highway and mountain manual mode high rev driving and level does not move at all.
pgh88 is offline   Reply With Quote
Old 11-29-2012, 01:19 PM   #1983
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Right. You obviously have one of the GOOD ones. Congrats.
Don't let Zeeper know you went that fast. He'll point it out every time you post.
79letour is offline   Reply With Quote
Old 11-29-2012, 01:37 PM   #1984
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Being that so many don't seem to use a DROP, one would think Subaru would be more proactive in helping those of us out who bought cars with issues.
79letour is offline   Reply With Quote
Old 11-29-2012, 02:30 PM   #1985
Zeeper
Scooby Specialist
 
Member#: 299286
Join Date: Oct 2011
Chapter/Region: NESIC
Location: Upstate NY
Vehicle:
2015 WRX CVT
White

Default

Quote:
Originally Posted by 79letour View Post
Right. You obviously have one of the GOOD ones. Congrats.
Don't let Zeeper know you went that fast. He'll point it out every time you post.
80mph+ and 129mph+ (aka you wanted to see how fast you could make a 2012 impreza go) are really two different things as far as stress on the engine.

And people wonder why manufacturers install rev limiters...

Last edited by Zeeper; 11-29-2012 at 03:38 PM.
Zeeper is online now   Reply With Quote
Old 11-29-2012, 02:39 PM   #1986
ccgood
Scooby Newbie
 
Member#: 302769
Join Date: Dec 2011
Default Mine consumes as well

My 2012 2.0i Sport Limited was delivered 12/23/11, did my first oil change at 3k in 3/12. When July 12 came around, I had about 7k miles on the car, I had a few long trips planned and my car threw the oil low light while driving on the highway. I pulled off at a Napa, checked the oil and found it to be just below the min level. I topped it off and called the dealer to do the 7500 oil change and brought up the issue. They told me there was nothing they could do at that time but complete the oil change and just keep an eye on it, but also to not top off if this issue reoccured. So now, in 11/12 I am around 12k miles (about 2200 miles short of my 15k oil change) and the light came on again. I checked the level and found it to be just slightly above the min level, so I called up the dealer and scheduled an apt (also to reflash the OBD). After the visit, the Service representative brought out the "up to 1 quart in 1,200 miles" consumption as normal. We started a consumtion test, as I still plan on having the 15k oil change (~2months or so).

So I guess add me to the list. I am not happy about it, nor do I feel content with the fact that I could potentially need to add up to 6.25 quarts (7500 [mile] /1200 [mile/qt]) between oil changes, as per the warranty.

I kinda of just started looking for this topic today, so if this has been stated anywhere Im sorry for asking the question, but, is there anything being done by either SOA or some community of owners who are having this issue.
ccgood is offline   Reply With Quote
Old 11-29-2012, 03:36 PM   #1987
jr0bb5
Scooby Specialist
 
Member#: 315353
Join Date: Apr 2012
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sp Prem
5MT OBP/DGM

Default

Quote:
Originally Posted by ccgood View Post
My 2012 2.0i Sport Limited was delivered 12/23/11, did my first oil change at 3k in 3/12. When July 12 came around, I had about 7k miles on the car, I had a few long trips planned and my car threw the oil low light while driving on the highway. I pulled off at a Napa, checked the oil and found it to be just below the min level. I topped it off and called the dealer to do the 7500 oil change and brought up the issue. They told me there was nothing they could do at that time but complete the oil change and just keep an eye on it, but also to not top off if this issue reoccured. So now, in 11/12 I am around 12k miles (about 2200 miles short of my 15k oil change) and the light came on again. I checked the level and found it to be just slightly above the min level, so I called up the dealer and scheduled an apt (also to reflash the OBD). After the visit, the Service representative brought out the "up to 1 quart in 1,200 miles" consumption as normal. We started a consumtion test, as I still plan on having the 15k oil change (~2months or so).

So I guess add me to the list. I am not happy about it, nor do I feel content with the fact that I could potentially need to add up to 6.25 quarts (7500 [mile] /1200 [mile/qt]) between oil changes, as per the warranty.

I kinda of just started looking for this topic today, so if this has been stated anywhere Im sorry for asking the question, but, is there anything being done by either SOA or some community of owners who are having this issue.
Good luck buddy... most of us are just getting the run-around from our dealers/SOA. Hopefully you'll have better luck, but I wouldn't be too optimistic. Unless your car is burning more than a quart per 1200 miles, you're just gonna be told that it's normal consumption and to "keep your eye on it." Wish I had better news for ya. Keep pressing the issue though! Who knows, maybe something will be done... eventually.

Last edited by jr0bb5; 11-29-2012 at 03:42 PM.
jr0bb5 is online now   Reply With Quote
Old 11-29-2012, 03:38 PM   #1988
jr0bb5
Scooby Specialist
 
Member#: 315353
Join Date: Apr 2012
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sp Prem
5MT OBP/DGM

Default

79, that's crazy that you're having that insurance problem! I think someone or something is trying to tell you that you should have never bought that car and to dump it as soon as possible...
jr0bb5 is online now   Reply With Quote
Old 11-29-2012, 03:45 PM   #1989
jd_24
Scooby Newbie
 
Member#: 318301
Join Date: Apr 2012
Location: Minnesota
Vehicle:
2012 CVT Sport Prem
Ice Silver Metalic

Default

Quote:
Originally Posted by 79letour View Post
I'm still fighting with USAA about my rates. My cars VIN apparently denotes that its a 2012 WRX premium. I asked soa about this, no response. Several attempts now. So I'm paying 200 a month because of my VIN#.
Had I known I'd be paying WRX insurance rates, and having to constantly monitor and maintain this silly car, I deeply, DEEPLY regret not buying a wrx.
Interesting. I also have USAA, but I'm fairly sure my Impreza Sport Prem. is listed as that with them and not a WRX. I think I'll double check it.
jd_24 is offline   Reply With Quote
Old 11-29-2012, 04:27 PM   #1990
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

My ins card says WRX.
I just wish the car matched it!!!
@ douchebag Zeeper- I've never hit the rev limiter. For all I know, I may actually wind out to the *150* indicated. But it got up to 125-130 pretty easily. Long straight roads from New Smyrna to lake county. My Kawi will BURY the speedo at 170 real quickly. Its never burnt any oil. And I've abused it like a pakistani dog. Driving fast doesn't void the warranty.
PLENTY of people seem to have engines burning oil, they keep trickilng in as seen above, and google is getting more hits on consumption searches.
@ccGood- sorry, man, sounds like your car is doing it too. Call SOA and let them know as a consumer, that you don't feel like you got the product you were expecting and that using that much oil is unacceptable no matter what they print in a manual. People need to satand up for their rights as consumers.
79letour is offline   Reply With Quote
Old 11-29-2012, 04:33 PM   #1991
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Jd- please let me know if your card says wrx.
What alerted me was usaa calling (in typical insurance creep fashion) to re-ask me all the same quesations as when I added the car. The rep said "how many miles a year are you driving the wrx premium?". Then I called with the vin of a 2011 wrx for sale. The 2011 wrx would be $300 a year cheaper to insure than my 2012 2.0i premium. A different 2012 impreza sport limited would be something like $500 or so cheaper.
79letour is offline   Reply With Quote
Old 11-29-2012, 04:53 PM   #1992
TObject
Scooby Newbie
 
Member#: 320185
Join Date: May 2012
Vehicle:
2012 Impreza 2.0i

Default

Quote:
Originally Posted by 79letour View Post
I wonder if anyones installed an oil catch can on one of these cars.
We should not really need catch cans as our cars do not use direct injection.

But in your case it may be interesting to see.
TObject is offline   Reply With Quote
Old 11-29-2012, 05:02 PM   #1993
Zeeper
Scooby Specialist
 
Member#: 299286
Join Date: Oct 2011
Chapter/Region: NESIC
Location: Upstate NY
Vehicle:
2015 WRX CVT
White

Default

Maybe your insurance issue is because your insurance company found out you are driving your car 130mph...so that is why they think it is a WRX?
Zeeper is online now   Reply With Quote
Old 11-29-2012, 05:22 PM   #1994
Impreza1228
Scooby Newbie
 
Member#: 325234
Join Date: Jul 2012
Location: NC
Vehicle:
2012 Impreza Pre CVT

Default

Quote:
Originally Posted by 79letour View Post
Jd- please let me know if your card says wrx.
What alerted me was usaa calling (in typical insurance creep fashion) to re-ask me all the same quesations as when I added the car. The rep said "how many miles a year are you driving the wrx premium?". Then I called with the vin of a 2011 wrx for sale. The 2011 wrx would be $300 a year cheaper to insure than my 2012 2.0i premium. A different 2012 impreza sport limited would be something like $500 or so cheaper.
79 what showings on your title? I'm sure could fax a copy of the title to rep at usaa and get that straightened out. I also have usaa and never had any problems with them they have been best insurance company I ever had so far.


What about gtp to trade for something else.
Impreza1228 is offline   Reply With Quote
Old 11-29-2012, 05:26 PM   #1995
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Lol. Zeeper. Dick.

Last edited by 79letour; 11-29-2012 at 05:36 PM.
79letour is offline   Reply With Quote
Old 11-29-2012, 05:48 PM   #1996
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

I'll look at my paperwork again when I get home, 1228.
I would love to trade for something else. But I have a broken seat, and oil consumption, and I don't think I should have to eat a $4000 loss because subaru built me a crappy car, man. Ideally, I'd like a pre-tsunami wrx.
But for now, I'm stuck with this car it seems.
The Fiesta ST will definitely be something I'd want to test drive.
79letour is offline   Reply With Quote
Old 11-29-2012, 05:58 PM   #1997
Zeeper
Scooby Specialist
 
Member#: 299286
Join Date: Oct 2011
Chapter/Region: NESIC
Location: Upstate NY
Vehicle:
2015 WRX CVT
White

Default

Quote:
Originally Posted by 79letour View Post
Lol. Zeeper. Dick.
You edited it and still ended up with this lame post?

Anyway, it is your own fault.

You brought me back to reply to your post because you mentioned me. Peace brother.
Zeeper is online now   Reply With Quote
Old 11-29-2012, 06:44 PM   #1998
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Peace, brother? Damn man, that's the nicest thing I've ever read from ya!
And also with you!
Really!

I didn't mean to bring you back in for more bickering, and my comment was admittedly smartassed, but I meant you no offense, thought you might even get a chuckle.
Peace, brother!
79letour is offline   Reply With Quote
Old 11-29-2012, 07:12 PM   #1999
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Since I have a lien on it, I don't have the actual title. The lien paperwork just has make (subaru) and body type (sw) and weight (2954). Well, it also has the vin, but I'm not going to be publishing that
Yet. Once its gone, I'll let yall know which vin to avoid.
79letour is offline   Reply With Quote
Old 12-01-2012, 08:17 PM   #2000
jr0bb5
Scooby Specialist
 
Member#: 315353
Join Date: Apr 2012
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sp Prem
5MT OBP/DGM

Default

Well it appears as though I have a frozen front caliper... pulled into my work parking lot and all of a sudden heard this god awful grinding/squealing noise from the front end. I also smelled something burning. I know I didn't hit or run over anything at the time, so that's the only thing I can think of. What a royal PITA! I know **** happens, but I'm becoming more and more dissapointed in this car on almost a daily basis. What sucks the worst is that my dealership is closed tomorrow and I'm supposed to use my car all day for work... not cool.

I know this thread is mostly dedicated to oil consumption, but this seems like the main thread for problems concerning the 12+ impreza... plus I didn't want to start a new thread.

On a side note, I'm using my boss's 09 Camry at the moment and what a comfy, smooth, quiet ride compaired to my impreza! I know comparing the 2 cars is like comparing apples to oranges, but it makes me not want driving my impreza again...

Last edited by jr0bb5; 12-02-2012 at 01:07 PM.
jr0bb5 is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Are there any DIY independent fog lights write ups yet for 2012 impreza sports? JDMSTA Electrical & Lighting 59 07-21-2013 09:04 AM
2012 Impreza 2.0i Mobil1 oil filter model # jr0bb5 Service & Maintenance 27 01-04-2013 06:18 PM
('11-'14) OC interval and the first oil change on 2012 Impreza 2.0 Oceanguy Impreza Forum 80 11-18-2012 01:56 PM
My Oil Light is Flickering and I have No Leak??? kakarotoni Newbies & FAQs 39 08-16-2012 11:36 AM
('11-'14) 2012 Impreza High beams = Low beams lighting Jmzda Impreza Forum 28 06-01-2012 01:14 PM


All times are GMT -4. The time now is 08:51 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.