Welcome to the North American Subaru Impreza Owners Club Wednesday October 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-08-2012, 12:35 PM   #2026
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

Quote:
Originally Posted by pgh88 View Post
My advice is to sell it. Thats what I did. Even though I had none of your issues I thought it was underpowered and returned poor MPG at least for me. Believe it or not after 8 months into a 42 month lease I lost 1,500 dollars on a trade
You can break a lease early? What did you buy instead?
* Registered users of the site do not see these ads.
sgoldste01 is offline   Reply With Quote
Old 12-08-2012, 06:10 PM   #2027
pgh88
Scooby Newbie
 
Member#: 316756
Join Date: Apr 2012
Default

Sure you can. The dealer just pays off the car, but there is no tax advantage between the two since you don't pay taxes up front on the lease. I bought a 13 Honda Accord EXL. I know apples and oranges but at 54 I wanted something a little more high end. The Impreza is a good car. Honda's CVT is amazing. I thought Subarus second gen CVT was good but the Honda is even better. I understand it is a in house design vs a Jacto build with Subaru
pgh88 is offline   Reply With Quote
Old 12-09-2012, 12:56 AM   #2028
KevinT.
Scooby Newbie
 
Member#: 291684
Join Date: Aug 2011
Chapter/Region: NESIC
Location: Dutchess Ny
Vehicle:
2004 Rs (Wrx Swap)
San Remo Red

Default

You know, you seem to complain a lot 79, if your "problems" are really THAT bad to warrent a 82 page thread and multiple other accounts of you complaining, just sell your car and buy a kia, im sure youll be much happier with that.
KevinT. is offline   Reply With Quote
Old 12-09-2012, 04:37 AM   #2029
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Thanks for the input asswipe. Go enjoy your car. Do you even own one of these?
79letour is offline   Reply With Quote
Old 12-10-2012, 09:49 PM   #2030
BretAZ
Scooby Newbie
 
Member#: 320866
Join Date: May 2012
Default

2012 sport limited w 13,100 miles. Bought new in may. Oil light is dimly illuminted. When I turn the headlights off it goes out but comes back on when I turn the headlights back on. Oil was changed at 3k and 7,500.

Without reading back through all this can someone tell me what it is and what Subaru is doing about it.
BretAZ is offline   Reply With Quote
Old 12-10-2012, 09:57 PM   #2031
jr0bb5
Scooby Specialist
 
Member#: 315353
Join Date: Apr 2012
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sp Prem
5MT OBP/DGM

Default

Quote:
Originally Posted by BretAZ View Post
Without reading back through all this can someone tell me what it is and what Subaru is doing about it.
To sum it up... nothing. Well not much anyway. No one knows 100% what the issue is, but people think it may have to do with the new low tension rings. There are a few rumors of people getting new engines or piston ring replacements, but who knows for sure.

Just a heads up tho, unless you're burning over a quart every 1200 miles, youre not going to get anywhere with SOA or their dealers.
jr0bb5 is offline   Reply With Quote
Old 12-10-2012, 10:12 PM   #2032
BretAZ
Scooby Newbie
 
Member#: 320866
Join Date: May 2012
Default

When I was in last oil change, I asked the service advisor about the oil light issue. She said it was due to a too short of wire on one of the sensors. Hadn't been following this issue since I wasn't having it, but it appears that most will experience it sooner or later.
BretAZ is offline   Reply With Quote
Old 12-10-2012, 10:29 PM   #2033
jr0bb5
Scooby Specialist
 
Member#: 315353
Join Date: Apr 2012
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sp Prem
5MT OBP/DGM

Default

Quote:
Originally Posted by BretAZ View Post
When I was in last oil change, I asked the service advisor about the oil light issue. She said it was due to a too short of wire on one of the sensors. Hadn't been following this issue since I wasn't having it, but it appears that most will experience it sooner or later.
Oops... guess i misunderstood. I didn't realize you were just talking about the dash light issue. I thought you were having oil consumption problems.
jr0bb5 is offline   Reply With Quote
Old 12-11-2012, 12:26 AM   #2034
BretAZ
Scooby Newbie
 
Member#: 320866
Join Date: May 2012
Default

Actually I am not sure what the problem is yet. I didn't realize there were a couple different issues. I hope its not low on oil, but that may very well be the case since I am nearing the end of this oil change interval. I will check it tomorrow.

I have owned a lot of cars. None of them have burned oil in any significant amount. If this caris burning oil, she wont be around long, and it will be my last Subaru.

I will contact the dealer tomorrow and see what they say.
BretAZ is offline   Reply With Quote
Old 12-11-2012, 05:17 AM   #2035
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

A dimly lit oil light is not indicative of an oil consumption issue. That problem is electrical.
sgoldste01 is offline   Reply With Quote
Old 12-11-2012, 07:36 AM   #2036
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Yeah, sensors and lights, and actually losing/burning oil are seperate issues. Although I'd like to hear what gets fixed!

At 2110mi, I'm down over a quart. 5w30 in cooler weather got me this, so I'm hoping for a quart per 1200 with w20 in the spring/summer. Its a shame to have to "hope my new car burns ENOUGH oil".
79letour is offline   Reply With Quote
Old 12-11-2012, 07:38 AM   #2037
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

It burned most of that quart in the first thusand miles, and then slowed up for the last thousand. Changing it to 0w20 this weekend. Experiment failed.
79letour is offline   Reply With Quote
Old 12-11-2012, 07:57 AM   #2038
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

You've only got 2k on your current fill of oil. Why change it now? Might as well get a full 5k out of it, for expense and environmental reasons if nothing else.
sgoldste01 is offline   Reply With Quote
Old 12-11-2012, 10:00 AM   #2039
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Because I don't want to keep racking up miles. I'm ready to see what putting in the RIGHT amount of w20 does.
Plus- I need to buy another quart to top it off, and don't feel like buying more 5w30. I already have all the stuff to do the change.
I only intended to keep this w30 in long enough to see what the rate of consumption would be.
Now back to the reccomended viscosity.
I'm now very sure of the fact that the dealers overfilling caused a lot of confusion about consumption rate. A dealer over-fill may have even caused this. At least its all documented. Damn, soa REALLY should shut down Bill Bryan, I can't believe they'd let such a shady dealer keep going. They definitely have a hard time selling subarus. And they don't bother with the service end of things...
79letour is offline   Reply With Quote
Old 12-11-2012, 12:13 PM   #2040
BretAZ
Scooby Newbie
 
Member#: 320866
Join Date: May 2012
Default

So this morning, the light was not on and would not come on. For those of you that have had the light come on, was is fully lit or just dim? Did it come and go or did it stay illuminated after it initially came on?
BretAZ is offline   Reply With Quote
Old 12-11-2012, 12:35 PM   #2041
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by BretAZ View Post
So this morning, the light was not on and would not come on. For those of you that have had the light come on, was is fully lit or just dim? Did it come and go or did it stay illuminated after it initially came on?
This thread is primarily about the low level light, and it is bright.

The dim light has been oil pressure afaik and it is electrical related
flyboy1100 is offline   Reply With Quote
Old 12-11-2012, 01:15 PM   #2042
BretAZ
Scooby Newbie
 
Member#: 320866
Join Date: May 2012
Default

Nice that we have oil lights coming on for different reasons and Subaru has not addressed either of these issues.
BretAZ is offline   Reply With Quote
Old 12-11-2012, 02:11 PM   #2043
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by BretAZ View Post
Nice that we have oil lights coming on for different reasons and Subaru has not addressed either of these issues.
very few people had the dim pressure light, it is a bad wire harness and I believe all were fixed no hassle
flyboy1100 is offline   Reply With Quote
Old 12-11-2012, 02:14 PM   #2044
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

I'd really be pissed if my OP light were on. MOST likely electrical though.
Last time my light came on, it did what it always does, it stayed brighly lit (in amber) until I shut the car down and add oil.
If your dipstick is staying at the same level, that is good. If you're regularly losing oil pressure it won't take long till you end up getting a new engine!
79letour is offline   Reply With Quote
Old 12-11-2012, 02:23 PM   #2045
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Bret- there's a youtube vid of the dip op light, iirc. Search for it and see if its the same issue as yours.
79letour is offline   Reply With Quote
Old 12-12-2012, 05:03 PM   #2046
ST Eye
Scooby Specialist
 
Member#: 73068
Join Date: Oct 2004
Location: MD
Vehicle:
2008 STI Boost Wagon
2014 Honda Accord Hybrid

Default

Overfill no more than a quart should not create a consumption issue.
ST Eye is offline   Reply With Quote
Old 12-12-2012, 11:19 PM   #2047
djbono
Scooby Newbie
 
Member#: 208098
Join Date: Apr 2009
Default

Went in for my 2nd (of 3) visits for consumption test, after 1500km (they had asked 1600, but I'm leaving in the morning and will be travelling 1000+kms within the next few days.)

First visit's result, after 2000km: 0.5L missing (but they had overfilled by a good inch more on the stick (several readings, days appart)).

>>Today's results, after 1500km: 0.5L missing, again.

BTW: I saw a young mechanic go out the front door, bottle of 0w20 in had - got to here my car was parked, just read oil level on the stick I presume, and added some in. That's a very scientific "consumtion test"....

After some time, the service clerk came back with yet the same dirty piece of paper, bearing the news about the 0.5L missing. But he claimed this was my third & final visit...wtf...

Anyways - want to hear the funniest ?
He told me the tolerance was 1L/1000km !?!?!?!?!?!?!

I believe, when this first started for me almost a year ago, I had read somewhere the tolerance was 1L/3000km - then it became 1L/2000km.
1L/1000km is downright outreageous.

I gave him little hell but I don't have the energy to fight anymore on this, so I simply laughed at him.
1L/1kkm... I have to check with APA ...
djbono is offline   Reply With Quote
Old 12-13-2012, 06:31 AM   #2048
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by djbono View Post
Went in for my 2nd (of 3) visits for consumption test, after 1500km (they had asked 1600, but I'm leaving in the morning and will be travelling 1000+kms within the next few days.)

First visit's result, after 2000km: 0.5L missing (but they had overfilled by a good inch more on the stick (several readings, days appart)).

>>Today's results, after 1500km: 0.5L missing, again.

BTW: I saw a young mechanic go out the front door, bottle of 0w20 in had - got to here my car was parked, just read oil level on the stick I presume, and added some in. That's a very scientific "consumtion test"....

After some time, the service clerk came back with yet the same dirty piece of paper, bearing the news about the 0.5L missing. But he claimed this was my third & final visit...wtf...

Anyways - want to hear the funniest ?
He told me the tolerance was 1L/1000km !?!?!?!?!?!?!

I believe, when this first started for me almost a year ago, I had read somewhere the tolerance was 1L/3000km - then it became 1L/2000km.
1L/1000km is downright outreageous.

I gave him little hell but I don't have the energy to fight anymore on this, so I simply laughed at him.
1L/1kkm... I have to check with APA ...
That sounds right for the brz. You have to go with what your owners manual states
flyboy1100 is offline   Reply With Quote
Old 12-13-2012, 08:45 AM   #2049
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Djbono- is your car a BRZ? If so, I didn't realize.
Your dealer sounds like my experiences. They're fine if you're an old fart paying a hundred bucks for a tranny fluid change. These "ugly duckling" cars are a headache and soa and the dealers keep playing the big run-around game.
And the owners manual says lots of stupid things. Like the pathetic oil allowance and the parts about checking the oil and coolant at the gas station "after the car cools down". Lmao... Owners Manual was written by evil lawyers.
79letour is offline   Reply With Quote
Old 12-13-2012, 09:57 AM   #2050
djbono
Scooby Newbie
 
Member#: 208098
Join Date: Apr 2009
Default

No - I have a slwoprezza 4-Door, touring ed
djbono is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Are there any DIY independent fog lights write ups yet for 2012 impreza sports? JDMSTA Electrical & Lighting 59 07-21-2013 08:04 AM
2012 Impreza 2.0i Mobil1 oil filter model # jr0bb5 Service & Maintenance 27 01-04-2013 05:18 PM
('11-'14) OC interval and the first oil change on 2012 Impreza 2.0 Oceanguy Impreza Forum 80 11-18-2012 12:56 PM
My Oil Light is Flickering and I have No Leak??? kakarotoni Newbies & FAQs 39 08-16-2012 10:36 AM
('11-'14) 2012 Impreza High beams = Low beams lighting Jmzda Impreza Forum 28 06-01-2012 12:14 PM


All times are GMT -4. The time now is 02:14 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.