Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-23-2012, 06:57 AM   #1
subaru life
Scooby Specialist
 
Member#: 305994
Join Date: Jan 2012
Chapter/Region: International
Location: everywhere
Unhappy ac help! :( its hot and getting worse...

Well after not having my ac for 6-7 months while it was winter. Also it was cause the belt broke when the pulley seized up. That happened right before winter. So anyway yesterday I got a new pulley and belt and installed it and was hoping for nice cold ac again and nothing happened except hot air came out. I even bought new freon kit from Walmart. But.it said charged..

Anybody got any clue? Fix it?
Let me know if u can help.. I really rather not take to the car shop...if its a easy fix.
* Registered users of the site do not see these ads.
subaru life is offline   Reply With Quote
Old 05-23-2012, 08:54 AM   #2
slimshade1
Scooby Newbie
 
Member#: 320515
Join Date: May 2012
Chapter/Region: SWIC
Location: Gilbert AZ
Vehicle:
98 impreza obs
green

Default

Is the compressor good?
slimshade1 is offline   Reply With Quote
Old 05-23-2012, 09:53 AM   #3
dan az
Scooby Specialist
 
Member#: 120355
Join Date: Jul 2006
Chapter/Region: SWIC
Location: prescott valley, az
Vehicle:
2004 wrx wagon 2.5
20g-xt, super slow

Default

if your in prescott I have a ac machine and work on ac on nearly a daily basis. usually a pully doesnt seize up, but rather the compressor does.
dan az is offline   Reply With Quote
Old 05-23-2012, 03:25 PM   #4
subaru life
Scooby Specialist
 
Member#: 305994
Join Date: Jan 2012
Chapter/Region: International
Location: everywhere
Default

i live in gilbert,az..well what happened what the pulley was not moving at all and the belt was burning(burning smell)... i removed the pulley and cut the belt...the idler pulley was not moving freely..right now the compressor is fine was i have the new belt and idler pulley on and its spinning freely...

just need the ac cause i transport my kids in it but for now were using the wifes honda crv..i just wanna drive my suby...
subaru life is offline   Reply With Quote
Old 05-23-2012, 03:26 PM   #5
subaru life
Scooby Specialist
 
Member#: 305994
Join Date: Jan 2012
Chapter/Region: International
Location: everywhere
Default

Quote:
Originally Posted by slimshade1 View Post
Is the compressor good?
yeah im pretty sure its good cause its spinning freely with the new pulley and belt
subaru life is offline   Reply With Quote
Old 05-23-2012, 04:14 PM   #6
thesoundproject
Scooby Newbie
 
Member#: 254734
Join Date: Aug 2010
Chapter/Region: SWIC
Location: AZ
Vehicle:
2000 2.2L-T
low boost hii compression

Default

The pulley will always spin doesn't necessarily mean the compressor works. If it is charged then it'll automatically turn on and you will hear it. Start cheap then work your way up. Check to make sure all cables are plugged in followed up by checking fuses and relays. If none of that is it then your compressor is basura and you need a new one.
thesoundproject is offline   Reply With Quote
Old 05-23-2012, 05:27 PM   #7
Flatfoot98H4
Scooby Newbie
 
Member#: 299023
Join Date: Oct 2011
Chapter/Region: SWIC
Location: AZ
Vehicle:
2000 RS
Sedona Red

Default

Quote:
Originally Posted by dan az View Post
if your in prescott I have a ac machine and work on ac on nearly a daily basis. usually a pully doesnt seize up, but rather the compressor does.
wish i was in prescott my a/c is meh but ehhh cycles funny, put to much r134 a in so i released some and since than hasnt been funky. but at one point it was drawing power while going a constant speed....any ideas?
Flatfoot98H4 is offline   Reply With Quote
Old 05-24-2012, 01:18 AM   #8
Momosaurus WRX
Scooby Specialist
 
Member#: 214737
Join Date: Jun 2009
Location: South Ogden
Default

When the pulley seized it may have burned up the clutch on the compressor. Just a thought.
Momosaurus WRX is offline   Reply With Quote
Old 05-24-2012, 01:32 AM   #9
bobturismo
Scooby Specialist
 
Member#: 42145
Join Date: Aug 2003
Location: cruizin' down the street in my
Vehicle:
6-4 jockin da bish-
es and slappin the hoes.

Default

is the clutch engaging?

Does the center of the a/c compressor pulley spin?
bobturismo is offline   Reply With Quote
Old 05-24-2012, 01:52 AM   #10
bobturismo
Scooby Specialist
 
Member#: 42145
Join Date: Aug 2003
Location: cruizin' down the street in my
Vehicle:
6-4 jockin da bish-
es and slappin the hoes.

Default

??


hello?
bobturismo is offline   Reply With Quote
Old 05-24-2012, 02:08 AM   #11
subaru life
Scooby Specialist
 
Member#: 305994
Join Date: Jan 2012
Chapter/Region: International
Location: everywhere
Default

I fixed it!!!! Yes!! I knew i shouldnt have dropped outof uti!! Lol
subaru life is offline   Reply With Quote
Old 05-24-2012, 08:43 AM   #12
BugEyeBetty
Scooby Newbie
 
Member#: 234645
Join Date: Jan 2010
Chapter/Region: TXIC
Location: Houston, TX
Vehicle:
2002 WRX Wagon
Midnight Black Pearl;

Default

Quote:
Originally Posted by subaru life View Post
I fixed it!!!! Yes!! I knew i shouldnt have dropped outof uti!! Lol
how did you fix it? I am having some issues too. I replaced my compressor to condenser hose, filled it with freon and it was blowing cold. I started hearing a weird chip. I pinpointed the chip to the ac compressor clutch. I thought I didnt put enough freon in it to engage the compressor.. I am really hoping its not the compressor..
BugEyeBetty is offline   Reply With Quote
Old 05-24-2012, 10:39 AM   #13
subaru life
Scooby Specialist
 
Member#: 305994
Join Date: Jan 2012
Chapter/Region: International
Location: everywhere
Default

Quote:
Originally Posted by BugEyeBetty View Post
how did you fix it? I am having some issues too. I replaced my compressor to condenser hose, filled it with freon and it was blowing cold. I started hearing a weird chip. I pinpointed the chip to the ac compressor clutch. I thought I didnt put enough freon in it to engage the compressor.. I am really hoping its not the compressor..
Honeslty i was drunk lastnight and was like what the hell!! Let me check the fuses.. sure enough a stupid 15amp15amp fuse was out..
subaru life is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wagon rattle, unusual/loud and getting worse... need help! Zeker555 Interior & Exterior Modification 10 04-11-2012 09:57 PM
help a n00b out and get a reward Soon2bSubbieowner Off-Topic 7 09-18-2004 07:30 AM
Help! where to go and get new seat covers? Freeman Southern California Impreza Club Forum -- SCIC 5 07-13-2004 02:23 AM
So I guess I"ll ask again since nobody helped me last time and its now worse juztin180 Factory 2.0L Turbo Powertrain 6 01-20-2003 04:22 AM
Need Help with Part Numbers and Getting Parts... Xscreamer Normally Aspirated Powertrain 1 02-26-2001 10:48 AM


All times are GMT -4. The time now is 08:55 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.