Welcome to the North American Subaru Impreza Owners Club Friday May 29, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-23-2012, 03:52 PM   #1
TopGearAddict
Scooby Newbie
 
Member#: 299233
Join Date: Oct 2011
Chapter/Region: MAIC
Location: NoVA
Vehicle:
2009 Impreza WRX 5DR
Obsidian Black

Default 2009 WRX Declined Performance

Ok so the problems are:
-Loose steering feel
-Jerky acceleration (comes and goes)
-Slow acceleration
-Rough engine feel in general

I have a few things that I thought may cause them:
-Really worn tires (changing to new pirellis tomorrow)
-Need for an oil change (changing it tomorrow)
-Extremely low coolant (filling it up today)

I really hope spirited driving or long distances aren't the cause. What do you guys think?
* Registered users of the site do not see these ads.
TopGearAddict is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-23-2012, 05:15 PM   #2
Nimbus09
Scooby Specialist
 
Member#: 212399
Join Date: May 2009
Chapter/Region: NWIC
Location: portland, or
Vehicle:
09 wrx 301hp/328tq
'00 miata blue

Default

I feel like I've experienced everything you have there, including the potential causes. My conclusion? It's in your head.

If you have an AP, start logging. Also, check your air filter and clean your maf.
Nimbus09 is offline   Reply With Quote
Old 05-24-2012, 04:38 PM   #3
TopGearAddict
Scooby Newbie
 
Member#: 299233
Join Date: Oct 2011
Chapter/Region: MAIC
Location: NoVA
Vehicle:
2009 Impreza WRX 5DR
Obsidian Black

Default

It was my air filter man! It was clogged with bugs and mud, shes all good now
TopGearAddict is offline   Reply With Quote
Old 05-24-2012, 06:58 PM   #4
Nimbus09
Scooby Specialist
 
Member#: 212399
Join Date: May 2009
Chapter/Region: NWIC
Location: portland, or
Vehicle:
09 wrx 301hp/328tq
'00 miata blue

Default

awesome! great to hear it's purring!
Nimbus09 is offline   Reply With Quote
Old 05-24-2012, 09:08 PM   #5
yeos
Scooby Specialist
 
Member#: 133855
Join Date: Dec 2006
Chapter/Region: NWIC
Location: Seattle
Vehicle:
2009 STi SparkSilver
Dom Tuned @ MPS

Default

Go ahead and clean off the MAF sensor with some MAF spray while your at it.
yeos is offline   Reply With Quote
Old 05-24-2012, 09:16 PM   #6
ki4syr
Scooby Newbie
 
Member#: 247574
Join Date: May 2010
Location: Overthere
Vehicle:
2013 PBP GV STI
2008 Impreza 2.5i

Default


Only 14,500 miles on the wife's '11 WRX and this is what I found. Wasn't having any performance issues, but glad I found it before they started.

The factory cold air duct must work pretty good. It catches everything!
ki4syr is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2009+ WRX - Torqued Performance Stage 2 vs. protune goldschlagerxx AccessPort 12 04-02-2012 10:52 PM
2009 Impreza Non-Turbo Performance Parts FiggyFigs Newbies & FAQs 12 03-10-2012 12:35 PM
2009 WRX tuned by Forged Performance savsuby300 Proven Power Bragging 5 07-06-2010 01:23 PM
What parts fit from 2009 WRX to 2009 impreza N/A skatorforeal Newbies & FAQs 6 01-25-2010 02:52 PM
2007 WRX STI or 2009 WRX STI or 2009 Evo X? AVCS-BoxerFTW General Community 70 08-27-2009 08:17 PM


All times are GMT -4. The time now is 12:53 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.