Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-02-2012, 06:59 PM   #1
tenchu
Scooby Specialist
 
Member#: 64147
Join Date: Jun 2004
Chapter/Region: MWSOC
Location: Milwaukee, WI
Vehicle:
1993 STi RA V LTD
Green

Default Instrument cluster inop

92 WRX wiring harness, 95 (i think) STi cluster, worked for a while, but during the whole fiasco of trying to get my car running (which it does now) the cluster stopped working. All fuses are good. Backlight works, highbeam indicator works, but I have no tach, fuel, temp, CEL, etc. Any clues where to start?
* Registered users of the site do not see these ads.
tenchu is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Anybody know when the Autometer instrument cluster bezel will be available? -=C=- Interior & Exterior Modification 7 01-30-2002 12:33 AM
STi Replacement instrument cluster for WRX? Zahnster General Forum Archive 2 03-25-2001 09:54 AM
Imp-OBS Instrument Cluster JeffO General Forum Archive 2 01-13-2001 08:52 AM
Instrument Cluster Color Norris Interior & Exterior Modification 5 01-11-2001 09:34 PM
Gauge pods in the corners of Instrument cluster?!?! Dan_E General Forum Archive 17 12-08-2000 06:18 PM


All times are GMT -4. The time now is 02:37 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.