Welcome to the North American Subaru Impreza Owners Club Monday December 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-14-2012, 12:16 AM   #1
banshee04
Scooby Specialist
 
Member#: 179014
Join Date: May 2008
Location: Oklahoma City, OK
Vehicle:
'06 WRX/STi
Built Motor/6766/E85

Default 06 WRX - FP Red, E85, 20psi - Feels like a dog (Map inside)

2006 WRX:
EJ257 with drop-in CP's
FP Red
DW 300 Pump
14000cc Inj
Fujitsubo EL Headers
FMIC
3.5in MAF Tube
TGV Deletes
20 psi
12:1 AFR

This is my first time tuning with E85. I read alot before I started and I think I have the concept down.

The car lags pretty bad; 20psi at like 5000rpm's.
The car doesnt really feel any faster then when I had a eBay 20g on it.

Here's a copy of my map. Any suggestions or help would be appreciated.
https://docs.google.com/open?id=0B2R...2FrTUdGMUZ0Y0k
* Registered users of the site do not see these ads.
banshee04 is offline   Reply With Quote
Old 06-14-2012, 03:10 AM   #2
Airboy
Scooby Specialist
 
Member#: 72829
Join Date: Oct 2004
Chapter/Region: W. Canada
Location: Calgary, Canada
Vehicle:
2006 WRX
EFR6758

Default

pre-turbo exhaust leak?
broken turbo?
Airboy is online now   Reply With Quote
Old 06-14-2012, 10:57 AM   #3
banshee04
Scooby Specialist
 
Member#: 179014
Join Date: May 2008
Location: Oklahoma City, OK
Vehicle:
'06 WRX/STi
Built Motor/6766/E85

Default

I actually replaced my old turbo which was similar to a FP Red to an actual Red. I thought it was a garbage turbo too so thata why I got a different turbo. I replaced all gaskets with OEM Subaru five layer gaskets.
banshee04 is offline   Reply With Quote
Old 07-07-2012, 07:57 PM   #4
alexmartynyuk
Scooby Newbie
 
Member#: 191967
Join Date: Oct 2008
Location: Vancouver
Vehicle:
2002 wrx
Captain America tuned

Default

maybe the problem is 14000 injectors lol.
alexmartynyuk is offline   Reply With Quote
Old 07-09-2012, 08:44 PM   #5
BlazeRex
Scooby Specialist
 
Member#: 268354
Join Date: Dec 2010
Chapter/Region: NESIC
Location: Massachusetts
Vehicle:
02 WRX 05 LGT
Slow Automatics

Default

5,000 rpm is about what I'd expect, a little laggy I spose. A green hits around 4000 on a really healthy car. Also, you should be able to get quite a bit more boost out of that, especially with E85
BlazeRex is offline   Reply With Quote
Old 07-10-2012, 12:12 AM   #6
Bamofo
Scooby Specialist
 
Member#: 159743
Join Date: Sep 2007
Location: Plymouth Ma
Vehicle:
07 STI Limited
TurboMike Tuned 2.35

Default

You should be hitting boost sooner with AVCS... but the Red didnt seem to wake up until around 27psi on the De-Stroke i tuned the other week... It was like night and day.
Bamofo is offline   Reply With Quote
Old 07-10-2012, 12:36 PM   #7
renosubby
Scooby Specialist
 
Member#: 152576
Join Date: Jun 2007
Chapter/Region: SWIC
Location: Reno, NV
Vehicle:
2006 STI 10.8@ 129
www.Mayhemtuning.com

Default

looked over your map and you could use a real tune! sorry man but your fueling needs tons of work, timing i wouldn't know with out looking at a log. but needs to be re worked some
avcs could use some work as well.

Cory
renosubby is offline   Reply With Quote
Old 08-02-2012, 10:28 AM   #8
endrswrd
Scooby Specialist
 
Member#: 323908
Join Date: Jun 2012
Chapter/Region: MWSOC
Location: Dayton Ohio
Vehicle:
2013 BRZ ltd
ISM

Default

Agreed with reno. Your fueling is hacked a bit. Seems like fueling tables were used to fix MAF issues....(just a guess but I have seen something similar before)
endrswrd is offline   Reply With Quote
Old 08-02-2012, 11:53 PM   #9
banshee04
Scooby Specialist
 
Member#: 179014
Join Date: May 2008
Location: Oklahoma City, OK
Vehicle:
'06 WRX/STi
Built Motor/6766/E85

Default

Just to let everyone know, I have been retuned and the car feels a ton better.

Thanks for everyones help!
banshee04 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PhatBotti Tuning: 2010 STi / FP RED / E85 / 500.4 WHP / Stock Catback-Sleeper Status! PhatBotti Tuning TKR Proven Power Bragging 42 02-14-2012 06:27 PM
EQ - 2006 STI - FP Red, 91 Octane - 360whp! Equilibrium Tuning Proven Power Bragging 18 12-12-2011 05:15 AM
Agile Tuned 04 Sti - FP Red/Q16 1/4 mile run 04fpgreensti Proven Power Bragging 19 07-24-2009 05:23 PM


All times are GMT -4. The time now is 02:57 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.