Welcome to the North American Subaru Impreza Owners Club Monday August 3, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-15-2012, 01:22 PM   #1
04reddragon
Scooby Newbie
 
Member#: 216553
Join Date: Jul 2009
Chapter/Region: SWIC
Location: Yuma,Az
Vehicle:
2006 wrx sti
gray

Default my 04 ac making crazy sounds need a shop or person to look at it plz

So yea the other day my AC was blowing warm air at times so I thought I was low on freon I charged it AC full blast and started blowing cold air but Its making a loud as noise its never made. Now when I turn the AC on it blows cold air but it makes a loud squeaky noise that's annoying. So I'm wanting to know who can check it out for me or know a good shop I can take so they can tell me wat is thanks guys
* Registered users of the site do not see these ads.
04reddragon is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 06-15-2012, 02:44 PM   #2
NAZSTI
Scooby Specialist
 
Member#: 164516
Join Date: Nov 2007
Chapter/Region: SWIC
Location: Northern AZ STI hence username
Vehicle:
2004 STI
PSM

Default

PM JapCarRealGood.
NAZSTI is offline   Reply With Quote
Old 06-15-2012, 05:53 PM   #3
s-tizzleboost
Scooby Newbie
 
Member#: 281439
Join Date: Apr 2011
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
2005 impreza wrx STi
WRB

Default

if its screaming when you turn a/c on its most likely the belt slipping. mine did the same thing, replaced the belt now its quiet!
s-tizzleboost is offline   Reply With Quote
Old 06-15-2012, 06:03 PM   #4
04reddragon
Scooby Newbie
 
Member#: 216553
Join Date: Jul 2009
Chapter/Region: SWIC
Location: Yuma,Az
Vehicle:
2006 wrx sti
gray

Default

Mmm I hope so. Cause I know before I charged it every fee seconds it would blow ice cold air then warm then wat I think is the compressor clutch would kick in and start blowing cold air so I thought it was low on freon
04reddragon is offline   Reply With Quote
Old 06-15-2012, 07:21 PM   #5
s-tizzleboost
Scooby Newbie
 
Member#: 281439
Join Date: Apr 2011
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
2005 impreza wrx STi
WRB

Default

yeah, if im not mistaken the compressor does not stay on constantly, so yeah it was prolly low, and check your belt! look at the teeth on it! if they are missing or are cracked and really dry, then replace it and that should fix the problem!
s-tizzleboost is offline   Reply With Quote
Old 06-15-2012, 07:28 PM   #6
04reddragon
Scooby Newbie
 
Member#: 216553
Join Date: Jul 2009
Chapter/Region: SWIC
Location: Yuma,Az
Vehicle:
2006 wrx sti
gray

Default

Yea I know when I charged it it took the whole can and blew ice cold air but then started making this loud noise then blew warm air. Then the next day I tried it and blows cool air now
04reddragon is offline   Reply With Quote
Old 06-15-2012, 08:44 PM   #7
04reddragon
Scooby Newbie
 
Member#: 216553
Join Date: Jul 2009
Chapter/Region: SWIC
Location: Yuma,Az
Vehicle:
2006 wrx sti
gray

Default

I just checked the belt and seems tight and no cracks. I did a test run and drove it and at first it blew cold air then warm the sound kinda goes away but seems like it wants to turn on and its a no go. Wat gives
04reddragon is offline   Reply With Quote
Old 06-16-2012, 03:15 AM   #8
s-tizzleboost
Scooby Newbie
 
Member#: 281439
Join Date: Apr 2011
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
2005 impreza wrx STi
WRB

Default

hmmm, you may need to ( not 100% on it) clean your condenser out!
s-tizzleboost is offline   Reply With Quote
Old 06-16-2012, 11:11 AM   #9
04reddragon
Scooby Newbie
 
Member#: 216553
Join Date: Jul 2009
Chapter/Region: SWIC
Location: Yuma,Az
Vehicle:
2006 wrx sti
gray

Default

Really? Seems easy how do I clean it out?
04reddragon is offline   Reply With Quote
Old 06-16-2012, 12:51 PM   #10
s-tizzleboost
Scooby Newbie
 
Member#: 281439
Join Date: Apr 2011
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
2005 impreza wrx STi
WRB

Default

that my man i have no clue! ive just herd of a dirty clogged condenser messing up the a/c and making it blow cold then making it stop.. i believe you have to vacuum it out, but idk exactly how! im sure there is a thread out there on here or iwsti.com!
s-tizzleboost is offline   Reply With Quote
Old 06-16-2012, 05:31 PM   #11
thegreg
Scooby Specialist
 
Member#: 105429
Join Date: Jan 2006
Chapter/Region: SWIC
Location: az
Vehicle:
2004 WRX STi
PSM

Default

You can bring it to my shop, Arizona Auto Care. 5235 s Kyrene #42 Tempe, 85283. 480.820.2693

Sounds like the system is either low, or overcharged. The pressure switches will cycle the compressor off, if once it builds pressure, see its too high or low. As far as the noise goes, it may just be the compressor cycling, hard to say with out hearing it first hand.

As far as the condenser goes, you can visually check the fins on the side that faces the bumper/grill area. You can blow it out with an air gun, or attempt to clean with water. Its unlikely that it is that restricted, but its possible, as the lack of air flow across the condenser will cause pressures to rise, and the compressor will cycle off.
thegreg is offline   Reply With Quote
Old 06-17-2012, 04:35 AM   #12
Infantry209
Scooby Newbie
 
Member#: 266895
Join Date: Dec 2010
Chapter/Region: SWIC
Location: Glendale, AZ
Vehicle:
2014 Thrustmaster TX
Fanatec CSPv2, gated 7spd

Default

Sounds like your belt could be loose, or you just have a leak. You said you recharged your ac recently. You did it yourself? Did you fasten all the bolts tightly? Did you change any gaskets or clips?
Infantry209 is offline   Reply With Quote
Old 06-17-2012, 04:46 AM   #13
metallbizkit
Scooby Newbie
 
Member#: 211119
Join Date: May 2009
Location: Tempe, AZ
Vehicle:
2012 STI Limited
Lightning Red

Default

Quote:
Originally Posted by NAZSTI View Post
PM JapCarRealGood.
Let us know how it goes wherever you take it, but I've heard some good names mentioned on the forums that can be trusted.
metallbizkit is offline   Reply With Quote
Old 06-17-2012, 12:19 PM   #14
s-tizzleboost
Scooby Newbie
 
Member#: 281439
Join Date: Apr 2011
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
2005 impreza wrx STi
WRB

Default

what thegreg said (:!
s-tizzleboost is offline   Reply With Quote
Old 06-17-2012, 12:47 PM   #15
04reddragon
Scooby Newbie
 
Member#: 216553
Join Date: Jul 2009
Chapter/Region: SWIC
Location: Yuma,Az
Vehicle:
2006 wrx sti
gray

Default

Yea i bought the belt ac belt and just to replace also got the power steering belt also my brother in law took my car to his.mechanic and said its the compressor so idk how sure he is.he missed with the trianglr part of the compressor and said it was it
04reddragon is offline   Reply With Quote
Old 06-17-2012, 01:52 PM   #16
s-tizzleboost
Scooby Newbie
 
Member#: 281439
Join Date: Apr 2011
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
2005 impreza wrx STi
WRB

Default

damn, i hope you get it all figured out! good luck!
s-tizzleboost is offline   Reply With Quote
Old 06-17-2012, 02:27 PM   #17
04reddragon
Scooby Newbie
 
Member#: 216553
Join Date: Jul 2009
Chapter/Region: SWIC
Location: Yuma,Az
Vehicle:
2006 wrx sti
gray

Default

Thanks bro hella hot outside need ac
04reddragon is offline   Reply With Quote
Old 06-17-2012, 05:20 PM   #18
s-tizzleboost
Scooby Newbie
 
Member#: 281439
Join Date: Apr 2011
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
2005 impreza wrx STi
WRB

Default

I know what you mean! I don't have a/c either haha! I gotta stop being lazy and take it back to fletchers cause they screwed me over!
s-tizzleboost is offline   Reply With Quote
Old 06-18-2012, 11:21 AM   #19
bluecloud
Scooby Newbie
 
Member#: 258852
Join Date: Sep 2010
Chapter/Region: SWIC
Location: AZ
Vehicle:
2002 "BugEye"Impreza
blue

Default

I also went to the shop cause my ac is not working . At first, I knew I had no charge. They charged it up, it ran cold for a min, then it stopped. The shop said it was the expansion valve cause and the cause was a blockage. We used ac cleaner thinking it would knock the clog loose, it worked fine for another two minutes then blew hot. I went by superstore they said 129 dollars for the part (crazy). . .so I called BAP and got the expansion valve for 12 dollars on order. I'm putting it in when the part comes in. The only sucky part is that the expansion valve is inside the car behind the dash, the repair program the shop is using said it would take 4 hours to get to. So I decided to bring it home and got to it less then 30 mins. I'll let you know of it works. It sounds like we have the same problem, mine was making a wired noise also because it the compressor was going into vacuum of that helps any.

Last edited by bluecloud; 06-18-2012 at 11:29 AM.
bluecloud is offline   Reply With Quote
Old 06-18-2012, 11:57 PM   #20
bobturismo
Scooby Specialist
 
Member#: 42145
Join Date: Aug 2003
Location: cruizin' down the street in my
Vehicle:
6-4 jockin da bish-
es and slappin the hoes.

Default

expansion valves are quite common on subarus, but it still needs to be hooked up to guages to find out exactly waht's going on.
bobturismo is offline   Reply With Quote
Old 06-18-2012, 11:57 PM   #21
bobturismo
Scooby Specialist
 
Member#: 42145
Join Date: Aug 2003
Location: cruizin' down the street in my
Vehicle:
6-4 jockin da bish-
es and slappin the hoes.

Default

expansion valves are quite common on subarus, but it still needs to be hooked up to guages to find out exactly waht's going on.
bobturismo is offline   Reply With Quote
Old 06-19-2012, 11:02 PM   #22
04reddragon
Scooby Newbie
 
Member#: 216553
Join Date: Jul 2009
Chapter/Region: SWIC
Location: Yuma,Az
Vehicle:
2006 wrx sti
gray

Default

Yea just want to know wat it really is don't want to buy things that j don't need was working great before I charged it smh
04reddragon is offline   Reply With Quote
Old 06-20-2012, 01:40 AM   #23
bluecloud
Scooby Newbie
 
Member#: 258852
Join Date: Sep 2010
Chapter/Region: SWIC
Location: AZ
Vehicle:
2002 "BugEye"Impreza
blue

Default

Quote:
Originally Posted by 04reddragon
Yea just want to know wat it really is don't want to buy things that j don't need was working great before I charged it smh
From what I've heard, when people try charging the air conditioning, water ends up in the system or its is over charged with freon that can make it not work . Good luck on finding what is wrong with it !
bluecloud is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Found a strange fossil/rock. Need a fossil nerd to look at it. Strider Off-Topic 69 03-13-2010 06:57 PM
Shop or mech to look over a used car in westchester ptrout Tri-State Area Forum 0 02-13-2010 10:06 AM
What's a fair price for this WRX? Going to look at it tomorrow. fiveightandten Newbies & FAQs 3 08-22-2009 05:47 PM
I need a shop or person recommendation around Seattle, please. (transmission swap) ChrisRT North West Impreza Club Forum -- NWIC 5 10-20-2006 10:51 PM
Stamford, CT area mechanics. or someone to look at my suspension? kbcr3 Tri-State Area Forum 2 02-25-2005 05:03 PM


All times are GMT -4. The time now is 12:23 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.