Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Baja Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-22-2013, 09:57 PM   #1
Baja_Gernaut
Scooby Specialist
 
Member#: 229922
Join Date: Nov 2009
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2005 F-Inductd BAJA
rumble black

Default group n mounts

Just installed all mounts and all the sloppiness went away instantly but now the baja vibrates at certain rpms. I have driven the car around the block and I am really glad I am not hearing the engine rock at any stoplights. I will try to post the old engine mounts with one bad mount, very flimsy granny mount and the dogbone mount very soft.
* Registered users of the site do not see these ads.
Baja_Gernaut is offline   Reply With Quote
Old 01-22-2013, 11:39 PM   #2
jrigby
Scooby Newbie
 
Member#: 256134
Join Date: Aug 2010
Chapter/Region: NWIC
Location: MT
Vehicle:
2005 Baja Turbo 6MT

Default

How many miles are on your mounts? I've been thinking about replacing mine, just haven't been motivated with the cold.
jrigby is offline   Reply With Quote
Old 01-23-2013, 09:13 AM   #3
Baja_Gernaut
Scooby Specialist
 
Member#: 229922
Join Date: Nov 2009
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2005 F-Inductd BAJA
rumble black

Default

My Baja has around 130 on the clock. The reason i wanted to change the mounts because i just replaced my rear drive shaft with a aftermarket one and i noticed my center bearing making a vibration while taking off. This is my third shaft so i had a theory about my mounts being weak and allowing the u joints near the tranny flex or buckle when there is a strain such as a launch in first gear. My first two drive shafts broke the u joints by the tranny, so if the engine is rocking back and forth, then that drive shaft u joint has to flex according to the engine movement.
i can say now that i do not feel any vibration in the center-bearing anymore or any movement on my stick shift. i do feel vibration coming from engine because of the stiffer mounts but i do not feel any strain on the drivetrain anymore.
I
Probably if I did this job again, I suggest changing all mounts with hardened ones except the engine. I think the OEM mounts do a better job with vibrations from the engine but the tranny mount is actually a joke. This is one mount that was incorrectly engineered because there so little support for so much movement from the car.

Last edited by Baja_Gernaut; 01-24-2013 at 05:15 PM. Reason: Typing sucks in a iphone
Baja_Gernaut is offline   Reply With Quote
Old 01-24-2013, 07:49 PM   #4
Ahzlon
Scooby Specialist
 
Member#: 45216
Join Date: Oct 2003
Chapter/Region: NESIC
Location: Essex, Vermont
Vehicle:
2005 Baja Turbo
Silver

Default

I had a set of bushings I can't remember where they came from in my 00 RS.. HOLY CRAP. first time i started up the car.. EVERYTHING vibrated every where.. I thought my dash was going to shake off. But they broke in after a while and were not as bad.. I do remember them being 25% stiffer then group N bushings. I still have them. Might install them this summer.
Ahzlon is offline   Reply With Quote
Old 01-24-2013, 08:01 PM   #5
Baja_Gernaut
Scooby Specialist
 
Member#: 229922
Join Date: Nov 2009
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2005 F-Inductd BAJA
rumble black

Default

i had the same experience when I started the car up. i am hoping they break in and the some of the vibrations goes away. I have the kartboy bushings and short shifter to install and this will definitely wipe away the wobble i have with the stick.
Baja_Gernaut is offline   Reply With Quote
Old 02-04-2013, 06:17 PM   #6
Baja_Gernaut
Scooby Specialist
 
Member#: 229922
Join Date: Nov 2009
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2005 F-Inductd BAJA
rumble black

Default

update on the mounts, vibration has gone away around 40 percent. Even the whining of the tranny has subsided so I happy with this upgrade. Now I am about install the kartboy shortshift with bushings.
Baja_Gernaut is offline   Reply With Quote
Old 02-04-2013, 10:38 PM   #7
steven765
Scooby Specialist
 
Member#: 105920
Join Date: Jan 2006
Location: Somewhere in the Northeast
Vehicle:
2006 Baja 5 Speed

Default

FML I just bought a new factory mount. Which group n mount fits the baja?
steven765 is offline   Reply With Quote
Old 02-05-2013, 01:35 PM   #8
Baja_Gernaut
Scooby Specialist
 
Member#: 229922
Join Date: Nov 2009
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2005 F-Inductd BAJA
rumble black

Default

Quote:
Originally Posted by steven765 View Post
FML I just bought a new factory mount. Which group n mount fits the baja?
i bought the 5 speed kit. apparently our bajas share the same mounts any other subaru that has a 2.5 engine. this what i went by and alll mounts fitted fine. thit kit comes with engine, tranny and pitch mount.
Baja_Gernaut is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:45 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.