Welcome to the North American Subaru Impreza Owners Club Friday July 1, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-20-2015, 03:21 PM   #1
shane_c
Scooby Newbie
 
Member#: 168062
Join Date: Jan 2008
Chapter/Region: E. Canada
Location: Nova Scotia, Canada
Vehicle:
2014 Impreza Touring
Black

Default Rear Wiper (winter)

Is there a company out there that makes a winter wiper for a '14 Impreza hatchback? The only ones I can find are the summer style blade and that was beyond useless all last winter.

From what I can find online it is a 12" blade. It looks like a 13" would fit so I bought one last weekend but the factory arm was wider than the opening in the wiper so I couldn't get it on.
* Registered users of the site do not see these ads.
shane_c is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-20-2015, 06:10 PM   #2
drpoop
Scooby Specialist
 
Member#: 421858
Join Date: May 2015
Default

Put a 14 inch blade on. The stock (12") size is too small for the window, 14 fits with more than enough room.
drpoop is offline   Reply With Quote
Old 10-22-2015, 01:56 PM   #3
aeoporta
Scooby Specialist
 
Member#: 334126
Join Date: Oct 2012
Chapter/Region: Tri-State
Location: New York
Vehicle:
2016 2.5i Premium MT
Dark Gray Mettallic

Default

Valeo R-12D works fine in winter, Valeo R-14B fits my forester so that may work on the imp as well
aeoporta is offline   Reply With Quote
Old 10-22-2015, 02:05 PM   #4
Angelus911
Scooby Specialist
 
Member#: 89967
Join Date: Jun 2005
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sport
DGM

Default

+1 on the 14" rear wiper. Greatly improves visibility, esp in the winter months.
Angelus911 is offline   Reply With Quote
Old 10-22-2015, 04:15 PM   #5
darederek
Scooby Newbie
 
Member#: 400816
Join Date: Sep 2014
Chapter/Region: Tri-State
Location: Greensburg, PA
Vehicle:
2015 Impreza 5MT
Ice Silver Metallic

Default

How do you even change the rear wiper?
darederek is offline   Reply With Quote
Old 10-22-2015, 05:07 PM   #6
drpoop
Scooby Specialist
 
Member#: 421858
Join Date: May 2015
Default

Quote:
Originally Posted by darederek View Post
How do you even change the rear wiper?
Same as the fronts IIRC. Pull the arm out, press a tab in the arm mounting point, and push the blade out. It's a J hook.


drpoop is offline   Reply With Quote
Old 10-22-2015, 05:12 PM   #7
darederek
Scooby Newbie
 
Member#: 400816
Join Date: Sep 2014
Chapter/Region: Tri-State
Location: Greensburg, PA
Vehicle:
2015 Impreza 5MT
Ice Silver Metallic

Default

Quote:
Originally Posted by drpoop View Post
Same as the fronts IIRC. Pull the arm out, press a tab in the arm mounting point, and push the blade out. It's a J hook.


Maybe the 2015's are different? Mine definitely doesn't have a replaceable arm. Looks like i can only replace the rubber
darederek is offline   Reply With Quote
Old 10-22-2015, 08:21 PM   #8
drpoop
Scooby Specialist
 
Member#: 421858
Join Date: May 2015
Default

Quote:
Originally Posted by darederek View Post
Maybe the 2015's are different? Mine definitely doesn't have a replaceable arm. Looks like i can only replace the rubber
Nope. Seriously doubt it. Maybe I can take a video of how to take it off my 2012 for you tomorrow.
drpoop is offline   Reply With Quote
Old 10-22-2015, 08:47 PM   #9
shane_c
Scooby Newbie
 
Member#: 168062
Join Date: Jan 2008
Chapter/Region: E. Canada
Location: Nova Scotia, Canada
Vehicle:
2014 Impreza Touring
Black

Default

Quote:
Originally Posted by darederek View Post
Maybe the 2015's are different? Mine definitely doesn't have a replaceable arm. Looks like i can only replace the rubber
My '14 does not have the j-hook style in the rear.
shane_c is offline   Reply With Quote
Old 10-22-2015, 08:54 PM   #10
drpoop
Scooby Specialist
 
Member#: 421858
Join Date: May 2015
Default

https://www.youtube.com/watch?v=PuwI9X2tikU

It's not j-hook... it should be idiot proof. You put the blade itself perpendicular to the arm and push it out.
drpoop is offline   Reply With Quote
Old 10-22-2015, 09:06 PM   #11
shane_c
Scooby Newbie
 
Member#: 168062
Join Date: Jan 2008
Chapter/Region: E. Canada
Location: Nova Scotia, Canada
Vehicle:
2014 Impreza Touring
Black

Default

Quote:
Originally Posted by drpoop View Post
https://www.youtube.com/watch?v=PuwI9X2tikU

It's not j-hook... it should be idiot proof. You put the blade itself perpendicular to the arm and push it out.
Thanks for the video. I have no trouble getting it off but didn't find anything at my local auto store that would fit the rear mount style. Looks like I need a B or D style, I've seen both mentioned.
shane_c is offline   Reply With Quote
Old 10-22-2015, 09:36 PM   #12
drpoop
Scooby Specialist
 
Member#: 421858
Join Date: May 2015
Default

I think it's B. The one I ordered from amazon was 14-B I believe.
drpoop is offline   Reply With Quote
Old 10-23-2015, 09:03 PM   #13
shane_c
Scooby Newbie
 
Member#: 168062
Join Date: Jan 2008
Chapter/Region: E. Canada
Location: Nova Scotia, Canada
Vehicle:
2014 Impreza Touring
Black

Default

I can't seem to find any frameless 14b winter blades. Do they exist? From what I can tell in the poor quality pictures online it looks like the Valeo's have a somewhat closed in frame but certainly not frameless.
shane_c is offline   Reply With Quote
Old 10-23-2015, 10:08 PM   #14
drpoop
Scooby Specialist
 
Member#: 421858
Join Date: May 2015
Default

Never had a problem with regular wiper blades on the rear window... That's what the defroster is for in combination with winter fluid.
drpoop is offline   Reply With Quote
Old 10-24-2015, 08:40 AM   #15
Obviously Tyler
Scooby Specialist
 
Member#: 395955
Join Date: Jul 2014
Chapter/Region: MAIC
Location: Space
Vehicle:
2016 WRX Premium
Ice Silver Metallic

Default

I forget about the rear wiper.. I never use it.

Kind of looks like the car is happy to see me and it's wagging its tail.
Obviously Tyler is offline   Reply With Quote
Old 10-26-2015, 02:47 PM   #16
shane_c
Scooby Newbie
 
Member#: 168062
Join Date: Jan 2008
Chapter/Region: E. Canada
Location: Nova Scotia, Canada
Vehicle:
2014 Impreza Touring
Black

Default

Quote:
Originally Posted by drpoop View Post
Never had a problem with regular wiper blades on the rear window... That's what the defroster is for in combination with winter fluid.
For the majority of last winter it would clear about 1-2" at most. It was horrible!

Since I can't find the frameless type I just went ahead and got a 14" regular wiper so at least the other 3 seasons of the year it'll clear a little more.
shane_c is offline   Reply With Quote
Old 10-28-2015, 06:16 AM   #17
flyboy1100
Scooby Guru
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by shane_c View Post
For the majority of last winter it would clear about 1-2" at most. It was horrible!

Since I can't find the frameless type I just went ahead and got a 14" regular wiper so at least the other 3 seasons of the year it'll clear a little more.
1-2" of what, snow?

Brush it off first! No wiper system is designed to handle that kind of load.

I have never had an issue with the rear blade not working in the winter, then again I am not using it to remove overnight snow, just the normal road mist
flyboy1100 is offline   Reply With Quote
Old 10-28-2015, 11:10 AM   #18
shane_c
Scooby Newbie
 
Member#: 168062
Join Date: Jan 2008
Chapter/Region: E. Canada
Location: Nova Scotia, Canada
Vehicle:
2014 Impreza Touring
Black

Default

Quote:
Originally Posted by flyboy1100 View Post
1-2" of what, snow?

Brush it off first! No wiper system is designed to handle that kind of load.

I have never had an issue with the rear blade not working in the winter, then again I am not using it to remove overnight snow, just the normal road mist
I do remove the snow and ice. But it gets covered with road grime and salt and even when I use the washer fluid on the back window the blade is so frozen that it only clears 1-2". It's like that all winter.
shane_c is offline   Reply With Quote
Old 10-28-2015, 11:54 AM   #19
flyboy1100
Scooby Guru
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by shane_c View Post
I do remove the snow and ice. But it gets covered with road grime and salt and even when I use the washer fluid on the back window the blade is so frozen that it only clears 1-2". It's like that all winter.
crazy, even under the same circumstances i don't see that result.

i have an anco 14b currently, but don't like it (does ok, but is streaky) probably will get a valeo 14b like everyone else.
flyboy1100 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 11:57 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.