Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-23-2012, 11:50 PM   #1
dcon9999
Scooby Newbie
 
Member#: 326345
Join Date: Jul 2012
Chapter/Region: MAIC
Location: Lehigh Valley, PA
Vehicle:
2012 5-Door Premium
Ice Metallic Silver

Question Airbag did NOT deploy

So, after 4 weeks of ownership of my brand new first-ever subaru, i had a car turn in front of me - hit me - and push me into a ford f-250. Pics below.

I was doing 45mph - slammed brakes - so less at the time of impact -- but obviously didn't avoid the accident...zero airbags!? The first car hit my front left - and when pushed into the 2nd - hit my front right..

Now, mind you - I got some bruises and few cuts - but walked....

As I'm trying to find a new, new impreza, figured I'd post to see if its a sensor thing, malfunction, etc.

Thoughts?













* Registered users of the site do not see these ads.
dcon9999 is offline   Reply With Quote
Old 08-24-2012, 12:59 AM   #2
Economatic
Scooby Specialist
 
Member#: 220091
Join Date: Aug 2009
Chapter/Region: NWIC
Location: Portland
Vehicle:
2009 WRX Sedan

Default

Well, if you walked away with a few bruises and it didn't deploy then I'm guessing it did what it was supposed to. Good to hear you're alright.
Economatic is offline   Reply With Quote
Old 08-24-2012, 01:39 AM   #3
garudatwo
Scooby Specialist
 
Member#: 322385
Join Date: Jun 2012
Chapter/Region: Tri-State
Default

Don't have an answer to your question, but glad you're still with us!
garudatwo is offline   Reply With Quote
Old 08-24-2012, 02:10 AM   #4
FASTofwestchester
Former Vendor
 
Member#: 292964
Join Date: Aug 2011
Vehicle:
1998 Legacy RHD TT
White

Default

Looks like side impact was too far forward and front hit was too high. Glad your ok..,
FASTofwestchester is offline   Reply With Quote
Old 08-24-2012, 07:41 AM   #5
Ying
Scooby Newbie
 
Member#: 166490
Join Date: Dec 2007
Chapter/Region: Tri-State
Location: Harrisburg, PA
Vehicle:
2011 WRX
WRB

Default

Did your head hit the steering wheel or one of the pillars?
Ying is offline   Reply With Quote
Old 08-24-2012, 08:12 AM   #6
SpamBot
Scooby Specialist
 
Member#: 287534
Join Date: Jul 2011
Default

Looks like there wouldn't be a deployment here. Had you been hit in the door area, the side bags would have gone off. Had the front end hit been in the front, the front bags would have gone off. A side hit in the fender won't do it.
SpamBot is offline   Reply With Quote
Old 08-24-2012, 11:02 AM   #7
dcon9999
Scooby Newbie
 
Member#: 326345
Join Date: Jul 2012
Chapter/Region: MAIC
Location: Lehigh Valley, PA
Vehicle:
2012 5-Door Premium
Ice Metallic Silver

Default

Actually hit my head on the "oh ****" handle - that's what cut me open. Don't remember hitting head on anything else....but bruising indicates that I moved forwards and sideways (toward driver side door) into my seat belt...

I agree with economatic that walking away....maybe it wasnt supposed to go off - but of course that's the question I get from everyone now --- how did it not deploy...and my answer has been....umm - sensors/computer decided not to....lol
dcon9999 is offline   Reply With Quote
Old 08-24-2012, 12:15 PM   #8
DrD
Scooby Guru
 
Member#: 22412
Join Date: Aug 2002
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2012 Legacy 2.5GT
Ice Silver Metallic

Default

If you flip through your owner's manual, it explains when the airbags will and will not deploy - a side hit towards the front isn't going to do it. (I had a similar hit - no cuts for me, but my shoulder hit the b-pillar pretty hard as the car spun and shattered my collar bone (so now I have a plate and 9 screws holding it together) - no airbag deployment) You have to be hit pretty close to square on the doors to get the side airbags to deploy.
DrD is offline   Reply With Quote
Old 08-27-2012, 10:49 AM   #9
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Wow. Glad you're ok.
79letour is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:07 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.