Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-14-2012, 03:09 PM   #1
FFMirby
Scooby Newbie
 
Member#: 196808
Join Date: Dec 2008
Chapter/Region: SCIC
Location: Palmdale, CA
Vehicle:
2014 STi limited
SWP

Default 2011 WRX Dimming mirror, clutch, electrical

2011 WRX Premium Sedan
Has anyone been experiencing any of these issues?

Dimming mirror with the homelink is to heavy for the fastener holding it to the windshield. My mirror has fallen twice once while driving and the other while adjusting the mirror. I've taken it in to the dealership to have the fastener and plastic piece holiding the mirror replaced but obviously seems like a design flaw. Spoke to dealership they have had many complaints about this.

Clutch has already had to be replaced only have 28,000 miles on the car. Car started making a rattling noise after 15,000 miles while either holding the clutch or engaging, mechanics tightening heat shields and removed rocks from behind heat shield. Noise still continued they replaced my throw out bearing. Noise came back after talking to the mechanics we both came to conclusion the springs on the actually clutch disc broke off somehow. Spoke to other same year and make subaru owners and they are experiencing the same thing.

Had maybe 2,000 miles on the car and the left turn signal was blinking really fast, went to check the obvious no bulbs were burnt out. Took the car in and some wires were touching which caused the mishap. Now have 30,000 miles on the car and once again started blinking fast, checked the bulbs there were good but low voltage were going to the bulbs. Found the wires that are bent, straightened them out and blinker works fine again. Looks like the battery is stuffed in tight by the wiring which is causing this. Has to be another designed flaw. Spoke to the dealership they too have had many complaints about the same problem.

My question is what to do besides keep taking the car in for what seems like Subaru design flaws?
* Registered users of the site do not see these ads.
FFMirby is offline   Reply With Quote
Old 08-17-2012, 01:34 PM   #2
BSOD2600
Scooby Newbie
 
Member#: 126760
Join Date: Sep 2006
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2011 WRX Limited
Black

Default

Mirror - nope.
Clutch - not yet.
Blinker - yup, along with dozens of others - http://forums.nasioc.com/forums/show....php?t=2174949
BSOD2600 is offline   Reply With Quote
Old 08-17-2012, 04:04 PM   #3
n2oiroc
Scooby Specialist
 
Member#: 141952
Join Date: Feb 2007
Chapter/Region: MWSOC
Location: milwaukee, wi
Vehicle:
03 emo 8/2011 wrx

Default

my clutch started slipping at 10k miles (disc looked like new, pressure plate was weak). replaced it with an exedy stage 1. 10k later the new throwout bearing is making noise and as i let the clutch out or anytime i engine brake, i get a rattling noise. its my daily driver and it has never been launched. i do drive aggressively, but i dont slam it from gear to gear or anything like that. i think these clutches are just junk. my original throw out bearing at 10k felt bone dry and on its way out too.
n2oiroc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 05:25 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.