Welcome to the North American Subaru Impreza Owners Club Thursday August 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-23-2012, 09:04 PM   #1
platinumstar17
Scooby Newbie
 
Member#: 159756
Join Date: Sep 2007
Chapter/Region: International
Location: caribbean
Vehicle:
1998 wrx sti
white 10.5@134

Default oil light flashing after engine swap

i have a jdm v3 wrx and the engine went bad it was a ek20k. i swapped out the engine for a v5 sti ej207 engine. after installing the engine and started it up the oil light on the dash was flashing and the car had a misfire.

what could be the cause of this?
* Registered users of the site do not see these ads.
platinumstar17 is offline   Reply With Quote
Old 06-23-2012, 10:54 PM   #2
eg33GC
Scooby Specialist
 
Member#: 206851
Join Date: Mar 2009
Chapter/Region: MWSOC
Vehicle:
99 V4
EJ20K RS

Default

if it is not an erroneous wiring issue, your shortblock is now garbage. the switch is 2.1psi.
eg33GC is offline   Reply With Quote
Old 06-26-2012, 07:25 AM   #3
platinumstar17
Scooby Newbie
 
Member#: 159756
Join Date: Sep 2007
Chapter/Region: International
Location: caribbean
Vehicle:
1998 wrx sti
white 10.5@134

Default

got the problem sorted
platinumstar17 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 Forester A/T Oil Temp light flashing after fluid change slideways suby Transmission (AT/MT) & Driveline 2 12-16-2011 10:05 PM
AT oil temp flashes after starter replace hondadude32 Legacy Forum 4 08-27-2009 01:45 PM
is it common to lose oil after engine swap? bnr34rb26dett Newbies & FAQs 9 02-23-2009 04:55 PM
gas light flashing after fuel pump intalled... BBBsti LTD Factory 2.5L Turbo Powertrain 8 12-12-2007 02:32 AM
Dash Lights flashing after clutch swap? Swiffer Car Audio, Video & Security 1 11-11-2007 05:58 PM


All times are GMT -4. The time now is 06:56 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.