Welcome to the North American Subaru Impreza Owners Club Tuesday October 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Interior & Exterior Modification

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-06-2008, 03:41 AM   #1
tonecold
Scooby Newbie
 
Member#: 37476
Join Date: May 2003
Chapter/Region: BAIC
Location: Milpitas, CA
Vehicle:
MY02 WRX Stage 2
PSM (215whp/223wtq)

Default How to Dim the STi gauge cluster?

Hi,

I installed an 06 STi cluster into my 02 bugeye.
The only problem I have is that the cluster is always lit even when the headlights aren't turned on.

I don't mind it, but the LEDs are really bright.
Is there a way to dim the cluster?

Also, my turn signals blink really fast now.
Is this normal?

TIA
* Registered users of the site do not see these ads.
tonecold is offline   Reply With Quote
Old 04-06-2008, 10:38 AM   #2
car_cursed
Scooby Guru
 
Member#: 85327
Join Date: Apr 2005
Chapter/Region: RMIC
Location: West Jordan, UT
Vehicle:
More projects than
you can shake a stick at.

Default

if you signal is blinking fats that usually menas one of the bulbs is out. check that. does the dimmer on your stalk not dim the gauges? i think it is installed wrong
car_cursed is offline   Reply With Quote
Old 04-06-2008, 12:52 PM   #3
tonecold
Scooby Newbie
 
Member#: 37476
Join Date: May 2003
Chapter/Region: BAIC
Location: Milpitas, CA
Vehicle:
MY02 WRX Stage 2
PSM (215whp/223wtq)

Default

OH......good to hear about the bulbs being out. I also did my tail lights and I need to get a new bulb for the rear blinkers. When I did my test run, I didn't have rear blinker bulbs on.
I hope putting them in will fix this problem.

I have an 02 bugeye, and I don't remember if I could DIM the gauges.
Anyone know how?
tonecold is offline   Reply With Quote
Old 04-06-2008, 01:10 PM   #4
dubya-R-ex
Scooby Specialist
 
Member#: 113698
Join Date: Apr 2006
Chapter/Region: MWSOC
Location: Locktucky, IL
Default

oh boy! On the turn signal stalk there is a twisting "switch". Try turning that and it should take care of your problem if everything is installed right.
dubya-R-ex is offline   Reply With Quote
Old 04-06-2008, 01:26 PM   #5
sammyswrxsti
Scooby Specialist
 
Member#: 148172
Join Date: May 2007
Location: Yadkinville, NC
Vehicle:
2002 WRX
Midnight Black Pearl

Default

rep on the turn signal stalk there is a rotating outer ring.. that will dim your gauges.. it should work.. its t he same in the sti
sammyswrxsti is offline   Reply With Quote
Old 04-06-2008, 02:02 PM   #6
thedaddyb
Scooby Specialist
 
Member#: 64374
Join Date: Jun 2004
Chapter/Region: MAIC
Location: Baltimore, MD
Vehicle:
07 WRX SWP *SOLD
03 2.5ts BRP long gone

Default

when I put sti gauges in my 03 the dimmer control didn't work any longer on the turn signal stalk. (it still dimmed all the other interior lights) There is a dimmer control on the gauges that you had to use with one of the adjustment knobs that stick out.

The gauges themselves should still be reactive when you turn your lights on though.
thedaddyb is offline   Reply With Quote
Old 04-06-2008, 08:00 PM   #7
tonecold
Scooby Newbie
 
Member#: 37476
Join Date: May 2003
Chapter/Region: BAIC
Location: Milpitas, CA
Vehicle:
MY02 WRX Stage 2
PSM (215whp/223wtq)

Default

Well... I tried to change the dimming using the signal stalk but they didn't work.

I read somewhere that on the STi cluster if you push the right adjustment knob on the cluster then you can get into a menu where you can control the dimming.

I tried that....but it only cycles through "A" and "B" trip odometers. I never get the "ILL" option.

Anyone get this to work?
tonecold is offline   Reply With Quote
Old 04-07-2008, 11:38 AM   #8
thedaddyb
Scooby Specialist
 
Member#: 64374
Join Date: Jun 2004
Chapter/Region: MAIC
Location: Baltimore, MD
Vehicle:
07 WRX SWP *SOLD
03 2.5ts BRP long gone

Default

you had to hold it down for a couple of seconds. similar to how you have to adjust the shift light.
thedaddyb is offline   Reply With Quote
Old 04-07-2008, 04:48 PM   #9
FigNuts
Scooby Specialist
 
Member#: 125413
Join Date: Sep 2006
Chapter/Region: NWIC
Location: Tualatin, OR
Default

I've got an 05 STi cluster in my 02 WRX and all that I have to do is push the odometer knob twice and then I get the illumination menu. Then you just rotate the knob counter-clockwise to dim.
FigNuts is offline   Reply With Quote
Old 04-07-2008, 05:29 PM   #10
tonecold
Scooby Newbie
 
Member#: 37476
Join Date: May 2003
Chapter/Region: BAIC
Location: Milpitas, CA
Vehicle:
MY02 WRX Stage 2
PSM (215whp/223wtq)

Default

^^^^Glad to know it works on the 05 STi.
Did you just cut the B28 and A9 wire?

AFAIK, the only difference between 05 and 06 is the 06 has two more pins in the C connector? Or does the 05 also have two more pins?

At any rate, I wonder why I can't access this ILL menu.....
tonecold is offline   Reply With Quote
Old 04-07-2008, 05:31 PM   #11
Cyclops
Scooby Specialist
 
Member#: 95017
Join Date: Sep 2005
Chapter/Region: NWIC
Location: Everett, WA
Vehicle:
2000 2.2RSTI stroker
2010 SWP STI

Default

Quote:
Originally Posted by FigNuts View Post
I've got an 05 STi cluster in my 02 WRX and all that I have to do is push the odometer knob twice and then I get the illumination menu. Then you just rotate the knob counter-clockwise to dim.
Yep. Exact same for me. Also, it has two different ILL settings, one for when your headlights are on and one for when they're off. I have my headlights on setting to the second brightest and my headlights off to the brightest and it works great. Someone posted up some big complicated thing on how to attached it to the stalk dimmer but that seems pointless.
Cyclops is offline   Reply With Quote
Old 04-07-2008, 05:36 PM   #12
FigNuts
Scooby Specialist
 
Member#: 125413
Join Date: Sep 2006
Chapter/Region: NWIC
Location: Tualatin, OR
Default

[quote=tonecold;21820338Did you just cut the B28 and A9 wire?
[/quote]


I know I cut the b28 but I cannot remember if I cut the a9 wire. I followed a write-up that I came across.
FigNuts is offline   Reply With Quote
Old 04-07-2008, 05:44 PM   #13
Cyclops
Scooby Specialist
 
Member#: 95017
Join Date: Sep 2005
Chapter/Region: NWIC
Location: Everett, WA
Vehicle:
2000 2.2RSTI stroker
2010 SWP STI

Default

Quote:
Originally Posted by tonecold View Post
^^^^Glad to know it works on the 05 STi.
Did you just cut the B28 and A9 wire?

AFAIK, the only difference between 05 and 06 is the 06 has two more pins in the C connector? Or does the 05 also have two more pins?

At any rate, I wonder why I can't access this ILL menu.....
Yes, it has 2 extra pins on the 05. I had to shave off a couple guides on my 02 wiring harness to make it fit right. I cut the A9 and B28 wires just because that's what the walkthrough said to do. My dimmer works just fine, try pushing in the right knob a few times and see if it says ILL. I just hit it until it says that then hold down the rev limiter thing and it adjusts.
Cyclops is offline   Reply With Quote
Old 04-07-2008, 05:52 PM   #14
HERSHEY
Scooby Specialist
 
Member#: 148549
Join Date: May 2007
Chapter/Region: NESIC
Location: RI
Vehicle:
95 RHD GC V7 STi
04 WRX, Sold the BlackSTi

Default

I have the 04 jdm sti cluster and can't get the dimming to work, hopefully all this will work. Anyone know how to make the thermometer to work? Do I have to buy some kind of piece or something?
HERSHEY is offline   Reply With Quote
Old 04-07-2008, 05:54 PM   #15
Cyclops
Scooby Specialist
 
Member#: 95017
Join Date: Sep 2005
Chapter/Region: NWIC
Location: Everett, WA
Vehicle:
2000 2.2RSTI stroker
2010 SWP STI

Default

Quote:
Originally Posted by HERSHEY View Post
I have the 04 jdm sti cluster and can't get the dimming to work, hopefully all this will work. Anyone know how to make the thermometer to work? Do I have to buy some kind of piece or something?
There was a post somewhere on scoobymods about that. You have to buy a third party thermometer and wire it all up with the cluster harness to make it read outside temp.
Cyclops is offline   Reply With Quote
Old 04-07-2008, 06:22 PM   #16
tonecold
Scooby Newbie
 
Member#: 37476
Join Date: May 2003
Chapter/Region: BAIC
Location: Milpitas, CA
Vehicle:
MY02 WRX Stage 2
PSM (215whp/223wtq)

Default

Quote:
Originally Posted by Cyclops View Post
Yes, it has 2 extra pins on the 05. I had to shave off a couple guides on my 02 wiring harness to make it fit right. I cut the A9 and B28 wires just because that's what the walkthrough said to do. My dimmer works just fine, try pushing in the right knob a few times and see if it says ILL. I just hit it until it says that then hold down the rev limiter thing and it adjusts.
Hmmm... is there something different about the 05 STi vs. 06 STi that is not allowing me to change the dimming?

I guess what I need is someone with an 06STi cluster in 02 bugeye to confirm that it does work!
tonecold is offline   Reply With Quote
Old 04-07-2008, 06:31 PM   #17
Cyclops
Scooby Specialist
 
Member#: 95017
Join Date: Sep 2005
Chapter/Region: NWIC
Location: Everett, WA
Vehicle:
2000 2.2RSTI stroker
2010 SWP STI

Default

Yeah that's really bizarre, I wonder if they made it only dimmed by turning the stalk adjuster.
Cyclops is offline   Reply With Quote
Old 04-09-2008, 03:10 AM   #18
tonecold
Scooby Newbie
 
Member#: 37476
Join Date: May 2003
Chapter/Region: BAIC
Location: Milpitas, CA
Vehicle:
MY02 WRX Stage 2
PSM (215whp/223wtq)

Default

Bump for some 06 STi guys help on how to DIM.

04 STi guys can push on the Trip knob to adjust the dimming.

05 STi guys can push on the Trip knob to adjust the dimming, but have two ILL options (Headlights on/off)
tonecold is offline   Reply With Quote
Old 04-09-2008, 03:12 AM   #19
tonecold
Scooby Newbie
 
Member#: 37476
Join Date: May 2003
Chapter/Region: BAIC
Location: Milpitas, CA
Vehicle:
MY02 WRX Stage 2
PSM (215whp/223wtq)

Default

Here is how to get the OAT (Outside Air Temperature) to work.

http://scoobymods.com/forums/showthr...erature+sensor

How to install 05STi in 02-03
http://forums.nasioc.com/forums/show...temp+light+STI
tonecold is offline   Reply With Quote
Old 11-23-2012, 09:38 PM   #20
youngjom
Scooby Newbie
 
Member#: 125706
Join Date: Sep 2006
Chapter/Region: South East
Location: Irvine, CA
Vehicle:
2003 bugeye sedan
midnight black

Default

OP were you able to fix the issue? I put in an 07 sti gauge cluster in my 03 bugeye and i cant dim my cluster either... tried holding down and just pressing the trip button but i dont see any ILL menu... arghhh these things are so damn bright at night times...
youngjom is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install LED in Gauge Cluster T-Johnson16 Electrical & Lighting 2 03-28-2010 02:34 PM
how to put the sti on the 02-03 fog light covers ownnij Interior & Exterior Modification 9 07-15-2007 08:29 PM
Where to find oem sti gauge cluster? Ntercooled Interior & Exterior Modification 8 08-15-2006 05:41 AM
how to dim the DEFI BF's txjunglist Interior & Exterior Modification 5 12-27-2004 11:44 AM
Does anyone have any pics/instructions of how to do the GC8 gauge cluster mod? psyber_0ptix Interior & Exterior Modification 7 12-20-2004 11:33 PM


All times are GMT -4. The time now is 01:52 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.