Welcome to the North American Subaru Impreza Owners Club Saturday December 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-18-2013, 11:50 PM   #26
QwaktastiK
Scooby Specialist
 
Member#: 219100
Join Date: Aug 2009
Chapter/Region: Tri-State
Location: Philadelphia, PA
Vehicle:
'09 WRX Premium 5dr
COBB Stg3 336whp/370wtq

Default

Bump. Getting an inspection tomorrow and going to have the dealership take a look at this. Hoping they can fix it. The squeak is now the loudest thing on my car and I'm modded.
* Registered users of the site do not see these ads.
QwaktastiK is offline   Reply With Quote
Old 08-21-2013, 07:49 PM   #27
Armyofcase
Scooby Newbie
 
Member#: 281396
Join Date: Apr 2011
Chapter/Region: South East
Location: Knoxville, TN
Vehicle:
2009 WRX Sedan
World Rally Blue

Default

Have them check the welds on the firewall. I've got a thread on here with pics I just posted about the issues I was facing...
Armyofcase is offline   Reply With Quote
Old 08-22-2013, 12:20 PM   #28
QwaktastiK
Scooby Specialist
 
Member#: 219100
Join Date: Aug 2009
Chapter/Region: Tri-State
Location: Philadelphia, PA
Vehicle:
'09 WRX Premium 5dr
COBB Stg3 336whp/370wtq

Default

Yeah. I'm posting in both threads too. Dealership is taking care of it under my extended warranty. They need the car for several days. Have the appt scheduled for the first Tues in Sept.
QwaktastiK is offline   Reply With Quote
Old 08-25-2013, 01:02 PM   #29
thunderbucks
Scooby Newbie
 
Member#: 365131
Join Date: Aug 2013
Location: Greenfield, MA
Vehicle:
2013 WRX Limited 4dr
Crystal Black Silica

Default

Quote:
Originally Posted by Snow Drift View Post
My 2008 had two different types of sounds, here is what I did:

1) Spray the arm of the clutch pedal with WD-40. This stopped mine from making noises (besides the 100% normal high pitched click sound). This sound happened almost every time I used the clutch.
My car has 838 miles and makes this noise every shift while driving.

Is it normal to have to WD-40 a car with less than a thousand miles? There could be worse things wrong with my car, but c'mon this is driving me nuts. I just want to enjoy the damn thing w/o any noises for at least a couple months.
thunderbucks is offline   Reply With Quote
Old 08-25-2013, 10:27 PM   #30
QwaktastiK
Scooby Specialist
 
Member#: 219100
Join Date: Aug 2009
Chapter/Region: Tri-State
Location: Philadelphia, PA
Vehicle:
'09 WRX Premium 5dr
COBB Stg3 336whp/370wtq

Default

Quote:
Originally Posted by thunderbucks View Post
My car has 838 miles and makes this noise every shift while driving.

Is it normal to have to WD-40 a car with less than a thousand miles? There could be worse things wrong with my car, but c'mon this is driving me nuts. I just want to enjoy the damn thing w/o any noises for at least a couple months.
Take it back to the dealership and tell them to give you a car without the squeaky clutch pedal option.
QwaktastiK is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 WRX Clutch Chirp & Squeak Haohmaru Transmission (AT/MT) & Driveline 8 04-22-2012 07:42 PM
07 wrx clutch replacement SQUEAK?? NEED HELP!! shocker47 Transmission (AT/MT) & Driveline 3 04-10-2012 07:23 PM
Clutch noise/squeak subasurf Transmission (AT/MT) & Driveline 2 05-06-2011 12:13 PM
2010 WRX crazy noise after clutch install Odin2347 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 6 06-27-2010 02:42 AM
06 WRX Clutch Pedal Squeaking suBooneru Warranty Issues & SOA Problems 4 02-08-2006 09:56 AM


All times are GMT -4. The time now is 07:15 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.