Welcome to the North American Subaru Impreza Owners Club Wednesday October 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-07-2012, 01:46 PM   #1
mike the pipe
Scooby Newbie
 
Member#: 297236
Join Date: Oct 2011
Location: malta
Vehicle:
2003 wrx edm
blue

Default launch control

anybody know where i can get lc patch from for 03 edm A4TE001G from?
* Registered users of the site do not see these ads.
mike the pipe is offline   Reply With Quote
Old 06-07-2012, 01:57 PM   #2
wgr73
Scooby Specialist
 
Member#: 232458
Join Date: Dec 2009
Chapter/Region: SWIC
Location: Las Cruces, El Paso
Vehicle:
2008 STi (OBP)
CAMTuning.com

Default

TinyWrex?
wgr73 is offline   Reply With Quote
Old 06-08-2012, 07:53 AM   #3
fast377
Scooby Newbie
 
Member#: 256942
Join Date: Sep 2010
Chapter/Region: South East
Location: Kingsland, GA
Vehicle:
2002 WRX
WRB

Default

fast377 is offline   Reply With Quote
Old 06-08-2012, 12:11 PM   #4
mike the pipe
Scooby Newbie
 
Member#: 297236
Join Date: Oct 2011
Location: malta
Vehicle:
2003 wrx edm
blue

Default

tinywrex site seems to be down and the link says downloadable free patch but doesn`t seem to work. what do you guys suggest?
mike the pipe is offline   Reply With Quote
Old 06-08-2012, 06:57 PM   #5
fast377
Scooby Newbie
 
Member#: 256942
Join Date: Sep 2010
Chapter/Region: South East
Location: Kingsland, GA
Vehicle:
2002 WRX
WRB

Default

Quote:
Originally Posted by mike the pipe View Post
tinywrex site seems to be down and the link says downloadable free patch but doesn`t seem to work. what do you guys suggest?
It works, but works funny. I just downloaded one and it kept giving me errors. Add it to your cart, and check out as if you were paying for it. You will have to create an account, but when it comes time to checkout it will show a zero balance. Confirm that, and that's where I got an error...but the next day, the file was in my email. Their site says allow 24 hours for the download to be emailed to you.
fast377 is offline   Reply With Quote
Old 06-10-2012, 07:42 AM   #6
mike the pipe
Scooby Newbie
 
Member#: 297236
Join Date: Oct 2011
Location: malta
Vehicle:
2003 wrx edm
blue

Default

excellent i recieved the patch and unzipped it. now can`t really get it to work. how do i know if my 16 bit rom image is 192k? plus are these the easiest instr or could it be i`m not understanding the language.
mike the pipe is offline   Reply With Quote
Old 06-10-2012, 07:57 AM   #7
fast377
Scooby Newbie
 
Member#: 256942
Join Date: Sep 2010
Chapter/Region: South East
Location: Kingsland, GA
Vehicle:
2002 WRX
WRB

Default

Save a copy of your map/tune then right click go to properties...tells you the size. Instructions probably aren't the easiest to understand if you aren't familiar with the language...but follow them exactly and you will be fine.
fast377 is offline   Reply With Quote
Old 06-10-2012, 11:38 AM   #8
mike the pipe
Scooby Newbie
 
Member#: 297236
Join Date: Oct 2011
Location: malta
Vehicle:
2003 wrx edm
blue

Default

thanks dude you are a real help if i could i1d by you beer! oh well my rom is 160k. now i`ll have to convert it.
mike the pipe is offline   Reply With Quote
Old 06-10-2012, 05:27 PM   #9
fast377
Scooby Newbie
 
Member#: 256942
Join Date: Sep 2010
Chapter/Region: South East
Location: Kingsland, GA
Vehicle:
2002 WRX
WRB

Default

No problem. Yes, you will have to convert your ROM. Easiest way is to download ecuedit. Read your rom, convert to 192k and save.
fast377 is offline   Reply With Quote
Old 06-11-2012, 06:03 AM   #10
mike the pipe
Scooby Newbie
 
Member#: 297236
Join Date: Oct 2011
Location: malta
Vehicle:
2003 wrx edm
blue

Default

ok another prob. when i unzipped the download the folder shows ecuflash.xml, patch, unpatch, tinypatcher and patch.dif. when i open tinypatcher it says invalid command line. none of the other files work.
mike the pipe is offline   Reply With Quote
Old 06-11-2012, 06:19 AM   #11
fast377
Scooby Newbie
 
Member#: 256942
Join Date: Sep 2010
Chapter/Region: South East
Location: Kingsland, GA
Vehicle:
2002 WRX
WRB

Default

When you unzip the files, you need to extract them to a new folder. If you want to use tinypatcher, you have to do it from the command prompt (old dos prompt) and type in exactly what the instruction say (click start, then search for "cmd" to bring up prompt). OR you can double click patch.bat and use it...your choice.
fast377 is offline   Reply With Quote
Old 06-11-2012, 04:57 PM   #12
mike the pipe
Scooby Newbie
 
Member#: 297236
Join Date: Oct 2011
Location: malta
Vehicle:
2003 wrx edm
blue

Default

ok another prob the patch is showing up when i open my rom in ecu flash but there are values already there and the instr say they should have already been set to zero for the first time and says not to use this rom cause i could have used an incompatable rom.
mike the pipe is offline   Reply With Quote
Old 06-11-2012, 07:19 PM   #13
fast377
Scooby Newbie
 
Member#: 256942
Join Date: Sep 2010
Chapter/Region: South East
Location: Kingsland, GA
Vehicle:
2002 WRX
WRB

Default

Did you download the old free version of ecuedit or the new trial version? I would say, it's either something with the trial version and the 192k conversion or when you initially open your rom in ecuflash, you aren't actually opening the new "patched" rom...which is an easy mistake, and would be my guess.
fast377 is offline   Reply With Quote
Old 06-13-2012, 06:07 AM   #14
mike the pipe
Scooby Newbie
 
Member#: 297236
Join Date: Oct 2011
Location: malta
Vehicle:
2003 wrx edm
blue

Default

ok the ver 1.2.0.72 is the one i downloaded and the rom i opened is the one that was in the same folder as the patch which now reads mike_rom_.hex.192.bin. before i did the conversion 192 wasn`t there.the patch shows in ecuflash when i open the rom just with added values and not 0.
mike the pipe is offline   Reply With Quote
Old 06-13-2012, 06:30 PM   #15
mike the pipe
Scooby Newbie
 
Member#: 297236
Join Date: Oct 2011
Location: malta
Vehicle:
2003 wrx edm
blue

Default

ok bare with me i confermed that my rom (map to be flashed with new patch) is not patched thats why i have the added values in ecuflash. the prob is that the patch that i want to apply to the rom will not run.
mike the pipe is offline   Reply With Quote
Old 06-13-2012, 09:03 PM   #16
fast377
Scooby Newbie
 
Member#: 256942
Join Date: Sep 2010
Chapter/Region: South East
Location: Kingsland, GA
Vehicle:
2002 WRX
WRB

Default

So you pulled the rom from the car. Converted that rom to 192k. And you can't apply the patch to the 192k rom? If that's the case, check the name you gave to your rom. When I did mine, I had to change the name before the patch would take it. It wouldn't work with spaces (i.e. my rom WAS "02 WRX_192" and I had to change it to"02_WRX_192" before it would work.
fast377 is offline   Reply With Quote
Old 06-14-2012, 11:34 AM   #17
mike the pipe
Scooby Newbie
 
Member#: 297236
Join Date: Oct 2011
Location: malta
Vehicle:
2003 wrx edm
blue

Default

exactly exactly but when it says in the intru run the patch then follow on screen instru the promt opens for like 1 sec then closes.
mike the pipe is offline   Reply With Quote
Old 06-15-2012, 08:01 AM   #18
fast377
Scooby Newbie
 
Member#: 256942
Join Date: Sep 2010
Chapter/Region: South East
Location: Kingsland, GA
Vehicle:
2002 WRX
WRB

Default

Quote:
Originally Posted by mike the pipe
exactly exactly but when it says in the intru run the patch then follow on screen instru the promt opens for like 1 sec then closes.
If you don't extract the zipped files to a dedicated folder of your creation, it will do that. Make a folder on your desktop and put all the files from the zip folder in it. Or have you done that already?
fast377 is offline   Reply With Quote
Old 06-15-2012, 12:02 PM   #19
mike the pipe
Scooby Newbie
 
Member#: 297236
Join Date: Oct 2011
Location: malta
Vehicle:
2003 wrx edm
blue

Default

yes thats what the instru say and thats what i did. desktop folder i unzipped the download into a new folder (desktop) and even tried running it with different prog and still. what do you run it with? i hopr its not a windows 7 prob.
mike the pipe is offline   Reply With Quote
Old 06-15-2012, 07:21 PM   #20
jnich69
Scooby Newbie
 
Member#: 242484
Join Date: Mar 2010
Chapter/Region: MAIC
Location: Pittsburgh/Cal U
Vehicle:
2003 18g'ed wrx
sunset orange metallic

Default

Quote:
Originally Posted by mike the pipe View Post
yes thats what the instru say and thats what i did. desktop folder i unzipped the download into a new folder (desktop) and even tried running it with different prog and still. what do you run it with? i hopr its not a windows 7 prob.
It shouldn't be a windows 7 problem. I just patched my rom running windows 7 about two days ago.
jnich69 is offline   Reply With Quote
Old 06-15-2012, 07:50 PM   #21
mike the pipe
Scooby Newbie
 
Member#: 297236
Join Date: Oct 2011
Location: malta
Vehicle:
2003 wrx edm
blue

Default

ok dudes just figured it out. i didnt realize that my rom file was saved as a .bin file not the name but the file although it was named xxxxx.hex. so now i changed the entire name and now comes up as a .hex file then converted to 192k, ran the patch and presto all values show 0 in ecu flash. now just need to set the values at what i want lc and flash. any suggestions?
mike the pipe is offline   Reply With Quote
Old 06-16-2012, 02:07 AM   #22
mike the pipe
Scooby Newbie
 
Member#: 297236
Join Date: Oct 2011
Location: malta
Vehicle:
2003 wrx edm
blue

Default

oh just remembered that i didn`t get the checksum incorrect window but values where all 0. does it make a difference or is my ecuflash patch incorrect.
mike the pipe is offline   Reply With Quote
Old 06-16-2012, 07:21 AM   #23
fast377
Scooby Newbie
 
Member#: 256942
Join Date: Sep 2010
Chapter/Region: South East
Location: Kingsland, GA
Vehicle:
2002 WRX
WRB

Default

Windows 7 here as well. And I didn't get the error like it said either. I don't think you are supposed to get it, I think it was telling you what to do if you did.
fast377 is offline   Reply With Quote
Old 06-17-2012, 03:53 PM   #24
mike the pipe
Scooby Newbie
 
Member#: 297236
Join Date: Oct 2011
Location: malta
Vehicle:
2003 wrx edm
blue

Default

ok guys i think i have things sorted now. when i get a chance i`ll flash.
mike the pipe is offline   Reply With Quote
Old 06-17-2012, 09:00 PM   #25
fast377
Scooby Newbie
 
Member#: 256942
Join Date: Sep 2010
Chapter/Region: South East
Location: Kingsland, GA
Vehicle:
2002 WRX
WRB

Default

Nice! Let us know how it goes.
fast377 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can Cruise control co-exist with launch control with the 2002 wrx Hydra? jigga Other Engine Management 5 04-17-2007 08:16 PM
Utec launch control tried out on my 03 wagon IA Performance Engine Management & Tuning 20 03-19-2003 07:07 PM
UTEC launch control in full effect. Opinions within IA Performance Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 56 03-13-2003 07:46 PM
UTEC Launch control rev limiter? Typhoon Engine Management & Tuning 6 01-28-2003 09:08 PM
Launch control and flat shift...what do you think? Onederer Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 29 10-23-2002 06:40 PM


All times are GMT -4. The time now is 09:30 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.