Welcome to the North American Subaru Impreza Owners Club Wednesday April 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-11-2012, 10:47 AM   #1
ZeroMOA
Scooby Newbie
 
Member#: 228127
Join Date: Oct 2009
Chapter/Region: NESIC
Location: Fremont, NH
Vehicle:
2002 2.5RS
truck bed liner

Default Green "POWER" light coming on!?!? 02 2.5RS 5spd

I have a 2002 2.5RS 5spd. and yesterday the green "POWER" light came on in the gauge cluster (above the E-brake light). I have called 5 Subaru dealerships and none of the techs have heard of this. Internet results only yield pre-OBDII automatic transmission codes. PS fluid is good, charging system is good, car is running and driving fine. I hooked up my scan tool and it doesn't read any codes. I am perplexed. Any suggestions? Anyone else experience this?
* Registered users of the site do not see these ads.
ZeroMOA is offline   Reply With Quote
Old 07-11-2012, 06:33 PM   #2
bakaichi
Scooby Newbie
 
Member#: 301619
Join Date: Nov 2011
Location: Langley, B.C.
Vehicle:
2009 2.5i Hatch
Dark Grey Metallic

Default

Its telling you... it need more power up upgrades...
kidding..

sorry cant help you on this one .

hope some one can chin in on some advice ~
bakaichi is offline   Reply With Quote
Old 07-11-2012, 08:12 PM   #3
subiidude
Scooby Specialist
 
Member#: 141472
Join Date: Feb 2007
Chapter/Region: MAIC
Location: moco
Vehicle:
2008 shagg wgn STI
OG FP20g+e85 corn booze

Default

the owners Manuel will shows what all the lights on the dash mean... flip through it and double check because ive never head of a green "POWER" light for a non turbo suby lol
subiidude is offline   Reply With Quote
Old 07-11-2012, 09:20 PM   #4
strychnine
*** Banned ***
 
Member#: 316108
Join Date: Apr 2012
Default

^ Nope. It certainly doesn't.

subaru.com > contact us

they usually get to you in a day or two.

Also I'm fairly sure cross posting isn't allowed. Probably on the other forums you posted on too.
strychnine is offline   Reply With Quote
Old 07-11-2012, 10:56 PM   #5
Bluefoton
Scooby Specialist
 
Member#: 141373
Join Date: Feb 2007
Chapter/Region: E. Canada
Location: Quebec, QC
Vehicle:
2008 2.5i-hatch -
now with a HID retrofit

Default

used to have a bugeye, never saw such light...
Bluefoton is offline   Reply With Quote
Old 07-12-2012, 07:14 AM   #6
Duvanator
Scooby Newbie
 
Member#: 217257
Join Date: Jul 2009
Location: Thunder Bay, Canada
Vehicle:
2008 2.5i hatch
white pearl + HID retro

Default

I know exactly what light your talking about, and right beside it is and amber 'manual' light? Do you have a 'manual' push button on the side if your shifter?
Duvanator is online now   Reply With Quote
Old 07-12-2012, 07:15 AM   #7
Duvanator
Scooby Newbie
 
Member#: 217257
Join Date: Jul 2009
Location: Thunder Bay, Canada
Vehicle:
2008 2.5i hatch
white pearl + HID retro

Default

I had a 1990 Subaru legacy with the 4eat which had that
Duvanator is online now   Reply With Quote
Old 07-12-2012, 09:18 AM   #8
ZeroMOA
Scooby Newbie
 
Member#: 228127
Join Date: Oct 2009
Chapter/Region: NESIC
Location: Fremont, NH
Vehicle:
2002 2.5RS
truck bed liner

Default

Quote:
Originally Posted by strychnine View Post
^ Nope. It certainly doesn't.

subaru.com > contact us

they usually get to you in a day or two.

Also I'm fairly sure cross posting isn't allowed. Probably on the other forums you posted on too.
I am not allowed to post the same question to multiple communities?
NASIOC rules do not apply to RS25 or DirtyImpreza or any other site. Cross-posting only applies to the different forums within NASIOC (eg. "Motorsports" & "General Community")

also, thanks for the subaru.com suggestion, humorously, that didn't cross my mind
ZeroMOA is offline   Reply With Quote
Old 07-12-2012, 09:19 AM   #9
ZeroMOA
Scooby Newbie
 
Member#: 228127
Join Date: Oct 2009
Chapter/Region: NESIC
Location: Fremont, NH
Vehicle:
2002 2.5RS
truck bed liner

Default

Quote:
Originally Posted by Duvanator View Post
I know exactly what light your talking about, and right beside it is and amber 'manual' light? Do you have a 'manual' push button on the side if your shifter?
not an automatic
ZeroMOA is offline   Reply With Quote
Old 07-12-2012, 09:25 AM   #10
Psychoreo
Scooby Guru
 
Member#: 79643
Join Date: Jan 2005
Chapter/Region: NESIC
Location: New Britain
Vehicle:
04 EJ207 Swapped
Mikey tuned 271whp/287wtq

Default

I have this light on my JDM cluster. It doesn't turn on though....


EDIT: according to a forester website and the google machine, the light is for automatic transmission codes.

If you have a manual, just remove the light
Psychoreo is offline   Reply With Quote
Old 07-16-2012, 09:34 AM   #11
ZeroMOA
Scooby Newbie
 
Member#: 228127
Join Date: Oct 2009
Chapter/Region: NESIC
Location: Fremont, NH
Vehicle:
2002 2.5RS
truck bed liner

Default

Quote:
Originally Posted by Psychoreo View Post
I have this light on my JDM cluster. It doesn't turn on though....


EDIT: according to a forester website and the google machine, the light is for automatic transmission codes.

If you have a manual, just remove the light
nah, i'm gonna rig it so it's always on. I like power
ZeroMOA is offline   Reply With Quote
Old 07-16-2012, 07:52 PM   #12
Rudgers73
Scooby Newbie
 
Member#: 141433
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Rochester, NY
Vehicle:
2006 Impreza 2.5i
Obsidian Black

Default

Just a thought: if it is on and it isn't normally something that should be on in your car there is a chance that a couple of pins on your ECU are shorted together that shouldn't be (moisture maybe). Just a guess thought. My dad was working on a ford focus once and the scanner tool was showing a bunch of turbo-based errors and sure enough he unplugged the harness to the ECU and a bunch of water poured out. let it dry overnight and everything was fine again
Rudgers73 is offline   Reply With Quote
Old 07-17-2012, 01:04 AM   #13
T Wrex--OH
Scooby Specialist
 
Member#: 179478
Join Date: May 2008
Chapter/Region: MWSOC
Location: Cleveland<OH>
Vehicle:
2000 Impreza 2.5 RS
Sedona Red Pearl

Default

T Wrex--OH is offline   Reply With Quote
Old 07-19-2012, 09:16 AM   #14
zavier
Scooby Specialist
 
Member#: 141189
Join Date: Feb 2007
Chapter/Region: Tri-State
Location: Philadelphia
Vehicle:
2007 2.5i (NBP)
2014 BRZ (DGM)

Default

Quote:
Originally Posted by T Wrex--OH View Post
He said it's not an automatic...hence not a 4EAT...unless it WAS one and it was swapped to a manual at some point, then the cluster would still have the light.
zavier is offline   Reply With Quote
Old 07-19-2012, 09:59 AM   #15
scarney1988
Scooby Newbie
 
Member#: 317760
Join Date: Apr 2012
Default

The thing either had the cluster swapped or the trans swapped it seems like. CarFax the vin and compare miles?
scarney1988 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:18 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.