Welcome to the North American Subaru Impreza Owners Club Monday July 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-26-2012, 01:52 PM   #1
RBrady29
Scooby Newbie
 
Member#: 254241
Join Date: Aug 2010
Chapter/Region: MWSOC
Location: Westerville, Ohio
Vehicle:
2005 wrx
silver

Default 08 WRX instrument cluster in an 05?

So everyone hears about swapping out the STI instrument cluster in their WRX but i would rather keep the WRX logo in my car so i was wondering if anyone has done this or heard if the 08 WRX cluster would fit in a 05? I would assume the fitment would work I am more concerned about the wiring, so any advice would be appreciated!
* Registered users of the site do not see these ads.
RBrady29 is offline   Reply With Quote
Old 07-27-2012, 02:19 AM   #2
alt14
Scooby Specialist
 
Member#: 271928
Join Date: Jan 2011
Chapter/Region: Tri-State
Location: Gettysburg PA
Vehicle:
2014 WRX Limited
Crystal Black Silica

Default

I'm not sure an 08 cluster would fit an older model, they look different out side of the dash
alt14 is offline   Reply With Quote
Old 07-27-2012, 02:24 AM   #3
rob1n1
Scooby Specialist
 
Member#: 276425
Join Date: Mar 2011
Chapter/Region: NWIC
Location: Seattle, WA
Default

Quote:
Originally Posted by RBrady29 View Post
So everyone hears about swapping out the STI instrument cluster in their WRX but i would rather keep the WRX logo in my car so i was wondering if anyone has done this or heard if the 08 WRX cluster would fit in a 05? I would assume the fitment would work I am more concerned about the wiring, so any advice would be appreciated!
Do you want the red color? You can do that easily, search around for the color change howto.

As for fitting a GR (08+) cluster into a GD (02-07), 99% sure that wouldn't work based on the fact that I'm pretty certain they're different sizes.
rob1n1 is offline   Reply With Quote
Old 07-27-2012, 11:08 AM   #4
alt14
Scooby Specialist
 
Member#: 271928
Join Date: Jan 2011
Chapter/Region: Tri-State
Location: Gettysburg PA
Vehicle:
2014 WRX Limited
Crystal Black Silica

Default

I thought so, the old style dips down on the sides and the new ones are more flat, not to say the three tabs wouldn't be in the same place
alt14 is offline   Reply With Quote
Old 07-27-2012, 11:20 AM   #5
All4bSpinnin
Scooby Guru
 
Member#: 99102
Join Date: Oct 2005
Chapter/Region: South East
Location: Jax, FL
Vehicle:
08 Corvette Z06
problem Traction?

Default

the clusters are different in shape... you can get around that by doing some custom work but the real question is the wiring...
All4bSpinnin is offline   Reply With Quote
Old 07-27-2012, 12:19 PM   #6
RBrady29
Scooby Newbie
 
Member#: 254241
Join Date: Aug 2010
Chapter/Region: MWSOC
Location: Westerville, Ohio
Vehicle:
2005 wrx
silver

Default

i was looking at the set up of the wiring for both years the 08s seemed to have one big plug instead of multiple different ones
RBrady29 is offline   Reply With Quote
Old 07-27-2012, 02:26 PM   #7
All4bSpinnin
Scooby Guru
 
Member#: 99102
Join Date: Oct 2005
Chapter/Region: South East
Location: Jax, FL
Vehicle:
08 Corvette Z06
problem Traction?

Default

you'll need to get a wiring diagram for both... does anyone know if the tach signal is the same?
All4bSpinnin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:47 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.