Welcome to the North American Subaru Impreza Owners Club Saturday July 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-28-2012, 06:21 PM   #1
FabCruz
Scooby Newbie
 
Member#: 299797
Join Date: Nov 2011
Chapter/Region: SCIC
Location: Los Angeles/Temecula/San Diego
Vehicle:
2012 STi Sedan
SWP

Default Lights on dash randomy went off.

I have a 2012 STi and was wondering if this has happened to anyone.

Since I do not have tpms sensors on my wheels that's been on of course but the abs, hill assist, and traction light randomly went off after exiting the freeway. I was stuck in traffic for about an hr and a half. Then drove about 30 mins home.

I did a short pull in 2nd till about 5k rpms then looked down and the lights were on. But it might have been on before that without me noticing.

Got home turned the car off started it back up after a min or so then it was gone.

Anyone know what that's all about?

Car is completely stock aside from nameless axleback.
* Registered users of the site do not see these ads.
FabCruz is offline   Reply With Quote
Old 07-29-2012, 01:23 PM   #2
Scubalu
Scooby Newbie
 
Member#: 326743
Join Date: Jul 2012
Location: Sunrise beach, Mo
Vehicle:
91 3000gt vr4
Cyber grey

Default

Is like to know too! My car randomly turns on the engine light, cruise control, and traction light. Then will shut off a couple days later?
Scubalu is offline   Reply With Quote
Old 07-29-2012, 03:19 PM   #3
FabCruz
Scooby Newbie
 
Member#: 299797
Join Date: Nov 2011
Chapter/Region: SCIC
Location: Los Angeles/Temecula/San Diego
Vehicle:
2012 STi Sedan
SWP

Default

Quote:
Originally Posted by Scubalu
Is like to know too! My car randomly turns on the engine light, cruise control, and traction light. Then will shut off a couple days later?
So yours stays on for a couple days?
FabCruz is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:16 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.