Welcome to the North American Subaru Impreza Owners Club Saturday October 22, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 07-30-2012, 12:26 PM   #1
Scooby Specialist
Member#: 205629
Join Date: Mar 2009
Chapter/Region: Tri-State
Location: In the woods, NJ
'04 v7 207 WRX
Dull version of JBP

Default Headlight confusion.

So for the past few months my headlights have been acting very strange.

What I have gathered from the past few months of observation is as follows.

With the headlight switch on the column switched on to just the low beams the passenger side low beam is bright (as it should be). Meanwhile the driver side high and low beam are both glowing a feint orange. When I push the lever on the steering column to engage the high beams only the passenger side high beam comes on, but the passenger side low beam also stays on and bright.

Fogs are unaffected thus far.

Things I have replaced to attempt to fix the problem.
1.Socket for headlight on driver side.
2.Both relays in the junction box under the hood.
3.Both the headlight and fog light switch that are behind the glove box.
~ I checked the ground locations that I knew of connected to the front harness. Cleaned them and tightened them back down.
~Also considering replacing the switch on the steering column.

I hope someone on here has the electrical knowledge to help. I really don't want to go to a dealership for fear of the cost.
If it will help I will take a few pictures.

Thanks for reading.
* Registered users of the site do not see these ads.
BbugWag is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-30-2012, 01:33 PM   #2
Trust no one
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
02 WRX
15 WRX/05 GTO


Check the driver side headlight fuse in the engine fuse box.
Mulder is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 09:55 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.