Welcome to the North American Subaru Impreza Owners Club Thursday December 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Interior & Exterior Modification

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-19-2014, 11:06 PM   #1
turbo sol
Scooby Newbie
 
Member#: 245106
Join Date: Apr 2010
Chapter/Region: MWSOC
Location: Kansas city
Vehicle:
2004 WRX Wagon
San Remo

Question Combo switch makes running lights come on?

So my headlights kept flickering, and I could here the relay clicking on an off as they did so.

coupled with the fact I could keep them on by wiggling my headlight switch (on the stalk) led me to clean up the contact as shown here.

It appears to have fixed my headlight issues, but now my rear running lights are on.

I even unplugged the headlight switch and they stayed on. can anyone help me out here?
* Registered users of the site do not see these ads.
turbo sol is offline   Reply With Quote
Old 03-19-2014, 11:46 PM   #2
turbo sol
Scooby Newbie
 
Member#: 245106
Join Date: Apr 2010
Chapter/Region: MWSOC
Location: Kansas city
Vehicle:
2004 WRX Wagon
San Remo

Default

figured it out.

i hit the switch on top of the steeting column when I reassembled things.

Im not used to that switch, but it forces the rear running lights to stay on with out a key.


I'll leave this here, because that link above is great to fix the combo switch issue.

http://honest-bob.com/combo-switch-fix/
turbo sol is offline   Reply With Quote
Old 03-19-2014, 11:54 PM   #3
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

dinsdale
Uncle Scotty is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:54 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.