Welcome to the North American Subaru Impreza Owners Club Monday December 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-08-2012, 09:23 AM   #1
caddkearney92
Scooby Newbie
 
Member#: 268482
Join Date: Dec 2010
Location: Pennsylvania
Vehicle:
2002 Outback Sport
Red

Default Engine Ping

I have an 02 OBS and about a year ago I started hearing an engine ping usually in 4th and 5th, my mechanic told me i could fix the problem by increasing the octane i put in to 89. That seemed to fix the problem but recently the pinging started up again, and again i was told to increase my octane but this time it had no effect. The only mod i have on the car is a ram air intake and im starting to think that may be the cause.

If anyone has any idea's I would be interested in hearing them
* Registered users of the site do not see these ads.
caddkearney92 is offline   Reply With Quote
Old 10-08-2012, 09:38 AM   #2
trife86
Scooby Newbie
 
Member#: 301368
Join Date: Nov 2011
Vehicle:
2012 WRX
PBP

Default

Start with a tune up
trife86 is offline   Reply With Quote
Old 10-08-2012, 09:48 AM   #3
Black94Snake
Scooby Specialist
 
Member#: 274499
Join Date: Feb 2011
Chapter/Region: NESIC
Location: RI
Vehicle:
1994 5.8T Cobra
565rwhp @ 10psi

Default

loose the intake, replace your plugs and pcv, and run some seafoam through the car.
Black94Snake is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:00 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.