Welcome to the North American Subaru Impreza Owners Club Tuesday September 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-08-2012, 01:27 AM   #1
Spy
Scooby Specialist
 
Member#: 60062
Join Date: Apr 2004
Chapter/Region: VIC
Location: Vancouver
Vehicle:
2000 Impreza 2.5RS
2009 Norco Team DH

Default GC: Rough idle and hesitation

My 2000 Impreza RS sometimes has a rough idle and some hesitation in lower RPMs, < 3000. Hoping someone with more knowledge might be able to help me out.

It seems like it only does it when its warm, but not all the time. On and off.

It has thrown two codes:
P0136 - Rear 02 sensor circuit malfunction
P0139 - Rear 02 sensor slow response

After I cleared these two codes, they haven't come back so I am hesitant to replace the expensive sensors if they aren't what is causing the problem.

Car seems to run a bit rich.
Coolant is normal colour and isn't burning or anything so I don't think its the head gasket.

-Timing belt: Recently replaced, tensioner was reused. Car ran perfect after with the new belt for some time before this happened.
-Oil and air filter changes have been done regularly
-Fuel filter hasn't been changed in quite some time
-Almost new spark plugs
-Spark plug wires haven't been changed in a long time, seem fine though
-Can't see any exhaust leaks

Here is the live data, maybe someone if able to tell if something doesn't look right. (Unfortunately, this was when the car was cold and idling fine)
https://www.dropbox.com/s/92md4cn72o...%2049%20PM.jpg
https://www.dropbox.com/s/8iwdw59z1p...%2041%20PM.jpg
https://www.dropbox.com/s/92md4cn72o...%2049%20PM.jpg

Thanks for your help.
* Registered users of the site do not see these ads.
Spy is offline   Reply With Quote
Old 08-08-2012, 07:19 PM   #2
Spy
Scooby Specialist
 
Member#: 60062
Join Date: Apr 2004
Chapter/Region: VIC
Location: Vancouver
Vehicle:
2000 Impreza 2.5RS
2009 Norco Team DH

Default

bumb! please help. Hesitation seemed to get worse a bit on the way to work today.

When I'm driving and then stop. Immediately after the idle is OK, but as I sit there idling it gets worse and worse. It doesn't stall, but gets close. And then it's hard to get going again sometimes as there is not power... feels like I have no gas and the car just bogs out, but I have lots of gas. Once I'm in higher RPM's there is no problem.
Spy is offline   Reply With Quote
Old 08-08-2012, 11:42 PM   #3
nasiocjunkie
Scooby Specialist
 
Member#: 80864
Join Date: Feb 2005
Chapter/Region: AKIC
Location: Anchorage, Alaska
Vehicle:
I'll have the tuna.
No crust.

Default

http://www.rs25.com/forums/f13/t6639...ere-first.html

If you're getting those codes then you should test your o2 sensor. If you don't know how to test it just change it out and see if it solved your problem (mine cost me about $68 at O'Reilly's Auto). Also you may want to clean or get your maf checked out with a scanner.
nasiocjunkie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:09 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.