Welcome to the North American Subaru Impreza Owners Club Tuesday July 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > General Community

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-22-2013, 05:36 PM   #8426
CASHxMONEYxMIKE
Scooby Specialist
 
Member#: 228719
Join Date: Nov 2009
Chapter/Region: NWIC
Location: Chicago NW Suburbs
Vehicle:
2013 STi
Satin White Pearl

Default

Lots of May deliveries! We're all together, hooray!!
* Registered users of the site do not see these ads.
CASHxMONEYxMIKE is offline   Reply With Quote
Old 04-22-2013, 05:45 PM   #8427
BrandonHtwo0
Scooby Newbie
 
Member#: 348212
Join Date: Feb 2013
Chapter/Region: MWSOC
Location: Portage, Indiana
Vehicle:
2013 STI Limited Sdn
SWP

Default

As promised, pictures of the new baby.

Did a hard break-in for 30 miles, then babied it for a bit with a couple WOT pulls every couple hundred miles. Engine braked after each pull. Put 1200 miles on it in 3 days (road trip from PA). RPM's never stayed the same for more than 10 seconds at a time...lots of shifting and made the trip hell lol.

But...it is sexy! And the STP exhaust is a beastly, throaty sound...



















BrandonHtwo0 is offline   Reply With Quote
Old 04-22-2013, 06:58 PM   #8428
JustinPGH
Scooby Newbie
 
Member#: 344834
Join Date: Jan 2013
Location: Pittsburgh
Vehicle:
2013 WRX 5-Door Lmtd
DGM

Default

Quote:
Originally Posted by CASHxMONEYxMIKE View Post
I started week 13 today
Me too... Seems like a lot of people with late January orders are starting to get details. I'm gonna call SOA again tomorrow, can't hurt!
JustinPGH is offline   Reply With Quote
Old 04-22-2013, 07:08 PM   #8429
punkNdrublic04
Scooby Newbie
 
Member#: 273621
Join Date: Feb 2011
Chapter/Region: Tri-State
Location: Ballston Lake, NY
Vehicle:
2013 WRX Limited
SWP Hatch

Default

Congrats to everyone who is getting their cars soon!

I just installed my SMY cluster and Defi boost gauge today.
punkNdrublic04 is online now   Reply With Quote
Old 04-22-2013, 07:12 PM   #8430
punkNdrublic04
Scooby Newbie
 
Member#: 273621
Join Date: Feb 2011
Chapter/Region: Tri-State
Location: Ballston Lake, NY
Vehicle:
2013 WRX Limited
SWP Hatch

Default

Quote:
Originally Posted by CASHxMONEYxMIKE View Post
You guys wanna hear some bull? So on Saturday i left work to go grab lunch, and I noticed my passenger rear tire was sunk down a little but not totally flat. So I rolled it back a little and saw a nail (slow leak). Filled it up and went to discount tire because they would fix it as it was under warranty. Turns out the inside sidewall was starting to ruin, so he couldn't fix that tire. And the other rear was already a little bald. So they gave me credit for the two rear and I had to buy two new tires for a car I'm getting rid of in less than a month. I'm pissed.
Wanna hear what happned to me last week?

So my WRX is a week old and only has 900 miles on her. I go to check the mail and when I'm pulling away from the mailboxes (I live in an apartment complex) I hear this clicking noise from me passenger side rear tire. I stop the car and see a huge ass license plate bolt sticking out of the middle of my tire!!!

Needless to say I FLIPPED OUT!!!

I had to bring my brand new car to a tire shop and have them plug my new tire with only 900 miles on it...I was/am so PISSSSSSEDDD!!!!!
punkNdrublic04 is online now   Reply With Quote
Old 04-22-2013, 07:34 PM   #8431
Heedlessone
Scooby Specialist
 
Member#: 254130
Join Date: Aug 2010
Chapter/Region: NWIC
Location: Bozeman, MT
Vehicle:
2004 STi
Twinscroll Goodness

Default

Quote:
Originally Posted by punkNdrublic04 View Post

Wanna hear what happned to me last week?

So my WRX is a week old and only has 900 miles on her. I go to check the mail and when I'm pulling away from the mailboxes (I live in an apartment complex) I hear this clicking noise from me passenger side rear tire. I stop the car and see a huge ass license plate bolt sticking out of the middle of my tire!!!

Needless to say I FLIPPED OUT!!!

I had to bring my brand new car to a tire shop and have them plug my new tire with only 900 miles on it...I was/am so PISSSSSSEDDD!!!!!
I'll top that.

Bought new tires, Toyo R1R's, last season for autox. Got them mounted and drove home. When I got home, with 30 miles on my brand new tires, there was a giant bolt on the outside tread block. Right on the edge where it's not repairable. I had to order another new tire, pull my wheel off and have the shop put the new one on, again.

Now that, is bull.
Heedlessone is offline   Reply With Quote
Old 04-22-2013, 07:48 PM   #8432
SubieLuvin
Scooby Specialist
 
Member#: 248202
Join Date: May 2010
Chapter/Region: MWSOC
Location: Columbus, Ohio
Vehicle:
2013 WRX Sedan
SWP

Default

Quote:
Originally Posted by JustinPGH View Post

Me too... Seems like a lot of people with late January orders are starting to get details. I'm gonna call SOA again tomorrow, can't hurt!
It's lookin like dgm shouldn't be far behind this batch of swp coming
SubieLuvin is offline   Reply With Quote
Old 04-22-2013, 08:06 PM   #8433
punkNdrublic04
Scooby Newbie
 
Member#: 273621
Join Date: Feb 2011
Chapter/Region: Tri-State
Location: Ballston Lake, NY
Vehicle:
2013 WRX Limited
SWP Hatch

Default

Quote:
Originally Posted by Heedlessone View Post
I'll top that.

Bought new tires, Toyo R1R's, last season for autox. Got them mounted and drove home. When I got home, with 30 miles on my brand new tires, there was a giant bolt on the outside tread block. Right on the edge where it's not repairable. I had to order another new tire, pull my wheel off and have the shop put the new one on, again.

Now that, is bull.
Damn, that does suck...**** NAILS AND SCREWS!!!
punkNdrublic04 is online now   Reply With Quote
Old 04-22-2013, 09:09 PM   #8434
Jyu87
Scooby Newbie
 
Member#: 342040
Join Date: Dec 2012
Chapter/Region: MAIC
Vehicle:
2013 STi Hatchback
Satin White Pearl

Default

Ugh, waiting for my car to come in! Estimated date was May 6th with the ship coming in on the 26th of April! I hope it comes in early!

Does anyone know anything about the vehicle carrier vessels coming in?
Jyu87 is offline   Reply With Quote
Old 04-22-2013, 09:16 PM   #8435
inspectah
Scooby Newbie
 
Member#: 345290
Join Date: Jan 2013
Chapter/Region: NESIC
Location: Bar Harbor, ME
Vehicle:
2013 STI hatch
CBS - on order

Default

Quote:
Originally Posted by Jyu87 View Post
Ugh, waiting for my car to come in! Estimated date was May 6th with the ship coming in on the 26th of April! I hope it comes in early!

Does anyone know anything about the vehicle carrier vessels coming in?
I know that it will drive you insane.
inspectah is offline   Reply With Quote
Old 04-22-2013, 09:30 PM   #8436
OMS1
Scooby Newbie
 
Member#: 349135
Join Date: Mar 2013
Chapter/Region: MAIC
Location: 60463/15601
Vehicle:
2013 PBP WRX 5-door

Default

I just got an email from my dealer...



Currently showing "month of August"...
OMS1 is offline   Reply With Quote
Old 04-22-2013, 09:35 PM   #8437
Jyu87
Scooby Newbie
 
Member#: 342040
Join Date: Dec 2012
Chapter/Region: MAIC
Vehicle:
2013 STi Hatchback
Satin White Pearl

Default

Quote:
Originally Posted by inspectah View Post
I know that it will drive you insane.
FML. Last couple weeks have been hard to go through.
Jyu87 is offline   Reply With Quote
Old 04-22-2013, 10:42 PM   #8438
suby25
Scooby Specialist
 
Member#: 52822
Join Date: Jan 2004
Chapter/Region: NESIC
Location: Upper Valley VT
Vehicle:
1995 Impreza L Baby!
EJ20G'd and DCCD'd

Default

Quote:
Originally Posted by Jyu87 View Post
FML. Last couple weeks have been hard to go through.
Tell me about it. My car was on a boat that landed around the 18th, I feel like I've been counting every second since!
suby25 is offline   Reply With Quote
Old 04-22-2013, 10:46 PM   #8439
Scoobers
Scooby Newbie
 
Member#: 341693
Join Date: Dec 2012
Chapter/Region: MWSOC
Location: Powell, OH
Vehicle:
2013 Subaru
13 WRX SWP

Default

Quote:
Originally Posted by suby25 View Post
Tell me about it. My car was on a boat that landed around the 18th, I feel like I've been counting every second since!
1.) How do you know which boat your car is on?

2.) How long do cars sit at the port before being trucked to the dealership?
Scoobers is offline   Reply With Quote
Old 04-22-2013, 11:30 PM   #8440
CASHxMONEYxMIKE
Scooby Specialist
 
Member#: 228719
Join Date: Nov 2009
Chapter/Region: NWIC
Location: Chicago NW Suburbs
Vehicle:
2013 STi
Satin White Pearl

Default

What's funny is they tell you at the tire shop, "oh don't worry well give you 40k mile warranty on your new tires as long as the damage is on top within the tread lining" and I have never once had damage in the tread lining. This past time was the first time I got a screw stuck within the tread lining, but oh wait. Because the car sat on a flat, when they took it off it somehow started cracking the inside wall of the tire and they can't fix that. So I still got suckered into buying a new tire.
CASHxMONEYxMIKE is offline   Reply With Quote
Old 04-23-2013, 12:13 AM   #8441
inspectah
Scooby Newbie
 
Member#: 345290
Join Date: Jan 2013
Chapter/Region: NESIC
Location: Bar Harbor, ME
Vehicle:
2013 STI hatch
CBS - on order

Default

Quote:
Originally Posted by Jyu87 View Post

FML. Last couple weeks have been hard to go through.
Tell me about it. I think subarus come on nyk line ships that usually have leader at the ended of the name (ex. Artemis Leader). I could be wrong though.
inspectah is offline   Reply With Quote
Old 04-23-2013, 12:13 AM   #8442
kanakamaoli808
Scooby Newbie
 
Member#: 296303
Join Date: Sep 2011
Chapter/Region: HIIC
Location: Hawaii, Kona
Vehicle:
2013 STI Limited.
Satin White Pearl.

Default

Nice car bro super clean SWP limited im on order to for a SWP Limited today's makes 4 weeks 2days September couldn't be any closer ha-ha.

Quote:
Originally Posted by BrandonHtwo0 View Post
As promised, pictures of the new baby.

Did a hard break-in for 30 miles, then babied it for a bit with a couple WOT pulls every couple hundred miles. Engine braked after each pull. Put 1200 miles on it in 3 days (road trip from PA). RPM's never stayed the same for more than 10 seconds at a time...lots of shifting and made the trip hell lol.

But...it is sexy! And the STP exhaust is a beastly, throaty sound...


















kanakamaoli808 is offline   Reply With Quote
Old 04-23-2013, 01:49 AM   #8443
WRB13WRX
Scooby Newbie
 
Member#: 341786
Join Date: Dec 2012
Chapter/Region: South East
Location: Birmingham, AL
Vehicle:
2013 WRX Ltd. Hatch
SWP

Default

Quote:
Originally Posted by punkNdrublic04 View Post
Damn, that does suck...**** NAILS AND SCREWS!!!
I've got a dent in my drivers door on the body line...2600 miles. pissess me off. no paint damage though

Last edited by WRB13WRX; 04-23-2013 at 02:16 AM.
WRB13WRX is offline   Reply With Quote
Old 04-23-2013, 07:54 AM   #8444
suby25
Scooby Specialist
 
Member#: 52822
Join Date: Jan 2004
Chapter/Region: NESIC
Location: Upper Valley VT
Vehicle:
1995 Impreza L Baby!
EJ20G'd and DCCD'd

Default

Quote:
Originally Posted by Scoobers View Post
1.) How do you know which boat your car is on?

2.) How long do cars sit at the port before being trucked to the dealership?
1.) My dealer told me when he gave me the VIN.

2.) It depends what options are being installed at the port and what other cars are being loaded on the truck. From what I've read, one to two weeks seems typical.
suby25 is offline   Reply With Quote
Old 04-23-2013, 08:47 AM   #8445
asiago_cheese
Scooby Newbie
 
Member#: 352819
Join Date: Apr 2013
Chapter/Region: MWSOC
Location: warm and sunny Cleveland, OH
Vehicle:
2013 WRX
DGM

Default

I feel like my car is probably on the same boat. I've got a VIN but carfax shows no records, so I assume it isn't even in the US yet. Order placed 1/13 or so, standard trim DGM hatchback.
asiago_cheese is offline   Reply With Quote
Old 04-23-2013, 09:39 AM   #8446
Girion47
Scooby Newbie
 
Member#: 240113
Join Date: Mar 2010
Chapter/Region: MWSOC
Location: Louisville, KY
Vehicle:
2010 WRB WRX 5dr
2013 DGM WRX 4dr

Default

Quote:
Originally Posted by CASHxMONEYxMIKE View Post
You guys wanna hear some bull? So on Saturday i left work to go grab lunch, and I noticed my passenger rear tire was sunk down a little but not totally flat. So I rolled it back a little and saw a nail (slow leak). Filled it up and went to discount tire because they would fix it as it was under warranty. Turns out the inside sidewall was starting to ruin, so he couldn't fix that tire. And the other rear was already a little bald. So they gave me credit for the two rear and I had to buy two new tires for a car I'm getting rid of in less than a month. I'm pissed.
I've got you beat. I sold my A4 back in February. 3 DAYS before I take it to the guy buying it I have the front right tire blow out, while my subaru is in the shop to have the window and frame replaced because it had been broken into the night before and my wife's laptop/purse were stolen.

So I'm on the side of the road, with a full size spare that needs air, no cash, and my cards are all deactivated. And then the tire place wouldn't replace just one, had to be both of the front ones at the same time due to wear.
Girion47 is offline   Reply With Quote
Old 04-23-2013, 10:06 AM   #8447
CASHxMONEYxMIKE
Scooby Specialist
 
Member#: 228719
Join Date: Nov 2009
Chapter/Region: NWIC
Location: Chicago NW Suburbs
Vehicle:
2013 STi
Satin White Pearl

Default

^^^ ouch sorry to hear man.
CASHxMONEYxMIKE is offline   Reply With Quote
Old 04-23-2013, 10:17 AM   #8448
suby25
Scooby Specialist
 
Member#: 52822
Join Date: Jan 2004
Chapter/Region: NESIC
Location: Upper Valley VT
Vehicle:
1995 Impreza L Baby!
EJ20G'd and DCCD'd

Default

Quote:
Originally Posted by asiago_cheese View Post
I feel like my car is probably on the same boat. I've got a VIN but carfax shows no records, so I assume it isn't even in the US yet. Order placed 1/13 or so, standard trim DGM hatchback.
When does the first entry show up? Is it when the car leaves the port or is received by the dealer? Just looking at a sample CARFAX, the first entry is pre-delivery inspection, the second is when the vehicle is offered for sale. I guess it's not clear what triggers the entry. Regardless, time to patiently wait until I get a call from the dealer.
suby25 is offline   Reply With Quote
Old 04-23-2013, 10:28 AM   #8449
turbogc8
Scooby Specialist
 
Member#: 26540
Join Date: Oct 2002
Chapter/Region: South East
Location: Bryant, AL
Vehicle:
2001 Turbo GC8 sold
2013 DGM WRX Hatch

Default

Pretty sure I don't have enough popcorn to hold me over, only 6 weeks down today.
turbogc8 is offline   Reply With Quote
Old 04-23-2013, 11:59 AM   #8450
McBakes83
Scooby Newbie
 
Member#: 196200
Join Date: Dec 2008
Chapter/Region: TXIC
Location: El Paso, TX (Ft Bliss)
Vehicle:
2013 Impreza STi
SWP Sedan

Default

Just got my VIN and ETA!

Ordered: 2/22/13
VON: 2/23/13
1st ETA: June
2nd ETA: 5/28/13
VIN: 4/23/13

It's awesome I have an ETA, but what isn't awesome is waiting until November to be able to actually drive it. This is going to make my deployment seem that much longer.
McBakes83 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:01 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.