Welcome to the North American Subaru Impreza Owners Club Tuesday July 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Water/Methanol Injection, Nitrous & Intercooler Cooling

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-28-2013, 08:09 PM   #1
KornShaDoW097
Scooby Newbie
 
Member#: 313618
Join Date: Mar 2012
Location: South San Diego
Vehicle:
2004 WRX

Default

So I do my datalogs in 3rd now and car runs fine but when I floor it in 2nd gear the AFR jumps up and drowns the motor. I'm using an aquamist HSF2/3

So what could be the issue? Can I adjust gain, thresh or the max output to combat this or what?

My mix is 60/40 mostly water to help with cyl temps. Get lower.

It's set by the IDC rather than boost by the way. I have 1000cc injectors and 2 steps colder plugs which have helped with the temps a lot. Was putting out 396WHP and will be putting in a new intercooler with much less restriction and an EWG.

I've also heard that higher advance in tuning is required for high water mixtures, could this be causing it as well?

Jon
* Registered users of the site do not see these ads.
KornShaDoW097 is offline   Reply With Quote
Old 08-28-2013, 09:08 PM   #2
point78
Scooby Newbie
 
Member#: 344329
Join Date: Jan 2013
Location: Denver
Vehicle:
2008 Wrx, 6mt

Default

Have you tried having the water activate by boost? A little before peak torque?
point78 is offline   Reply With Quote
Old 08-29-2013, 01:33 AM   #3
KornShaDoW097
Scooby Newbie
 
Member#: 313618
Join Date: Mar 2012
Location: South San Diego
Vehicle:
2004 WRX

Default

Quote:
Originally Posted by point78 View Post
Have you tried having the water activate by boost? A little before peak torque?
No, but since my peak is way up top I would rather start it earlier to avoid knock and help spool.

I just tried reverting the IDC control to 1x since it was at 1.5x before my turbo upgrade. I'll see if this fixes it.
KornShaDoW097 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 05:48 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.