Welcome to the North American Subaru Impreza Owners Club Wednesday August 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Reviews > Car Part Reviews

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-15-2012, 09:37 PM   #1
nubs1094
Scooby Newbie
Member Sales Rating: (4)
 
Member#: 161849
Join Date: Oct 2007
Chapter/Region: Tri-State
Location: kingston/ albany NY
Vehicle:
2007 #300 of 800
bagged 94 S10 S.B.C.406

Default Whiteline HD Endlinks

These are crap. I have had them on my car for 2+ years now (07 sti), just had to replace them. They were clunking like crazy. A little embarrassing actually, very loud and people outside my car mentioned it. Replaced them with kart boy and no noise.

But Wait, There's More! (in your best infomercial voice)

They also rusted so badley into the control arm that wd40, PB blaster, heat, hammer, prybar, would not get the passenger side off. I actually drove around with the nut loosened for a few days before the vibration and harshness of road travel broke it loose. They obviously don't have salt in austrailia where whiteline is made.

On another note, I also have their sway-bars and they seem to do just fine. I painted them before install because I noticed used ones often look like the outside layer had rusted off. The paint thing seems to work well thus far after 2 winters
* Registered users of the site do not see these ads.
nubs1094 is offline   Reply With Quote
Old 08-17-2012, 12:04 AM   #2
Fierysun
Scooby Specialist
Member Sales Rating: (100)
 
Member#: 82745
Join Date: Mar 2005
Chapter/Region: SCIC
Location: So Cal
Vehicle:
2005 Subaru STI
2003 WRX Wagon

Default

Pic's?
Fierysun is offline   Reply With Quote
Old 11-08-2012, 02:14 PM   #3
1wrxtra
Scooby Specialist
Member Sales Rating: (4)
 
Member#: 316364
Join Date: Apr 2012
Chapter/Region: International
Vehicle:
2012 WRX

Default

I installed mine about a month ago and they clunk like crazy... I am going to take another look under there to see what's up.

The last time I checked I noticed that the brackets they give you to mount the bottom of the endlink to the frame were loose and jiggling back and forth when I was driving.

This time I have a bunch of washers that I'm going to install to reduce the amount of movement the bracket has... I'm hoping this fixes the issue. I greased the crap out of the bushings so I doubt they are the problem, but I don't believe it should be necessary to tighten the lock nuts every few weeks to prevent the clunks.

If this doesn't work, I'm going with the Ralliteks.

Update:
I took another look at the brackets, they don't entirely fill out the gap in the control arm where they mount. I solved the problem by jamming a stainless steel washer in between the bracket and control arm. No more movement side to side, or front to back. No more noise.

Hooray.

Last edited by 1wrxtra; 11-10-2012 at 09:47 AM. Reason: Updated
1wrxtra is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:26 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.