Welcome to the North American Subaru Impreza Owners Club Thursday August 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Reviews > Car Part Reviews

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-17-2012, 12:45 PM   #1
RobSTI89
Scooby Specialist
Member Sales Rating: (35)
 
Member#: 225268
Join Date: Sep 2009
Chapter/Region: MAIC
Location: Ohio
Vehicle:
2005 STI
WRB

Default Fast motor sports intercooler hose kit fail

I had bought these fast motor sports intercooler hose kit off a great vendor wish I could say the same about product. They were suppose to fit my 2005 Sti but hoses completely did not fit not even close. Really upset and now car is in pieces waiting for some good ones. http://i1078.photobucket.com/albums/...CA3A783A0E.jpg

http://i1078.photobucket.com/albums/...CA34802B6B.jpg
* Registered users of the site do not see these ads.
RobSTI89 is offline   Reply With Quote
Old 08-20-2012, 10:11 AM   #2
Samurai Jack
Scooby Specialist
Member Sales Rating: (4)
 
Member#: 21145
Join Date: Jul 2002
Chapter/Region: NESIC
Location: Not in my own time
Vehicle:
2002 Enemy of Aku

Default

Have you verified yet that you received the actual, correct part? Based on the first thread you started on this, you had yet to make contact with the Vendor to verify you had the correct part
Samurai Jack is offline   Reply With Quote
Old 08-24-2012, 09:54 PM   #3
RobSTI89
Scooby Specialist
Member Sales Rating: (35)
 
Member#: 225268
Join Date: Sep 2009
Chapter/Region: MAIC
Location: Ohio
Vehicle:
2005 STI
WRB

Default

Yea I did just bad fitment returned got Samcos fit perfect
RobSTI89 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:18 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.