Welcome to the North American Subaru Impreza Owners Club Sunday November 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-22-2012, 07:53 PM   #1
spazsubaru
Scooby Newbie
 
Member#: 273127
Join Date: Feb 2011
Vehicle:
2007 impreza 2.5i
Black

Default uel = cel :( help?

okay so I got my uel headers on today, sounds great nice deep and loud. but after driving for about 30-40min a cel shoots at me..so as I figured this would happen I reset the ecu hoping it wouldn't come back....came back like 10 minutes down the road..any fixes? quick fixes? I have emissions in about 3 months.

thanks in advance
* Registered users of the site do not see these ads.
spazsubaru is offline   Reply With Quote
Old 08-22-2012, 07:55 PM   #2
klaus_b2
Scooby Newbie
 
Member#: 318411
Join Date: Apr 2012
Chapter/Region: South East
Location: North Carolina
Default

borla/ebay/rallisport?
klaus_b2 is offline   Reply With Quote
Old 08-22-2012, 08:58 PM   #3
mod maniac
NASIOC Supporter
 
Member#: 300551
Join Date: Nov 2011
Chapter/Region: SCIC
Location: mariposa ca.
Vehicle:
2&4 fxt & fxt sti
Fullers Garage

Default

Code # ?
mod maniac is offline   Reply With Quote
Old 08-23-2012, 12:20 AM   #4
GrundleJuice
NASIOC Supporter
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: stupid Florida
Vehicle:
2007 No YELLING
on the bus!

Default

Are you ok? Did you shoot back?

Seriously, though.

Sorry
GrundleJuice is offline   Reply With Quote
Old 08-23-2012, 12:24 AM   #5
mustardman
Scooby Newbie
 
Member#: 258718
Join Date: Sep 2010
Location: Burbs of Chicago
Vehicle:
07 2.5i

Default

O2 spacer....come on thats day uno stuff.

If your emissions is 3months away idk you even bolted up the exhaust. I would've waited regardless.
mustardman is offline   Reply With Quote
Old 08-23-2012, 12:35 AM   #6
spazsubaru
Scooby Newbie
 
Member#: 273127
Join Date: Feb 2011
Vehicle:
2007 impreza 2.5i
Black

Default

o2 spacer? ebay uel.
spazsubaru is offline   Reply With Quote
Old 08-23-2012, 12:45 AM   #7
pho_shizzle
Scooby Specialist
 
Member#: 181064
Join Date: May 2008
Chapter/Region: BAIC
Location: Bay Area
Vehicle:
00' 2.5RS
BRP

Default

Is it a P0420? Get a 02 bung spacer dude. Should help you eliminate one problem.
pho_shizzle is online now   Reply With Quote
Old 08-23-2012, 02:43 AM   #8
spazsubaru
Scooby Newbie
 
Member#: 273127
Join Date: Feb 2011
Vehicle:
2007 impreza 2.5i
Black

Default

po420 yeah that's it. ill look into it and hope it fixes it. any specific size? brand? etc
spazsubaru is offline   Reply With Quote
Old 08-23-2012, 10:45 AM   #9
cmiovino
Scooby Guru
 
Member#: 134005
Join Date: Dec 2006
Chapter/Region: MAIC
Location: Pittsburgh, PA
Vehicle:
2004 WRX Premium
PSM

Default

Do Not Use a Rear O2 Sensor Extender Bung/Anti-Fouler/etc With a 2005+ Subaru

http://forums.nasioc.com/forums/show....php?t=2234058
cmiovino is offline   Reply With Quote
Old 08-23-2012, 02:43 PM   #10
spazsubaru
Scooby Newbie
 
Member#: 273127
Join Date: Feb 2011
Vehicle:
2007 impreza 2.5i
Black

Default

okay what should I do then?
spazsubaru is offline   Reply With Quote
Old 08-23-2012, 03:02 PM   #11
mustardman
Scooby Newbie
 
Member#: 258718
Join Date: Sep 2010
Location: Burbs of Chicago
Vehicle:
07 2.5i

Default

You can use the spacer for your emissions or go back to stock and than revert back to aftermarket or take out the spacer and you'll get the code again and who cares...it won't effect performance.
mustardman is offline   Reply With Quote
Old 08-23-2012, 05:37 PM   #12
spazsubaru
Scooby Newbie
 
Member#: 273127
Join Date: Feb 2011
Vehicle:
2007 impreza 2.5i
Black

Default

so spacer for emissions then take it off and it will be fine?
spazsubaru is offline   Reply With Quote
Old 08-23-2012, 05:44 PM   #13
Sleeper_RS
Scooby Newbie
 
Member#: 305380
Join Date: Dec 2011
Default

Or pay a local tuner to turn off the p0420 code in the computer. Only cost me 40 bucks. I have no cats, obx EL, and no check engine light
Sleeper_RS is offline   Reply With Quote
Old 08-23-2012, 06:58 PM   #14
spazsubaru
Scooby Newbie
 
Member#: 273127
Join Date: Feb 2011
Vehicle:
2007 impreza 2.5i
Black

Default

I wish there was a local tuner in my area to do that for me..
spazsubaru is offline   Reply With Quote
Old 08-23-2012, 11:55 PM   #15
mod maniac
NASIOC Supporter
 
Member#: 300551
Join Date: Nov 2011
Chapter/Region: SCIC
Location: mariposa ca.
Vehicle:
2&4 fxt & fxt sti
Fullers Garage

Default

Quote:
Originally Posted by spazsubaru View Post
I wish there was a local tuner in my area to do that for me..
[quote][/QUO

Where are you ? If you get a taxtic cable you can do it yourself with rom raider. That is how I do it.
mod maniac is offline   Reply With Quote
Old 08-24-2012, 01:23 AM   #16
spazsubaru
Scooby Newbie
 
Member#: 273127
Join Date: Feb 2011
Vehicle:
2007 impreza 2.5i
Black

Default

Quote:
Originally Posted by mod maniac
eastern connecticut away from the cities close to the border of mass. if I had a lap top with rom raider I would be so happy
spazsubaru is offline   Reply With Quote
Old 08-25-2012, 05:45 PM   #17
spazsubaru
Scooby Newbie
 
Member#: 273127
Join Date: Feb 2011
Vehicle:
2007 impreza 2.5i
Black

Default

so the only fix is having someone tune that code so it doesn't show
spazsubaru is offline   Reply With Quote
Old 08-26-2012, 01:02 AM   #18
Bababou
Scooby Newbie
 
Member#: 280689
Join Date: Apr 2011
Chapter/Region: SWIC
Location: Glendale, Az
Vehicle:
2010 2.5i Impreza
Newport blue

Default

You can try wrapping the header with header wrap. If the exhaust is not hot enough this code can show up.
Bababou is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:47 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.