Welcome to the North American Subaru Impreza Owners Club Wednesday February 10, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 09-06-2012, 10:34 PM   #1
SubieNubie88
Scooby Newbie
 
Member#: 325391
Join Date: Jul 2012
Chapter/Region: NESIC
Vehicle:
2008 WRX
OBP

Default Squeaky Belt HELP

I have a stock 2008 WRX hatch.

When the car is cold and I start it up I have a squeaky belt. It squeaks when idle and a little while driving with and without AC ON. Sound does not change with acceleration or engaging clutch. After about 25 min of driving the sound is gone when idling. Any suggestions as to which belt this might be? I'm thinking maybe a serpentine.

Any advice or suggestions would be appreciated. Especially if anyone has experienced anything similar.

Thank You
* Registered users of the site do not see these ads.
SubieNubie88 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-07-2012, 10:33 AM   #2
Samurai Jack
Scooby Specialist
 
Member#: 21145
Join Date: Jul 2002
Chapter/Region: NESIC
Location: Not in my own time
Vehicle:
2002 Enemy of Aku

Default

Sounds like you have a loose belt that needs tightening
Samurai Jack is offline   Reply With Quote
Old 09-07-2012, 11:30 AM   #3
HinshawWRX
Medium Frank
Moderator
 
Member#: 140114
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Common Sense, VA
Vehicle:
2014 Porsche
GT3 (Currently on Fire)

Default

It will be either your A/c or Power Steering belt. We cannot tell you which belt it is, we're not there to hear it.

Look at each belt, look for cracking on the ribs, or excessive wear all around. I would replace and make sure everything is properly adjusted. Belts are cheap.
HinshawWRX is offline   Reply With Quote
Old 09-07-2012, 11:50 AM   #4
UK-Wagon
Scooby Specialist
 
Member#: 232430
Join Date: Dec 2009
Chapter/Region: SCIC
Location: On the Left side
Vehicle:
555 XTi
1 AW & 1 CGM

Default

Tighten both of them.... Likely both of them need it
UK-Wagon is offline   Reply With Quote
Old 09-07-2012, 02:44 PM   #5
Paidfor
Scooby Specialist
 
Member#: 267815
Join Date: Dec 2010
Chapter/Region: South East
Location: LSx allll done..need headers
Vehicle:
Be in awe
dont hate .)

Default

Dont be to quick on jumping to the drive belts tho.........Ive had the same little minor belt squeek before too and i actually had a timing tensioner somehow break loose from the threads in the block and tilt a little. Caused the timing belt to "walk" just a hair...maybe a 1/8 inch or so. Back and forth on the pulley. Squeak squeak squeak.. Made the same damn sound, couldve sworn it was the drive belts, only did it while cold too. Only way i was able to pinpoint it was, well after i noticed that the drive belts were in great condition, made no change in sound after spraying belts with brake clean (Brake clean will temporarily stop a belt squeal if its that particular belt), i pulled the timing cover to see that bastard walkin. Fixed stripped out tensioner and t belt....all good!!!
Paidfor is offline   Reply With Quote
Old 09-07-2012, 07:46 PM   #6
SubieNubie88
Scooby Newbie
 
Member#: 325391
Join Date: Jul 2012
Chapter/Region: NESIC
Vehicle:
2008 WRX
OBP

Default

Thanks for the advice fellas ... Working on it tomorrow morning ... I'll post what the result is
SubieNubie88 is offline   Reply With Quote
Old 09-08-2012, 02:03 AM   #7
UK-Wagon
Scooby Specialist
 
Member#: 232430
Join Date: Dec 2009
Chapter/Region: SCIC
Location: On the Left side
Vehicle:
555 XTi
1 AW & 1 CGM

Default

Just now noticed you have an 08.... the AC belt on youre car is NOT adjustable, its a Gates stretch belt. They are a PITA to install
The Power steering/Alt belt IS adjustable though.
UK-Wagon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 11:12 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.