Welcome to the North American Subaru Impreza Owners Club Tuesday September 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-24-2012, 05:22 PM   #1
phreakwenci
Scooby Newbie
 
Member#: 329549
Join Date: Aug 2012
Default 2.2L 95 Impreza.. easy way to fix thermostat?!?

Just bought an 95 2 door AWD impreza 2.2L, and when highway driving it's fine, when city driving she overheats after about 35-45 mins in the summer. So.. I first let her cool all the way down, then popped the hood, took off the radiator cap and turned her on, I saw bubbles for the first 90 seconds, then almost none, so I'm not sure that it's a bad head gasket, since afterwards I squeezed the hoses and they were very squeezable and soft. I'm thinking the Thermostat, I downloaded of the internets all the impreza manuals I could find, but seriously none of them show how to change the Thermostat. I'd buy a manual, but I'm a stereotypical poor (but damn good lookin!) actor in L.A.

So is there an easy how to guide for changing the Thermo on the 2.2L somewhere I can find? Are there any bitch bolts I need to be aware of? Etc?

Any help would be appreciated.

J.D.
* Registered users of the site do not see these ads.
phreakwenci is offline   Reply With Quote
Old 08-24-2012, 05:54 PM   #2
thebeephaha
Scooby Newbie
 
Member#: 248063
Join Date: May 2010
Chapter/Region: NWIC
Location: WA
Vehicle:
2003 Forester 2.5XTi
CrossSports Sierra Gold

Default

thebeephaha is offline   Reply With Quote
Old 08-24-2012, 06:02 PM   #3
phreakwenci
Scooby Newbie
 
Member#: 329549
Join Date: Aug 2012
Default

Oh wow. THANKS! I was wondering where the hell it was!
phreakwenci is offline   Reply With Quote
Old 08-25-2012, 01:12 PM   #4
thebeephaha
Scooby Newbie
 
Member#: 248063
Join Date: May 2010
Chapter/Region: NWIC
Location: WA
Vehicle:
2003 Forester 2.5XTi
CrossSports Sierra Gold

Default

No problem.
thebeephaha is offline   Reply With Quote
Old 08-25-2012, 02:41 PM   #5
StealthTL
Scooby Newbie
 
Member#: 206912
Join Date: Mar 2009
Chapter/Region: International
Location: Waaaaay North
Vehicle:
2006 Forester XT
DGM

Default

Sad, but I don't think the symptoms fit a bad thermostat.

If the thermostat fails closed, you won't be driving anywhere after 10 minutes of warm up, and if it failed open you have no heat and the gauge never budges off 'cold'.

Your prob sounds like a plugged rad, or worn out water pump.
Look for deposits in the rad tubes....
StealthTL is offline   Reply With Quote
Old 08-25-2012, 02:48 PM   #6
97ej22e
Scooby Newbie
 
Member#: 327710
Join Date: Jul 2012
Chapter/Region: NESIC
Location: Sanford, Maine
Vehicle:
1999 Impreza OBS
Green

Default

Hmmm I wonder if my T stat is bad, my car usually stays all the way down at cold and occasionally will come up about 1/4 of the way but then goes back down. I have new head gaskets and it was doing the same before I replaced them too.
97ej22e is offline   Reply With Quote
Old 08-27-2012, 03:09 PM   #7
phreakwenci
Scooby Newbie
 
Member#: 329549
Join Date: Aug 2012
Default

OMG. Guys... I seriously can't believe this.

This is the old thermo I just took out next to the new one
http://twitter.com/JanDavidSoutar/st...445248/photo/1

The previous owner broke it and then installed it. OMFG.

I'm speechless. I also don't have a clue which way my thermostat needs to be installed! which way does the jiggle pin need to point to? East west north south?

Help!?!
phreakwenci is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:05 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.