Welcome to the North American Subaru Impreza Owners Club Saturday October 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Alaskan Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Alaskan Impreza Club Forum -- AKIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-27-2013, 10:34 PM   #1026
BackflipJeff
Scooby Newbie
 
Member#: 291485
Join Date: Aug 2011
Chapter/Region: AKIC
Vehicle:
2007 Wrx wagon
Satin white

Default

New turbo new intercooler new uppipe thanks to Katelyn for helping with that part and front sway and some subframe bolts. Big thanks to Henry for helping me the entire way and thanks to retrac for helping me along with some parts.
* Registered users of the site do not see these ads.
BackflipJeff is offline   Reply With Quote
Old 01-27-2013, 11:55 PM   #1027
insane_one
Scooby Specialist
 
Member#: 301431
Join Date: Nov 2011
Chapter/Region: AKIC
Location: Anchorage, AK
Default

what kind of turbo?
insane_one is offline   Reply With Quote
Old 01-27-2013, 11:57 PM   #1028
BackflipJeff
Scooby Newbie
 
Member#: 291485
Join Date: Aug 2011
Chapter/Region: AKIC
Vehicle:
2007 Wrx wagon
Satin white

Default

Just a vf39.
BackflipJeff is offline   Reply With Quote
Old 01-28-2013, 01:30 AM   #1029
Racer Dubya
some old guy
Moderator
 
Member#: 112225
Join Date: Apr 2006
Chapter/Region: AKIC
Location: Anchorage
Vehicle:
1985 78 HP of Rage!
Blue

Default

Finished putting together my EA81 long block.

Rocker Arms


A shot of the push rods
Racer Dubya is offline   Reply With Quote
Old 01-28-2013, 01:32 AM   #1030
insane_one
Scooby Specialist
 
Member#: 301431
Join Date: Nov 2011
Chapter/Region: AKIC
Location: Anchorage, AK
Default

Quote:
Originally Posted by BackflipJeff View Post
Just a vf39.
Nice!
insane_one is offline   Reply With Quote
Old 01-28-2013, 02:50 AM   #1031
cosseywrx
Scooby Specialist
 
Member#: 276443
Join Date: Mar 2011
Chapter/Region: TXIC
Location: Abilene, TX
Vehicle:
2005 2.1 stroker WRX
OBP

Default

well dipstick blew on the way back to the Fbanks!!


so when i got home i installed some kstech goodie!
cosseywrx is offline   Reply With Quote
Old 01-28-2013, 07:02 AM   #1032
BackflipJeff
Scooby Newbie
 
Member#: 291485
Join Date: Aug 2011
Chapter/Region: AKIC
Vehicle:
2007 Wrx wagon
Satin white

Default

Quote:
Originally Posted by insane_one View Post

Nice!
Oh yea except for the knock issue I'm having at the moment the Cobb ap tune isn't quite right for me I guess so can't really have any fun yet.
BackflipJeff is offline   Reply With Quote
Old 01-28-2013, 12:28 PM   #1033
insane_one
Scooby Specialist
 
Member#: 301431
Join Date: Nov 2011
Chapter/Region: AKIC
Location: Anchorage, AK
Default

Quote:
Originally Posted by BackflipJeff View Post
Oh yea except for the knock issue I'm having at the moment the Cobb ap tune isn't quite right for me I guess so can't really have any fun yet.
i know how that goes

ive gotta get a better tune for my setup aswell. Cobb AP OTS maps just wont cut it.



Cossey- what caused your dipstick to blow like that?
insane_one is offline   Reply With Quote
Old 01-28-2013, 02:23 PM   #1034
kayetealynn
Scooby Specialist
 
Member#: 253304
Join Date: Jul 2010
Chapter/Region: AKIC
Location: Eagle River, AK
Vehicle:
2001 Impreza 2.5RS
Plus MOAR

Default

Quote:
Originally Posted by insane_one View Post

i know how that goes

ive gotta get a better tune for my setup aswell. Cobb AP OTS maps just wont cut it.

Cossey- what caused your dipstick to blow like that?
Frozen PCV valve.
kayetealynn is offline   Reply With Quote
Old 01-28-2013, 02:27 PM   #1035
chanomatik
NASIOC Supporter
 
Member#: 159474
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchorage (...for now...)
Vehicle:
2013 BRZ Ltd 6MT CBS
SNOSLO

OMGHi2U Not Me for the Day

Detailed it, for the most part. Nice wash and dry at Mt. View car wash yesterday.

Today I vacuumed the seats, floor and trunk mat, wiped down the entire interior, including door panels and trunk mat, and cleaned out the cupholder.

I'm letting my buddy borrow it for the day while he takes his wife out for their anniversary. Be sure to wave if you see them driving around!
chanomatik is offline   Reply With Quote
Old 01-28-2013, 03:18 PM   #1036
cosseywrx
Scooby Specialist
 
Member#: 276443
Join Date: Mar 2011
Chapter/Region: TXIC
Location: Abilene, TX
Vehicle:
2005 2.1 stroker WRX
OBP

Default

Its because i had a scoop and no tmic. Lines froze.

Fixed with plate delete. -51 does **** to cars
cosseywrx is offline   Reply With Quote
Old 01-28-2013, 11:27 PM   #1037
cosseywrx
Scooby Specialist
 
Member#: 276443
Join Date: Mar 2011
Chapter/Region: TXIC
Location: Abilene, TX
Vehicle:
2005 2.1 stroker WRX
OBP

Default

Well all oil was cleaned up the best i can in these cold conditions!!!! Lost about 1qt of oil. Being scoopless should vastly improve that problem from happening.
cosseywrx is offline   Reply With Quote
Old 01-28-2013, 11:58 PM   #1038
Nomadgene
Scooby Guru
 
Member#: 22923
Join Date: Aug 2002
Chapter/Region: International
Location: above 8000 rpm!
Vehicle:
2002 EJ207 V8 1.5xtr
TWIN-SCROLL Black Bugeye

Default

Where'd it happen Cossey? Was it past Cantwell? Healey? or Nenana?
Nomadgene is offline   Reply With Quote
Old 01-29-2013, 12:16 AM   #1039
Dominator
NASIOC Supporter
 
Member#: 156712
Join Date: Aug 2007
Chapter/Region: AKIC
Location: Fairbanks, Alaska
Vehicle:
1991 Legacy SS
Pearl White

Default

From what he told me, he thought it was as he was getting into Fairbanks. I met up with him for the parts, just inside of town, and he just found it.
Dominator is offline   Reply With Quote
Old 01-29-2013, 12:19 AM   #1040
Nomadgene
Scooby Guru
 
Member#: 22923
Join Date: Aug 2002
Chapter/Region: International
Location: above 8000 rpm!
Vehicle:
2002 EJ207 V8 1.5xtr
TWIN-SCROLL Black Bugeye

Default

Glad to hear you got your stuff Dom. Curious to hear more first hand details.
Nomadgene is offline   Reply With Quote
Old 01-29-2013, 12:44 AM   #1041
AKSubieDubie
Scooby Specialist
 
Member#: 190003
Join Date: Sep 2008
Chapter/Region: AKIC
Location: Fairbanks Alaska
Vehicle:
2007 STI EFR 8374
Black

Default

Update on Battery gig:

Well it was -49F ish when i parked the car at UAF.

It warmed up to -40F for a couple hours before I finally got out of lab at 5-6pm - It WAS plugged in since I parked it at 9am though. UAF cycles their plug ins off/on every 15 minutes - I checked my autostart for inside temp and it registered -39F.

Hit start, and it started up just fine. I don't think capacity is a problem when it's this cold and have things set up right

Isaac
AKSubieDubie is offline   Reply With Quote
Old 01-29-2013, 12:55 AM   #1042
_davin
Scooby Specialist
 
Member#: 260501
Join Date: Oct 2010
Chapter/Region: AKIC
Location: Anchorage, Alaska
Vehicle:
2011 WRX 5dr SWP Ltd

Default

15 minutes? Did people complain enough, I swear it used to be at least an hour if not two.
_davin is offline   Reply With Quote
Old 01-29-2013, 01:39 AM   #1043
Nomadgene
Scooby Guru
 
Member#: 22923
Join Date: Aug 2002
Chapter/Region: International
Location: above 8000 rpm!
Vehicle:
2002 EJ207 V8 1.5xtr
TWIN-SCROLL Black Bugeye

Default

Shakedown complete. Let the tuning begin.
Nomadgene is offline   Reply With Quote
Old 01-29-2013, 02:22 AM   #1044
snowdrift86
Scooby Newbie
 
Member#: 273920
Join Date: Feb 2011
Chapter/Region: AKIC
Location: Wasilla
Vehicle:
05 Legacy GT
Regal Blue Pearl

Default

DCCD controller finally installed and operating! So happy to have awd and now the roads are dry again ! Wish i knew how to post pics so i can show it off. But alas I am a newb at such things
snowdrift86 is offline   Reply With Quote
Old 01-29-2013, 11:15 AM   #1045
nasiocjunkie
Scooby Specialist
 
Member#: 80864
Join Date: Feb 2005
Chapter/Region: AKIC
Location: Anchorage, Alaska
Vehicle:
I'll have the tuna.
No crust.

Default

Quote:
Originally Posted by Dominator View Post
That sounds really cool! You better take some photos and show us the process. Should be a pretty cool legacy when you're done with it.
Day after install.


Parking lot 4xing.



6 coats of plasti dip over 2 coats of primer (bonds and holds better vs just bare rim). Rear sits higher than front with an empty trunk with no spare and sits close to level still no ass sag with a full trunk of tools.
nasiocjunkie is offline   Reply With Quote
Old 01-29-2013, 11:46 AM   #1046
retrac
Scooby Specialist
 
Member#: 217208
Join Date: Jul 2009
Chapter/Region: AKIC
Location: Alaska
Vehicle:
996 Porsche 911
Seal Gray

Default

Quote:
Originally Posted by nasiocjunkie View Post
Day after install.


Parking lot 4xing.



6 coats of plasti dip over 2 coats of primer (bonds and holds better vs just bare rim). Rear sits higher than front with an empty trunk with no spare and sits close to level still no ass sag with a full trunk of tools.
Looks like you need Forester trailing arm brackets to move the rear wheel back to the proper position.
retrac is offline   Reply With Quote
Old 01-29-2013, 12:32 PM   #1047
Nomadgene
Scooby Guru
 
Member#: 22923
Join Date: Aug 2002
Chapter/Region: International
Location: above 8000 rpm!
Vehicle:
2002 EJ207 V8 1.5xtr
TWIN-SCROLL Black Bugeye

Default

Quote:
Originally Posted by snowdrift86 View Post
DCCD controller finally installed and operating! So happy to have awd and now the roads are dry again ! Wish i knew how to post pics so i can show it off. But alas I am a newb at such things
Which controller did you go with?

Set up a photo bucket or similar picture hosting site account. Upload your photos and then copy the URL to the message box.
Nomadgene is offline   Reply With Quote
Old 01-29-2013, 01:47 PM   #1048
insane_one
Scooby Specialist
 
Member#: 301431
Join Date: Nov 2011
Chapter/Region: AKIC
Location: Anchorage, AK
Default

Quote:
Originally Posted by nasiocjunkie View Post
Day after install.


6 coats of plasti dip over 2 coats of primer (bonds and holds better vs just bare rim). Rear sits higher than front with an empty trunk with no spare and sits close to level still no ass sag with a full trunk of tools.
That looks freakin awesome!!
insane_one is offline   Reply With Quote
Old 01-29-2013, 01:59 PM   #1049
nasiocjunkie
Scooby Specialist
 
Member#: 80864
Join Date: Feb 2005
Chapter/Region: AKIC
Location: Anchorage, Alaska
Vehicle:
I'll have the tuna.
No crust.

Default

Quote:
Originally Posted by retrac View Post
Looks like you need Forester trailing arm brackets to move the rear wheel back to the proper position.
Just phoned Dooley and should have a set to pickup tomarrow. Forester trailing arms are installed already and the brackets should complete the rears being centered.

Quote:
Originally Posted by insane_one View Post
That looks freakin awesome!!
Ur rims would make moar awesome! Still sitting on it btw...
nasiocjunkie is offline   Reply With Quote
Old 01-29-2013, 03:22 PM   #1050
Dominator
NASIOC Supporter
 
Member#: 156712
Join Date: Aug 2007
Chapter/Region: AKIC
Location: Fairbanks, Alaska
Vehicle:
1991 Legacy SS
Pearl White

Default

Looks awesome Nasiocjunkie!
Dominator is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:51 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.