Welcome to the North American Subaru Impreza Owners Club Monday November 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > AccessPort

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-31-2012, 01:30 AM   #1
martinez801
Scooby Newbie
 
Member#: 295702
Join Date: Sep 2011
Chapter/Region: RMIC
Location: SLC,UT
Vehicle:
2004 2004 WRX
WRB

Default accesport reading my 04 wrx as an 02-03?

Ive tried 3 different accesports and it keeps reading my 04 wrx as an 02-03? anybody know what the situation might be? would it matter if i plug in the 02-03 maps?

thanks in advance
* Registered users of the site do not see these ads.
martinez801 is offline   Reply With Quote
Old 08-31-2012, 06:24 AM   #2
jebjkey
Scooby Specialist
 
Member#: 73884
Join Date: Nov 2004
Chapter/Region: International
Location: Naples, ITALY
Vehicle:
2005 STi
2006 Evolution MR

Default

Some assumptions I am making here:
You purchased an 04 WRX AP v2(b)
The other AP's you tried were appropriated for an 04 WRX
Your ECU is unmarried to any AP and you are trying to install and OTS Cobb map (stage 1 I am guessing)


Did you buy your car used?

Does it have an 04 ECU? [You can check the designation numbers on the actual ECU under the passenger carpet in the footwell. The number designation will tell you what it is supposed to be but it will not tell you what is programmed on the inside. It would not be the first time someone had to swap an ECU.]

Did a previous owner ruin the original ECU and replace it with an 02/03? [Not sure if this would work though]

Did a previous owner use open source tuning to flash an 02/03 map in the ECU? [Not sure if this would work either, but if so you could do the same to put an 04 map back in the ECU]

Not sure about any differences in the AP's between 02/03 and 04, when Cobb chimes in they can cover the AP specifically.

Last edited by jebjkey; 08-31-2012 at 06:33 AM.
jebjkey is offline   Reply With Quote
Old 08-31-2012, 09:58 AM   #3
Cobb Tuning
NASIOC Vendor
 
Member#: 4803
Join Date: Mar 2001
Location: Austin, DFW, Portland, SOCAL
Default

Quote:
Originally Posted by martinez801 View Post
Ive tried 3 different accesports and it keeps reading my 04 wrx as an 02-03? anybody know what the situation might be? would it matter if i plug in the 02-03 maps?

thanks in advance
Assuming this is a version 2 AccessPORT, then likely the ECU in your car has been swapped with an 02 or 03 ECU (which is possible in an 04 or 05 WRX). It should not be possible to reflash an 02 or 03 WRX ECU image on to an 04 or 05 ECU.

The AccessPORT checks the ECU identifier before it installs, so this is the only explanation as to why it wants to install as 02/03 ECU on your 04 WRX. As far as I know, others have run an 02/03 ECU in 04/05 WRX before without issue, so you will probably be fine (especially if you've had no issues since you've had the car). If you can take a picture of the top of the ECU and post it, we can confirm what ECU is in the car.

Bill
Cobb Tuning is offline   Reply With Quote
Old 09-01-2012, 02:35 AM   #4
martinez801
Scooby Newbie
 
Member#: 295702
Join Date: Sep 2011
Chapter/Region: RMIC
Location: SLC,UT
Vehicle:
2004 2004 WRX
WRB

Default

yea i bought it used. not sure if they might of put an 02-03 ecu. will try to get a pic of it. i appreciate your guys input. thanks
martinez801 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:09 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.