Welcome to the North American Subaru Impreza Owners Club Thursday July 10, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-01-2012, 08:28 PM   #1
NDS1521
Scooby Newbie
 
Member#: 269920
Join Date: Jan 2011
Location: Spokane
Vehicle:
04 wrx

Default ecuflash help

I recently purchased an 02 wrx that needed some fine tuning. It came with a tactrix, so I emailed a tuner with good reviews got the initial Rom but cannot load it. The error code every time is kernal get version. So far I have tried two diff cables, two diff USB cords, two diff laptops, one with windows 7 and one with xp. I am out of ideas. I have to get these injectors scaled or I will not pass emissions. Would them to get a reading from my obd2 port count that out as a possible problem?
* Registered users of the site do not see these ads.
NDS1521 is offline   Reply With Quote
Old 09-01-2012, 09:09 PM   #2
ProfessWRX
Scooby Specialist
 
Member#: 323379
Join Date: Jun 2012
Vehicle:
06 WRX

Default

Did you get one of those green jumpers? I don't know your year but some years need them. Tactrix sells them for the openport.
ProfessWRX is online now   Reply With Quote
Old 09-01-2012, 10:24 PM   #3
NDS1521
Scooby Newbie
 
Member#: 269920
Join Date: Jan 2011
Location: Spokane
Vehicle:
04 wrx

Default

Yes I have the jumper and flash block. I have an 02 wrx
NDS1521 is offline   Reply With Quote
Old 09-01-2012, 10:35 PM   #4
NDS1521
Scooby Newbie
 
Member#: 269920
Join Date: Jan 2011
Location: Spokane
Vehicle:
04 wrx

Default

Also romraider and learningview work just not ecu flash.
NDS1521 is offline   Reply With Quote
Old 09-02-2012, 02:29 PM   #5
NDS1521
Scooby Newbie
 
Member#: 269920
Join Date: Jan 2011
Location: Spokane
Vehicle:
04 wrx

Default

Bump for answers
NDS1521 is offline   Reply With Quote
Old 09-02-2012, 04:15 PM   #6
NDS1521
Scooby Newbie
 
Member#: 269920
Join Date: Jan 2011
Location: Spokane
Vehicle:
04 wrx

Default

Would having maps sent for an 02 ecu when I actually have an 05 ecu be the problem? I just seen in learning view that this car is reading for an 05 ecu which I was never told when purchasing it.
NDS1521 is offline   Reply With Quote
Old 09-02-2012, 04:25 PM   #7
quazimoto
Scooby Guru
 
Member#: 70395
Join Date: Sep 2004
Chapter/Region: MAIC
Location: Da-boonies,Va
Default

That could be a problem. Or you don't have the latest Ecuflash definitions. Not to mention there are about 500 posts on people having issues with Ecuflash.
quazimoto is offline   Reply With Quote
Old 09-02-2012, 04:51 PM   #8
sidewayz
Scooby Specialist
 
Member#: 5810
Join Date: Apr 2001
Chapter/Region: Tri-State
Location: Easton PA
Vehicle:
2001 S366 2.5RS

Default

If you are trying to flash an 02 rom onto a 05 rom it will not connect.
sidewayz is offline   Reply With Quote
Old 09-02-2012, 05:42 PM   #9
chappell943
Scooby Newbie
 
Member#: 297718
Join Date: Oct 2011
Chapter/Region: International
Location: New Zealand
Vehicle:
2001 V7 Sti Prodrive
White

Default

If you are getting an etune the most ideal way is to download your stock rom off your ecu and send that to the tuner.
chappell943 is offline   Reply With Quote
Old 09-02-2012, 08:39 PM   #10
NDS1521
Scooby Newbie
 
Member#: 269920
Join Date: Jan 2011
Location: Spokane
Vehicle:
04 wrx

Default

Yea I found out the initialization process is way different. I should have sent the Rom to him first and it would have been seen probably much sooner. Oh well lesson learned. I'll post back when I get my Rom to verify that was the only problem.
NDS1521 is offline   Reply With Quote
Old 09-08-2012, 08:49 PM   #11
end_of_silence
Scooby Newbie
 
Member#: 85565
Join Date: Apr 2005
Location: Finksburg, MD
Vehicle:
2002 Goon Project
95 Neon Sport RX beater

Default

I had this issue this morning after trying to get the base rom for the first time. I thought that all I had to do for my 02 was connect the jumper. However, I had to have the jumper in place and have the green plugs connected to get the ECU into test mode. Timing the click of "ok" and turning the ignition to "on" was crucial as well. Once I figured that out, smooth sailing. Good luck!
end_of_silence is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:54 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.