Welcome to the North American Subaru Impreza Owners Club Saturday September 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Proven Power Bragging

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-13-2012, 06:33 PM   #1
Shortpersonbk
Scooby Specialist
 
Member#: 319017
Join Date: May 2012
Chapter/Region: MWSOC
Location: Michigan
Vehicle:
12 slow sti 6266 e
595/450

Default Track time any tips for future? slow :(

2012 sti
basic stg 2 ..cobb intake down pipe nameless cat back..launching at 3,500
tuned for 21 pounds by Torqued Performance

I feel like i should be running alot quicker where do you guys think i am loosing all my time at. MY current theory is aside from me launching bad i left traction control on for my runs at the bottom of 2nd it puts the brakes on pretty hard for a short period of time but i would think it would not hurt me that bad if there is a reason for it to put the brakes on. Thank you guys for taking a look.
* Registered users of the site do not see these ads.
Shortpersonbk is online now   Reply With Quote
Old 10-13-2012, 06:45 PM   #2
masayver
Scooby Newbie
 
Member#: 176021
Join Date: Mar 2008
Chapter/Region: MWSOC
Location: Chicago, IL
Vehicle:
2011 Impreza WRX
Lighting Red

Default

You're sure your car isn't pulling any timing? Have you logged your car?
masayver is offline   Reply With Quote
Old 10-13-2012, 06:50 PM   #3
Shortpersonbk
Scooby Specialist
 
Member#: 319017
Join Date: May 2012
Chapter/Region: MWSOC
Location: Michigan
Vehicle:
12 slow sti 6266 e
595/450

Default

Quote:
Originally Posted by masayver View Post
You're sure your car isn't pulling any timing? Have you logged your car?
I have during the E-Tune process which was only a couple weeks before this and most of my logs were during the mid day alot hotter then that night so that thought never came to my mind. I guess my main thing is i am not the best driver so i more or less don't want to blame a tune until i know its that if you know what i mean. Does anything scream driver error?
Shortpersonbk is online now   Reply With Quote
Old 10-13-2012, 06:53 PM   #4
BmoreSti
Scooby Newbie
 
Member#: 230719
Join Date: Nov 2009
Chapter/Region: MAIC
Location: Baltimore, Maryland
Vehicle:
2005 Sti Andrewtech
& TurboXS FTW

Default

First issues is your launching at 3,500. Set launch control higher. Start off at 5K, slip the clutch to you feel a little move and get your foot of the clutch like you just stepped in dog poop. I cut 1.69s or better on all seasons
BmoreSti is offline   Reply With Quote
Old 10-13-2012, 07:03 PM   #5
Shortpersonbk
Scooby Specialist
 
Member#: 319017
Join Date: May 2012
Chapter/Region: MWSOC
Location: Michigan
Vehicle:
12 slow sti 6266 e
595/450

Default

Quote:
Originally Posted by BmoreSti View Post
First issues is your launching at 3,500. Set launch control higher. Start off at 5K, slip the clutch to you feel a little move and get your foot of the clutch like you just stepped in dog poop. I cut 1.69s or better on all seasons
I like my car in one piece...maybe next time i will try a 5k launch do you think its all in the launch thats giving me such a slow time?
Shortpersonbk is online now   Reply With Quote
Old 10-13-2012, 07:12 PM   #6
BmoreSti
Scooby Newbie
 
Member#: 230719
Join Date: Nov 2009
Chapter/Region: MAIC
Location: Baltimore, Maryland
Vehicle:
2005 Sti Andrewtech
& TurboXS FTW

Default

Im on stock trans, diff, axles and have launch my car close to 200 times. I have a 6 puck clutch also. I have not broken one thing on the car. FWD cars launch higher then 3,500

You have a Sti trans, let it rip!
BmoreSti is offline   Reply With Quote
Old 10-13-2012, 07:14 PM   #7
Shortpersonbk
Scooby Specialist
 
Member#: 319017
Join Date: May 2012
Chapter/Region: MWSOC
Location: Michigan
Vehicle:
12 slow sti 6266 e
595/450

Default

Quote:
Originally Posted by BmoreSti View Post
Im on stock trans, diff, axles and have launch my car close to 200 times. I have a 6 puck clutch also. I have not broken one thing on the car. FWD cars launch higher then 3,500

You have a Sti trans, let it rip!
Alright i guess i will next time...whats your suggestion on traction control?
Shortpersonbk is online now   Reply With Quote
Old 10-13-2012, 07:18 PM   #8
BmoreSti
Scooby Newbie
 
Member#: 230719
Join Date: Nov 2009
Chapter/Region: MAIC
Location: Baltimore, Maryland
Vehicle:
2005 Sti Andrewtech
& TurboXS FTW

Default


that was a 1.66 60ft

I have a 05, i leave my dccd to auto.
BmoreSti is offline   Reply With Quote
Old 10-13-2012, 07:21 PM   #9
Dave D.
Scooby Specialist
 
Member#: 130990
Join Date: Nov 2006
Chapter/Region: NWIC
Location: Menzel Lake, WA
Vehicle:
06 Red Ltd.Wagon
I need a new tuner!

Default

Quote:
Originally Posted by BmoreSti View Post
BmoreSti first time back at track - YouTube

that was a 1.66 60ft

I have a 05, i leave my dccd to auto.
What was your time and trap? Don't leave us hanging.
Dave D. is offline   Reply With Quote
Old 10-13-2012, 07:24 PM   #10
BmoreSti
Scooby Newbie
 
Member#: 230719
Join Date: Nov 2009
Chapter/Region: MAIC
Location: Baltimore, Maryland
Vehicle:
2005 Sti Andrewtech
& TurboXS FTW

Default

Hahah that was a no time run

That pass a 12.48@108 on 17psi. Spent about 2 hours tuning it after the motor break in. Getting retuned the last week of the month with the new goodies
BmoreSti is offline   Reply With Quote
Old 10-13-2012, 07:26 PM   #11
BmoreSti
Scooby Newbie
 
Member#: 230719
Join Date: Nov 2009
Chapter/Region: MAIC
Location: Baltimore, Maryland
Vehicle:
2005 Sti Andrewtech
& TurboXS FTW

Default

I was wrong that was a 1.68. the other pass was a 1.66 Sorry
BmoreSti is offline   Reply With Quote
Old 10-13-2012, 07:29 PM   #12
CatfaceType-R
Scooby Guru
 
Member#: 81102
Join Date: Feb 2005
Chapter/Region: MWSOC
Location: I sell platinum cat jewelry.co
Default

Shift earlier, redline 1-2, 3rd to 5900, 4th to 5800.

Quick, not fast. 2.5 liter +vf series is dead in late rpm.
CatfaceType-R is offline   Reply With Quote
Old 10-13-2012, 07:33 PM   #13
Shortpersonbk
Scooby Specialist
 
Member#: 319017
Join Date: May 2012
Chapter/Region: MWSOC
Location: Michigan
Vehicle:
12 slow sti 6266 e
595/450

Default

ahh i was pulling till like 6800...i never even thought about shifting lower...i time a couple street pulls when the weather gets better to see how much that helps but your saying pull 4th to 5800 don't rev it out till the end? With this year sti i would have figured at least in 4th to pull it all the way out endstead of shift because the gear allows it to not need to use 5th in the 1/4th without running what like 115ish....
Shortpersonbk is online now   Reply With Quote
Old 10-13-2012, 08:34 PM   #14
arod35
Scooby Newbie
 
Member#: 328822
Join Date: Aug 2012
Default

Turn traction control off. That **** is killing you
arod35 is offline   Reply With Quote
Old 10-13-2012, 08:37 PM   #15
darex11
Scooby Newbie
 
Member#: 282465
Join Date: May 2011
Vehicle:
2011 STI
Red

Default

You should be fine launching higher especially in an sti. I went to the track last night in my 2011 wrx and started at 4500 rpms and tweaked it from there. My best was launching from 6300 rpms but I was going easy on the clutch, the dog poop theory seems to work pretty good. My transmission felt fine I only managed a 13.72 myself but I still have work to do. I think I could use a bigger intercooler for sure!
darex11 is offline   Reply With Quote
Old 10-15-2012, 10:18 AM   #16
CatfaceType-R
Scooby Guru
 
Member#: 81102
Join Date: Feb 2005
Chapter/Region: MWSOC
Location: I sell platinum cat jewelry.co
Default

Quote:
Originally Posted by Shortpersonbk View Post
ahh i was pulling till like 6800...i never even thought about shifting lower...i time a couple street pulls when the weather gets better to see how much that helps but your saying pull 4th to 5800 don't rev it out till the end? With this year sti i would have figured at least in 4th to pull it all the way out endstead of shift because the gear allows it to not need to use 5th in the 1/4th without running what like 115ish....
Nope, shift early. The car is out of torque at that rpm in higher gears. The only reason you redline 1&2 is the mechanical advantage in gearing.

Shoot me a pm if u need more help, this stuff I know, ask almost anyone here. Drag racing is my game.
CatfaceType-R is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:20 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.