Welcome to the North American Subaru Impreza Owners Club Saturday August 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-11-2012, 02:41 AM   #51
Concillian
Scooby Guru
 
Member#: 4414
Join Date: Feb 2001
Location: Dublin, CA
Vehicle:
2002 WRX Sedan
Midnight Black

Default

Intake mani to TGV is a gasket, as is TGV to intake ports on the head.
Fuel injector seat o-rings are another possible leak spot.
BPV could be leaking by back into inlet

Exhaust leak pre-turbo would be screeching LOUD. Banshee wail / whistling sound.
Not screeching = intake tract.

You need to pressurize the intake tract. Not going to find boost leaks easy without pressure and / or smoke.
* Registered users of the site do not see these ads.
Concillian is offline   Reply With Quote
Old 10-26-2012, 12:15 AM   #52
UncleSchnitty
Scooby Newbie
 
Member#: 298703
Join Date: Oct 2011
Chapter/Region: Tri-State
Location: Philadelphia PA
Vehicle:
2004 Wrx
Blue

Default

Just to update anyone who cares. The rattle that I was hearing was a bearing going. The po must not have changed oil and or beat the hell out of it. New motor is being put in next week so that should give me all my power back. Thank you all for your help though
UncleSchnitty is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:24 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.