Welcome to the North American Subaru Impreza Owners Club Tuesday July 7, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-16-2012, 07:08 PM   #126
Dillinja666
Scooby Newbie
 
Member#: 332644
Join Date: Sep 2012
Chapter/Region: SCIC
Location: A whales Vagina
Vehicle:
07 STI
It's white

Default

wow....all that for a blown motor. It didnt sound werid to you when it was cranking?
* Registered users of the site do not see these ads.
Dillinja666 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-16-2012, 07:26 PM   #127
deanorbust
Scooby Specialist
 
Member#: 186025
Join Date: Aug 2008
Chapter/Region: Tri-State
Location: Levittown, NY
Vehicle:
2005 STI
CGM

Default

Quote:
Originally Posted by Dillinja666
wow....all that for a blown motor. It didnt sound werid to you when it was cranking?
It cranked fine and didn't start. Sounded like if your battery wasn't getting enough voltage. The timing belt also was not good
deanorbust is offline   Reply With Quote
Old 10-16-2012, 07:32 PM   #128
Dillinja666
Scooby Newbie
 
Member#: 332644
Join Date: Sep 2012
Chapter/Region: SCIC
Location: A whales Vagina
Vehicle:
07 STI
It's white

Default

Jeez, well these are the things that asking for help on the internet can't help. A seasoned mechanic might have been like woa woa woa, lets have a look at that motor before we go crazy with electrical if he was actually there in person. Like someone above said you have to start with the basics.

I'm glad you figured it out and are gonna get it up and running, congrats on solving the puzzle.
Dillinja666 is offline   Reply With Quote
Old 10-16-2012, 07:51 PM   #129
some dude
Scooby Specialist
 
Member#: 100300
Join Date: Nov 2005
Chapter/Region: MWSOC
Location: MIC|-|IG/\N
Vehicle:
06 WRX
CGM

Default

Sounds like a New Jersey homicide detective dicked you over haarrrddd.
some dude is offline   Reply With Quote
Old 10-16-2012, 07:57 PM   #130
perez8608
Scooby Newbie
 
Member#: 249852
Join Date: Jun 2010
Chapter/Region: NESIC
Location: canton ma
Vehicle:
1998 2.5rs
blue ridge pearl

Default

Not everyone can tell what a motor sounds like with no compression but you had originally posted that you had no spark. What did they find with that? As the other guy stated a seasoned tech can tell the difference between a motor with no compression and one that has so that's easy enough. Sucks for you but a fairly easy diagnosis. I'm curious about the no spark issue.
perez8608 is offline   Reply With Quote
Old 10-17-2012, 03:44 AM   #131
DHRDAN
Scooby Specialist
 
Member#: 204358
Join Date: Feb 2009
Chapter/Region: SCIC
Location: Santa Paula, CA.
Vehicle:
01 2.5RS W/ EJ257
Black

Default

This thread is the exact reason morons shouldn't buy used cars.


this owner talked **** forever because he has no idea what he was getting into... then he finds out he has a blown motor cause he wants to cheap out.


i'm not surprised... and i'm really laughing at this idiot. good job moron... in 2 years you're going to need another engine.
DHRDAN is offline   Reply With Quote
Old 10-17-2012, 06:46 AM   #132
deanorbust
Scooby Specialist
 
Member#: 186025
Join Date: Aug 2008
Chapter/Region: Tri-State
Location: Levittown, NY
Vehicle:
2005 STI
CGM

Default

Alright mods can close and delete this thread nothing but just awesome opinions like this fine gentlemen above.
deanorbust is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:21 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.