Welcome to the North American Subaru Impreza Owners Club Thursday September 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-07-2013, 03:33 PM   #1
VERSION7
Scooby Newbie
 
Member#: 306038
Join Date: Jan 2012
Default Po171 maf issues

So i get a po171 code.. Naturally thought i had a leak... Went through the car with a can of brake clean, no leaks found. Im going to pressure test it at work tonight. Anyway im starting to think my maf is bad. I plug my scan tool in and its reading 2.4-2.7 g/s however i have nothing to compare that too..I've been searching this forum for the last hour trying to find what the maf readings should be but no such luck. Any help would be greatly appreciated. Thanks
* Registered users of the site do not see these ads.
VERSION7 is offline   Reply With Quote
Old 02-07-2013, 06:45 PM   #2
VERSION7
Scooby Newbie
 
Member#: 306038
Join Date: Jan 2012
Default

Anybody?
VERSION7 is offline   Reply With Quote
Old 02-07-2013, 07:04 PM   #3
super_usdm
Scooby Specialist
 
Member#: 286211
Join Date: Jun 2011
Chapter/Region: BAIC
Location: Sacramento, CA
Vehicle:
2003 WRX
1993 Legacy SS

Default

Sounds like you're on the right track. I assume youve read through this..

http://forums.nasioc.com/forums/showthread.php?t=475620

It's hard to hit all the possible leak spots with brake cleaner (I think youre supposed to use starter fluid or carb cleaner- not sure about brake). I got a smoke test done and found a leak at my PCV valve that I never would have spotted otherwise.
super_usdm is offline   Reply With Quote
Old 02-07-2013, 08:00 PM   #4
VERSION7
Scooby Newbie
 
Member#: 306038
Join Date: Jan 2012
Default

Thank you! I seriously dont know how i didnt find that??? My search sucks from my iphone i guess it was bring my up a bunch of random threads with po171 in them but no info that helped. Thanks again.
VERSION7 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:51 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.